Information in this document is subject to change without notice and does not represent a commitment on the part of Microsoft Corporation. The software described in this document is furnished under a license agreement or nondisclosure agreement. The software may be used or copied only in accordance with the terms of the agreement. It is against the law to copy this software on magnetic tape, disk, or any other medium for any purpose other than the purchaser's personal use.

Copyright Microsoft Corporation, 1985

Microsoft, the Microsoft logo, and XENIX are registered trademarks, and The High Performance Software is a trademark of Microsoft Corporation.

UNIX is a trademark of AT&T Bell Laboratories.

Document Number: 290190004-500-R01-0386

Part Number: 091-092-031
Contents

1 Getting Started
1.1 Introduction 1-1
1.2 Getting Started 1-1
1.3 Command Screen 1-1
1.4 Output of Commands 1-2
1.5 Main Command Menu 1-3
1.6 Status Line 1-3
1.7 Message Line 1-4
1.8 Definitions 1-4
1.9 Using This Manual 1-6

2 Choosing Commands
2.1 Command Menus 2-1
2.2 Editing Responses to Commands 2-1
2.3 Carrying Out a Command: The RETURN Key 2-2
2.4 Canceling a Command: The CANCEL Key 2-2
2.5 Redrawing the Screen: The REDRAW Key 2-2

3 Using the Visual Shell
3.1 Introduction 3-1
3.2 Creating Files 3-1
3.3 Managing Files 3-3
3.4 Managing Directories 3-12
3.5 Listing Permissions: The Run Command 3-19
3.6 Managing Floppy Disks 3-20
3.7 Running Applications: The Run Command 3-25
3.8 Sending and Receiving Mail 3-31
3.9 Getting Help: The Help Command 3-34
3.10 Quitting 3-37

4 Using Advanced Features
4.1 Introduction 4-1
4.2 Using the Window 4-1
4.3 Expanding the Window: The Window Command 4-3
4.4 Using the Window with Simple Commands 4-5
4.5 Changing the Menus 4-7
4.6 Renaming Commands 4-12
4.7 Creating and Modifying Submenus 4-14
4.8 Changing Command Menus 4-15
4.9 .mnu Files 4-15
5 Key Directory

5.1 Introduction 5-1
5.2 Key Chart 5-1

6 Command Directory

6.1 Introduction 6-1
6.2 Copy 6-2
6.3 Delete 6-5
6.4 Edit 6-6
6.5 Help 6-7
6.6 Mail 6-8
6.7 Name 6-9
6.8 Options 6-10
6.9 Options Directory 6-11
6.10 Options Filesystem 6-12
6.11 Options Output 6-17
6.12 Options Permissions 6-18
6.13 Print 6-19
6.14 Quit 6-19
6.15 Run 6-20
6.16 View 6-21
6.17 Window 6-22

A Command Mapping

A.1 Command Map A-1

B Making Your Own Menu Files

B.1 Introduction B-1
B.2 Command Menus B-3
B.3 .mnu Files B-3
B.4 Command Menu Prompts B-3
B.5 Command Menu Fields B-4
B.6 Command Lines B-5
B.7 Help Text B-5
B.8 Examples B-5

C Message Directory

C.1 Messages C-1
Chapter 1

Getting Started

1.1 Introduction 1-1
1.2 Getting Started 1-1
1.3 Command Screen 1-1
1.4 Output of Commands 1-2
1.5 Main Command Menu 1-3
1.6 Status Line 1-3
1.7 Message Line 1-4
1.8 Definitions 1-4
1.9 Using This Manual 1-6
Welcome...
Welcome to Microsoft® Excel, the most powerful integrated spreadsheet for the Macintosh™. Excel combines a sophisticated spreadsheet with built-in graphics and a worksheet-oriented database. And with Excel, you can create your own functions and macros, which make it easy to automate repetitive actions.

Excel provides fast, powerful calculating ability, plus the flexibility to create graphics from your information. You will find that Excel handles even the most complex financial or statistical problems with ease.
1.1 Introduction

The XENIX® Operating System Visual Shell is an interface between you and your computer's operating system. The Visual Shell can be used on any microprocessor running XENIX Version 3.0 or System V.

The user interface or "shell" is what you see on the screen when your system is waiting for a command. The shell interprets all commands to the operating system; it replaces the traditional command-line with a visual shell that shows you a menu of the most commonly executed applications and utilities.

As with Microsoft® Productivity® software, pressing the HELP key or choosing the Help command displays Help information. Files for use with a command may be selected by pointing to a file or directory with the cursor. This saves you from having to type the whole filename or directory name, and reduces the possibility of selecting the wrong file or directory.

An important feature of the Visual Shell is that you can customise it for different purposes. You can create commands and help files as well as tailor the shell for different applications.

The Visual Shell typically will be used by people running prepackaged applications (such as Microsoft Multiplan®) under XENIX. Users with more advanced knowledge will customise the menus for more efficient running of applications and data processing.

In this chapter, we will define some terms and introduce you to the Visual Shell environment.

1.2 Getting Started

To use this manual you need to know how to log in to your computer. If your system has been customised with the Visual Shell, you will see the Visual Shell screen when you log in.

If your system has not been customised, you will see the "$" prompt when you login. To start the Visual Shell from the "$" prompt, type the following command:

vsh

Your screen is redrawn and the Visual Shell appears.

1.3 Command Screen

When you start the XENIX Visual Shell the first thing you will see is the command screen. Your screen may look something like this:
1.4 Output of Commands

The center portion of your screen appears blank when you start your computer. As you type commands, the output of these commands appears in the central portion of the screen. The command output scrolls up each time a new command is typed, until the directory window is reached. The output scrolls past the directory window as new output is displayed at the bottom. The command menu, message line, and status line are temporarily erased during command execution and are redrawn when the command has completed.
 Normally, output in this area reflects the Visual Shell command you choose. A special command lets you see exactly which XENIX command you are running. See Section 6.11 of Chapter 6, "Command Directory," for more information.

1.5 Main Command Menu

The main command menu shows 12 commands:

- Copy
- Delete
- Edit
- Help
- Mail
- Name
- Options
- Print
- Quit
- Run
- View
- Window

You will use these commands to copy and delete files, run applications, quit the session, obtain Help text, and access many of the functions of the operating system. Below the menu is the prompt, "Choose option or type command letter." You will learn how to choose options and type command letters in Chapter 3, "Using the Visual Shell."

1.6 Status Line

The status line is the last line on the screen. It gives you the following information:

- The pathname of the working directory (left truncated if necessary).
- A message if you have mail.
- The date.
- The time.
- The name of the operating system (XENIX).

When the operating system is waiting for you to enter commands, two things are monitored and displayed on the status line: the time and the date. The time is updated every minute, and the date is updated daily.
1.7 Message Line

The message line is above the status line. The Visual Shell displays various messages on this line when you choose commands and execute operating system tasks. Any error messages you may receive appear on this line.

1.8 Definitions

You should understand the following terms when using the Visual Shell. These terms are defined in more detail in the XENIX User's Guide.

<table>
<thead>
<tr>
<th>Term</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>A file is a collection of related information. All programs, text, and data on your disks reside in files. You create a file each time you enter and save data or text at your terminal. Files are also created when you write and name programs and save them on your computer.</td>
</tr>
<tr>
<td>Filename</td>
<td>A filename is a string of up to 14 characters. Characters such as period (.) and hyphen (-) are allowed so you may create filename extensions that are used to identify types of files. An example of a filename with an extension is newfile.mnu. Refer to your XENIX User's Guide for more information on naming files.</td>
</tr>
<tr>
<td>Directory</td>
<td>The names of files are kept in directories on your computer. These directories also contain information on the size of the files, their location on disk, and the dates that they were created or modified. The directory you are working in is called your &quot;working&quot; directory.</td>
</tr>
<tr>
<td>Pathname</td>
<td>A pathname is a sequence of directory names followed by a simple filename, each separated from the previous one by a forward slash (/). Pathnames are used to uniquely identify files that may have the same name or that are not in your current working directory. An example of a pathname is /usr/joe/testfile.</td>
</tr>
<tr>
<td>Special Characters</td>
<td>The asterisk (*) and the question mark (?) special characters can be used when specifying filenames. These special characters give you greater flexibility when using filenames in XENIX commands.</td>
</tr>
</tbody>
</table>
The question mark (?) in a filename indicates any character occupying that position. The asterisk (*) in a filename indicates any character occupying that position or any of the remaining positions in the filename. For more information on using special characters, see the XENIX User's Guide.

Switches

Switches are options that control operating system commands. They appear on command menus as choices, as in the following example:

recursive: Yes (No)

The default choice is always enclosed in parentheses.

Filter

A filter is a command that reads your input, transforms it in some way, and then outputs it, usually to your terminal or to a file. In this way, the data is said to have been "filtered" by the program. Since filters can be put together in many different ways, a few filters can take the place of a large number of specific commands.

Pipes

If you want to have the output of one program sent as input to another, you can "pipe" commands to the operating system. For example, you may occasionally need to have the output of one program sent as the input to another program. A typical case would be a program that produces output in columns. In addition, you may want to have the columns sorted.

Piping with the Visual Shell is accomplished by typing a bar (|) symbol in the "output:" field of a command menu. The Visual Shell will then display a Filter menu. You can choose the appropriate filter (Sort, More, Get, etc.) and your program will be "piped" through that filter. You can also pipe programs and commands through your own filters.

You can pipe (redirect) the output of a command or program by specifying an output filename or device name in the "output:" command field.
1.9 Using This Manual

This manual contains examples that you can follow while learning XENIX. To help you follow the examples, refer to Chapter 5, "Key Directory," for a list of key functions.

You can also use the Help command any time to find out which key to use to perform a function. Refer to Section 3.9, in Chapter 3, "Using the Visual Shell," for more information.
Chapter 2
Choosing Commands

2.1 Command Menus 2-1
2.2 Editing Responses to Commands 2-1
2.3 Carrying Out a Command: The RETURN Key 2-2
2.4 Canceling a Command: The CANCEL Key 2-2
2.5 Redrawing the Screen: The REDRAW Key 2-2
2.1 Command Menus

The lists of commands you see on your screen are called menus. In fact, any time you see choices on the bottom part of the screen, that is a menu. You can choose an option from a menu by pressing the SPACEBAR. As you press the SPACEBAR, watch the command menu. The highlight moves left to right, stopping at each command. Try pressing the SPACEBAR to move to each of the different options on the main command menu. Once you have selected a command, press the RETURN key and a new menu will be displayed on the screen. You must fill in the blank fields of this submenu to tell the Visual Shell what to do with the command you selected.

The BACKSPACE key can be used to back up (move right to left) through the commands.

To get back to the main command menu at any time, press the CANCEL key. Refer to Chapter 5, “Key Directory,” for the key or keys that perform the Cancel function.

Another way to select commands and other options is to type the first letter of the command or option while in the command menu. For example, if you want to copy a file, type C. You do not need to press RETURN; the Copy command will automatically be processed.

Note

If you press a key that does not work as a command, such as the letter J, the command screen will not change, but you will see the error message, “Not a valid option.”

2.2 Editing Responses to Commands

The Visual Shell provides special editing keys to edit responses in the command fields. The following keys are listed by function only. Refer to Chapter 5, “Key Directory,” for the exact key or sequence of keys that corresponds to these functions.

The field containing a proposed response is highlighted just after a command is selected or after pressing the TAB key.

To replace the proposed response, type the replacement. The Visual Shell automatically deletes the proposed response as soon as you type the new one.

To delete the proposed response and leave the field empty, press the DELETE key. All text that is highlighted is deleted.
Visual Shell

To append to the proposed response, press either the CHARACTER RIGHT or the WORD RIGHT key, then type the additional text.

Once the proposed response is altered, one character or word in the field is highlighted. This highlight is the edit cursor. The edit cursor may be moved to designate where or what to edit.

Use the CHARACTER LEFT, CHARACTER RIGHT, WORD LEFT, and WORD RIGHT keys to move the edit cursor in the command fields. The CHARACTER LEFT and CHARACTER RIGHT keys move the edit cursor left or right one character. The WORD LEFT and WORD RIGHT keys move the edit cursor left or right, choosing words or the space or punctuation between words.

To insert new text, type the text. It will be inserted in front of the edit cursor.

To delete text, use the BACKSPACE key to delete characters on the left side of the cursor. Use the DELETE key to delete what is highlighted by the cursor.

To replace text, delete the old text and type the new text.

2.3 Carrying Out a Command: The RETURN Key

The Visual Shell does not carry out the command until you tell it to do so by pressing the RETURN key. As shown earlier, the RETURN key is also used after you move the highlight to a command or subcommand name with the SPACEBAR or BACKSPACE keys.

You can press the RETURN key whenever the responses in all the command fields are correct. When a command has been carried out, the command screen reappears and waits for a new command. Note that if you choose a command by typing its first letter, you do not have to press the RETURN key.

2.4 Canceling a Command: The CANCEL Key

Before you press RETURN to carry out a command, you may press the CANCEL key to cancel the command. When you press the CANCEL key, the command screen will reappear and you can choose another command or quit the session. Refer to Chapter 5, “Key Directory,” to locate the CANCEL key on your keyboard.

2.5 Redrawing the Screen: The REDRAW Key

You may clear your screen at any time during the computer session by pressing the REDRAW key. Consult Chapter 5, “Key Directory,” to determine which key corresponds to the Redraw function.
Chapter 3
Using the Visual Shell

3.1 Introduction 3-1

3.2 Creating Files 3-1
  3.2.1 Using an Editor: The Edit Command 3-1
  3.2.2 Viewing Your Directory: The Direction Keys 3-3

3.3 Managing Files 3-3
  3.3.1 Viewing Files: The View Command 3-3
  3.3.2 Renaming Files: The Name Command 3-5
  3.3.3 Copying Files: The Copy File Command 3-6
  3.3.4Deleting Files: The Delete Command 3-8
  3.3.5 Printing Files: The Print Command 3-9
  3.3.6 Setting File Permissions: The Options Permissions Command 3-11

3.4 Managing Directories 3-12
  3.4.1 Creating a Directory: The Options Directory Make Command 3-13
  3.4.2 Transferring to Other Directories: The View Command 3-15
  3.4.3 Copying Directories: The Copy Directory Command 3-17
  3.4.4 Deleting Directories: The Delete Command 3-18
  3.4.5 Setting Directory Permissions: The Options Permissions Command 3-19

3.5 Listing Permissions: The Run Command 3-19

3.6 Managing Floppy Disks 3-20
  3.6.1 Creating a File System on a Disk 3-20
  3.6.2 Mounting a Floppy Disk 3-22
  3.6.3 Unmounting a Floppy Disk: The Unmount Command 3-24
  3.6.4 Checking Floppy Disks: The Filescheck Command 3-25

3.7 Running Applications: The Run Command 3-25
  3.7.1 Using Filters 3-27
3.8 Sending and Receiving Mail  3-31

3.9 Getting Help: The Help Command  3-34

3.10 Quitting  3-37
3.1 Introduction

This chapter discusses how to perform operating system functions by using Visual Shell commands. The topics include:

- Creating files.
- Managing files.
- Managing directories.
- Managing floppy disks.
- Sending and receiving mail.
- Running applications.
- Getting help.
- Quitting.

3.2 Creating Files

The Visual Shell includes a specific command to help you create and edit files. This command is called the Edit command.

3.2.1 Using an Editor: The Edit Command

You can create and delete text and program files using the XENIX editor. The Visual Shell default editor for XENIX is vi. Refer to Chapter 4, “Using Advanced Features,” for information on how to use other editors under XENIX.

You use the Edit command to automatically call up vi. When the vi menu appears, type the name of the file you want to create or edit, and then press the RETURN key. The Visual Shell will disappear and you will be using the editor. When you exit the editor, the Visual Shell is redisplayed.
Visual Shell

Example

This example creates a sample file named test in your working directory.

1. Choose the Edit command from the main command menu by typing the letter “E”. Your screen should look like this:

```
EDIT filename:
Enter a filename or select from list
/usr/diane  date  time  XENIX
```

2. Type the filename test in the “filename:” command field.

3. Press the RETURN key.

   The Visual Shell will disappear, and you will be using vi. (For more information on vi, see the XENIX User’s Guide.)
4. Type the letter I (for "Insert").

5. Type the following line:

   I'm a XENIX Visual Shell temporary file.

6. Press ESCAPE.

7. To save this file in your working directory type ":x". We will be referring to this test file in later sections of this manual.

### 3.2.2 Viewing Your Directory: The Direction Keys

You can scroll through your working directory anytime by pressing one of the direction keys: LEFT, RIGHT, UP, or DOWN. For example, to select the filename to the right of the current selection, press the RIGHT direction key.

### 3.3 Managing Files

The commands in this section will help you manage your files. The commands discussed are: View, Copy, Delete, Name, Options, and Print. These commands are used to view, copy, delete, rename, change permissions, and print files.

### 3.3.1 Viewing Files: The View Command

The View command is used to view files on the screen. You can scan through files using this command, but you cannot edit them. Use the Edit command to edit files.

To use the View command, choose the View command from the main command menu. Fill in the command menu with the name of the file you want to view. When you press the RETURN key, a five-line window will appear at the top of the screen. The file you selected will be displayed in that window. If the file is larger than the window, you can use the direction keys and some function keys to scroll the file in the window. Refer to Chapter 5, "Key Directory," for more information on function keys.

When the window appears on the screen, the main command menu will reappear. You can choose other Visual Shell commands while the window is on the screen.
Note

If you make a mistake, you can always press the CANCEL key to return to the main command menu. Refer to Chapter 5, "Key Directory," for information on the CANCEL key.

Example

To view the test file that you created with the Edit command (refer to Section 3.2.1), follow these steps:

1. Choose the View command from the main command menu.
2. Fill in the menu by typing test in the "name:" command field. Your screen should look like this:
3. Press the RETURN key.

When you press the RETURN key, a window will open at the top of your screen. The test file will appear in this window.

3.3.2 Renaming Files: The Name Command

The Name command renames files. To use this command, choose the Name command from the main command menu. The Name menu will appear. Fill in the name of the file you want to rename in the “from:” command field, and the new name of the file in the “to:” command field. When you press RETURN, your file will be renamed. You will know that the renaming process is complete when you see a message in the command output area of the screen.

You can rename any file according to the rules for naming files. Refer to the XENIX User's Guide for more information on naming conventions.
Example

To rename the test file temp1, follow these steps:

1. Choose the Name command from the main command menu.
2. Fill in the Name menu as follows:

```
/usr/diane/test
I'm a XENIX Visual Shell temporary file.
```

```
"test" [New file] 1 line, 44 characters
NAME from: test to: temp1
Enter a filename or select from list /usr/diane
```

3. Press RETURN.

The test file is now renamed temp1. You will see the message, "Name (1) test (2) temp1" in the command output area of the screen.

3.3.3 Copying Files: The Copy File Command

The Copy command on the main command menu is used to copy files. It is also used to copy directories as described in Section 3.4.3.
To copy a file, choose the Copy command from the main command menu. The Copy menu will appear. This menu asks you whether you want to copy a file or a directory. When you choose File, the Copy File menu appears. You must type the name of the file you want to copy in the "from:" command field, and the new name of the file in the "to:" command field.

Example

To make a copy of the temp1 file and name the copy temp2, follow these steps:

1. Choose Copy from the main command menu.
2. Choose File from the Copy menu.
3. Fill in the Copy File menu command fields. Your screen should look like this:
4. Press the RETURN key.

The message, “Copy File (1) temp1 (2) temp2” will appear in the command output area of the screen when the temp1 file has been copied. You now have two identical files in your working directory: temp1 and temp2.

3.3.4 Deleting Files: The Delete Command

You can delete files and directories with the Delete command. For information on deleting directories, refer to Section 3.4.4.

To delete a file, choose Delete from the main command menu. Fill in the name of the file you wish to delete in the “name:” command field. When you press RETURN, your file will be deleted. You will see a message in the command output area of the screen.
To delete the file temp2 from your working directory, follow these steps:

1. Choose the **Delete** command from the main command menu.
2. Type `temp2` in the "name:" command field.
3. Press RETURN.

The file `temp2` is deleted. You will see the message, "Delete (1) temp2" in the command output area of the screen.

### 3.3.5 Printing Files: The Print Command

The **Print** command is used to print files. To print a file, choose the **Print** command from the main command menu. The **Print** menu will appear. This menu contains a "filename:" command field. To print a file or files, type the name of the file in the "filename:" command field. When you press RETURN, your file will be sent to the printer. The message, "Print (1) filename" will be displayed in the command output area.

To print more than one file, separate the filenames with spaces when you fill in the "filename:" command field.

---

**Note**

Please make sure your printer is attached to your computer.

---

**Example**

To print the file `temp1`:

1. Choose the **Print** command from the main command menu.
2. Type `temp1` in the "filename:" command field. Your screen should look like this:
Visual Shell

Delete (1) temp2
PRINT filename: temp1
Enter one or more filenames or select from list
/usr/diane
date time XENIX

3. Press the RETURN key.

The temp1 file is sent to the printer. When it has been printed, the Visual Shell will display the message, “Print (1) temp1” in the command output area of the screen.
3.3.6 Setting File Permissions: The Options Permissions Command

The Options command is one of the Visual Shell commands that has a submenu of other commands. (The other Visual Shell commands with submenus are Copy and Mail). Use the Options command to set file permissions to protect various files in your directory. You can set the file permission to a variety of combinations.

To set a file permission, choose the Options command from the main command menu. An Options menu will appear. Now, choose the Permissions command. Fill in the command fields with the name of the file you wish to protect and with the kind of protection desired. When you press RETURN, the permission will change on your file.

Example

The following example sets read and write permission to “all users” for the file named temp1.

1. Choose Options from the main command menu.
2. Choose Permissions from the Options menu.
3. Fill in the command fields so that your screen looks like this:
Visual Shell

4. Press the RETURN key.

The file named temp1 is now changed so that all persons on the system can read and write to the file.

To verify that the permissions on the file have changed, you must run the XENIX ls -l command. Refer to Section 3.5 for more information.

3.4 Managing Directories

The commands in this section will help you manage your directories. These commands are used to create and delete directories, transfer to a new working directory, change permissions on directories, and determine disk usage.
3.4.1 Creating a Directory: The Options Directory Make Command

The Options menu contains several commands that perform directory functions. The Options Directory Make command creates new directories on your system. To create a directory, choose the Options command from the main menu. An Options menu will appear. Select the Directory command. The Options Directory menu will appear. When you choose the Make command, you will be asked to supply the name of the directory. You must supply a complete pathname if the directory is not a subdirectory of your working directory.

Example 1

Assume that your working directory is named /usr/diane. You want to create a forms directory under diane. Follow these steps:

1. Choose the Options command from the main command menu.
2. Choose the Directory command.
3. Choose the Make command from the Directory menu.
4. Fill in the Directory Make menu as follows:

```
./usr/diane
[.] [..] .profile temp1
```

Print (1) temp1
Options Permissions (1) temp1 (2) All (3) Yes (4) No (5) No
OPTIONS DIRECTORY MAKE directory: forms
Enter new path /usr/diane

5. Press RETURN.

The message, "(1) forms" will be displayed in the command output area when XENIX has created the directory.

*Example 2*

Assume that your working directory is `/usr/diane`. To create a `memo` subdirectory directory in `forms`, follow these steps:

1. Choose the **Options** command from the main command menu.
2. Choose the **Directory** command.
3. Choose the **Make** command from the **Directory** menu.
4. Fill in the Directory Make menu with the complete *pathname* of the directory you want to make. Your screen should look like this:

```
-usr/diane-
[.]         [..]       .profile     [forms]
temp1
```

Options Directory Make (1) forms
DIRECTORY MAKE directory: forms/memo
Enter a filename or select from list
/usr/diane

5. Press RETURN.

3.4.2 Transferring to Other Directories: The View Command

If you want to change to another directory and look at the files in that directory, use the View command to transfer to the new directory. To use the View command, choose View from the main command menu. Type the name of the directory you want to transfer to in the “name:” command field. When you press RETURN, your working directory will be the directory you selected. The status line will change to reflect that you are now working in a different directory.
Visual Shell

When you learn to use the Visual Shell window, you can use special keys to transfer to various directories. Section 4.2.1 in Chapter 4, "Using Advanced Features," tells you more about changing directories.

Example

Assume your working directory is `/usr/diane`. You want to change to another user's directory, `/usr/sally`. Follow these steps:

1. Choose the View command from the main command menu.
2. Type `/usr/sally` in the "name:" command field. Your screen should look like this:

```
VIEW name: /usr/sally
```

3. Press the RETURN key.
Your working directory will now be /usr/sally. To check this, look at the status line at the bottom of your screen. This line keeps track of your working directory. Use the View command to return to your working directory.

3.4.3 Copying Directories: The Copy Directory Command

You can copy directories with the Copy Directory command. First, choose the Copy command from the main command menu. Then, choose Directory from the Copy menu. Type the pathname of the directory you want to copy in the “from:” command field. Type the new pathname of the directory in the “to:” command field. If you want all subdirectories of the directory copied also, choose “Yes” in the “recursive:” command field. The default is “No.” When you press RETURN, your directory will be copied, and the message, “Copy Directory (1) filename (2) filename” will appear in the command output area of the screen.

Example

To make a copy of the /usr/diane/forms directory and name the directory /usr/diane/letters, follow these steps:

1. Choose Copy from the main command menu.

2. Choose Directory from the Copy menu.
3. Fill in the command fields so that your screen looks like this:

Options Directory Make (1) forms
Options Directory Make (1) forms/memo
COPY DIRECTORY from: /usr/diane/forms to: /usr/diane/letters
recursive: Yes(No)
Enter new path
/usr/diane

4. Press RETURN.

You now have two identical directories:

- /usr/diane/forms.
- /usr/diane/letters.

3.4.4 Deleting Directories: The Delete Command

You can delete directories with the Delete command. First, choose the Delete command from the main command menu. Type the pathname of the directory you want to delete in the "name:" command field. When you press RETURN, the directory will
be deleted. The message, "Delete (1) pathname" will be displayed in the command output area of the screen.

---

**Note**

You cannot delete a directory unless it is empty (contains no files).

---

**Example**

Assume that you have a /usr/diane/tmp directory on your disk. To delete the /usr/diane/tmp directory, follow these steps:

1. Delete each file from the directory using the Delete command on the main command menu.
2. When the directory is empty, choose Delete from the main command menu.
3. Type /usr/diane/tmp in the "name:" command field.
4. Press RETURN.

The /usr/diane/tmp directory is now deleted.

### 3.4.5 Setting Directory Permissions: The Options Permissions Command

You can set different directory permissions with the Options Permissions command. To set a permission on a directory, follow the same steps outlined in Section 3.3.6 for files. Type the pathname of the directory you want to protect in the "name:" command field. When you press RETURN, the protection for your directory will have changed.

### 3.5 Listing Permissions: The Run Command

You can check the permissions that are set on both files and directories by using the Visual Shell Run command and "running" the XENIX `ls -l` (for "list") command. Follow these steps:

1. Choose Run from the main menu.
2. When the Run menu appears, type "ls" in the "file:" command field.
3. Move to the "parameters" field and type "-l".
4. Press RETURN.

Your working directory and files will be displayed in the command output area of the screen. Protection values for each file and directory are also displayed.

3.6 Managing Floppy Disks

The commands in this section will help you manage your disks. The commands discussed are on the Options Filesystem menu. They are: Create, Filescheck, Spacefree, Mount, and Unmount. The following table describes these commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create</td>
<td>Creates a file system on a disk.</td>
</tr>
<tr>
<td>Filescheck</td>
<td>Checks the files for bad sectors; fixes disks.</td>
</tr>
<tr>
<td>Spacefree</td>
<td>Tells you how much space is left on the disk.</td>
</tr>
<tr>
<td>Mount</td>
<td>Allows you to “mount” (insert and use) a floppy disk.</td>
</tr>
<tr>
<td>Unmount</td>
<td>Allows you to “unmount” (take out) a floppy disk.</td>
</tr>
</tbody>
</table>

3.6.1 Creating a File System on a Disk

You cannot mount a floppy disk unless it has a file system on it. Use the Options Filesystem Create command to create a file system on a floppy disk.

To create a file system disk on a floppy disk, follow these steps:

1. Insert a formatted floppy disk into your system’s floppy disk drive.
2. Choose the Options Filesystem Create command.
3. Fill in the appropriate fields.
4. Press RETURN.

Warning:

If you create a file system on a floppy disk, then any data previously stored on that disk is destroyed.
Example

The following example creates a file system on a floppy disk. A file system is created on the disk in the floppy disk drive named /dev/fd0. The disk is then mounted.

1. Insert a formatted disk into your computer's floppy disk drive (/dev/fd0).
2. Choose Options from the main command menu.
3. Choose Filesystem from the Options menu.
4. Choose Create from the Filesystem menu.
5. Create a file system named /dev/fd0 on the floppy disk by filling in the command fields as follows:
6. Press RETURN.

8.6.2 Mounting a Floppy Disk

To mount a floppy disk on your computer, follow these steps:

1. Create an empty directory in your working directory. A common name for this directory is \textit{mnt}. If you already have an empty directory, you may use that directory instead. (For information on making directories, refer to Section 3.4.1.)

2. Insert a floppy disk containing a file system into your system's floppy disk drive.

3. Mount the floppy disk with the Options Filesystem Mount command.
You are now ready to use the floppy disk. If the mount is unsuccessful, use the Options Filesystem Filescheck command to check the disk. Refer to Section 3.6.4.

Example

You can mount the contents of the floppy disk's file system in an empty directory with the Mount command. Follow these steps:

1. Insert a floppy disk with a file system into your computer's floppy disk drive (/dev/fd0).
2. Choose Options from the main command menu.
3. Choose Filesystem from the Options menu.
4. Choose Mount from the Filesystem menu.
5. Mount the disk (/dev/fd0) in the empty directory you created (/usr/diane/mnt) by filling in the command fields so that your screen looks like this:
You can use the floppy disk simply by transferring to the /usr/diane/mnt directory with the View command. If you do not know how to transfer to another directory, refer to Section 3.4.2.

### 3.6.3 Unmounting a Floppy Disk: The Unmount Command

To remove a mounted floppy disk from a floppy disk drive, you must first "unmount" the disk. That is, you must break the connection between the operating system and your floppy disk. You do this with the **Options Filesystem Unmount** command. Follow these steps carefully:

1. Transfer to a directory other than the "mounted" directory. For example, transfer to the /usr/diane directory. Use the View command to transfer to a different directory.
2. Choose Options from the main command menu.
3. Choose Filesystem from the Options menu.
4. Choose Unmount from the Filesystem menu.
5. Type the disk drive name in the “device name:” command field.
6. Press RETURN.
7. Take out the floppy disk.

3.6.4 Checking Floppy Disks: The Filecheck Command

If you cannot mount a floppy disk, it is wise to run it through Filecheck. Refer to Chapter 6, “Command Directory,” for more information on the Options Filesystem Filecheck command.

To check a floppy disk, choose Options from the main command menu. Next, choose the Filesystem command. A Filesystem menu will appear. Choose Filecheck. Fill in the “device:” command field with the name of the floppy disk drive. When you press RETURN, the Visual Shell reports on the status of the disk, and fixes any problems (such as bad sectors).

---

Note

Using Filecheck may remove data from damaged portions of the disk, making the data inaccessible.

3.7 Running Applications: The Run Command

The Run command helps you run applications. These applications can be batch files that you create with an editor (using the Edit command), spreadsheet programs such as Microsoft® Multiplan®, and high-level language programs, such as C).
Visual Shell

When you choose the Run command, the following Run menu appears:

```
/usr/diane-------------------
[.] ..
profile [forms]
temp1 [letters] [mnt]       

Options Filesystem Mount (1) /dev/fd0 (2) /usr/diane/mnt (3) No

Options Filesystem Unmount (1) /dev/fd0

RUN file: parameters: output:
Enter a filename or select from list
/usr/diane
```

Since the Run command can be used for many different files and applications, the Run menu provides space to tell the operating system what you want to run and how to run it. The "file:" command field is used to specify which program or command to run. The "parameters:" field is used to specify any arguments that the operating system may need to run the program or command. Any special switches for the command or program should be typed in the "parameters:" command field.

You can use the "output:" field to direct output from the application or command to another file or device; or you can access the Filter menu by placing a bar (|) symbol in this field. (See below for more information on the Filter menu.) When you press the RETURN key, your application will run. When you exit your application, the main command menu is redisplayed.
### 3.7.1 Using Filters

A filter is a command that reads your input, transforms it in some way, and then outputs it, usually to your terminal or to a file. In this way, the data is said to have been "filtered" by the program. Since filters can be put together in many different ways, a few filters can take the place of a large number of specific commands. Visual Shell filters include: Count, Get, Head, More, Sort, and Tail. The following list describes these filters. The corresponding XENIX command name is enclosed in parentheses. If you need more information on these commands, look in the XENIX Reference Manual under the XENIX command name.

<table>
<thead>
<tr>
<th>Filter</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count</td>
<td>Counts lines, words, and characters (wc).</td>
</tr>
<tr>
<td>Get</td>
<td>Searches files for a pattern (grep).</td>
</tr>
<tr>
<td>Head</td>
<td>Displays the first few lines of a file (head).</td>
</tr>
<tr>
<td>More</td>
<td>Displays files 23 lines at a time (more).</td>
</tr>
<tr>
<td>Sort</td>
<td>Sorts files (sort).</td>
</tr>
<tr>
<td>Tail</td>
<td>Displays the last part of a file (tail).</td>
</tr>
</tbody>
</table>

You can access the Visual Shell filters by placing a bar (|) symbol in the "output:" command field of certain command menus. The Filter menu will appear. When you choose an appropriate filter and press RETURN, your program or command will be piped through that filter. Example 2, below, illustrates how to access the Sort filter.

**Note**

For more information on piping XENIX commands, refer to the XENIX User's Guide.

The Filter menu includes a Run command. This command is used to access filters you have written. To run a command through your own filter, choose the Run command from the main command menu. Type the name of the command in the "file:" command field, and type a bar symbol (|) in the "output:" field. Select the Run command on the Filter menu. Type the filename associated with your filter in the "file:" field. When you press RETURN, the command will be piped through your filter. Example 3 illustrates this process.

Three examples are provided below. The first example illustrates how to start a software application package, Microsoft Multiplan, with the Run command. The
second example shows you how to access a XENIX command not on the command menu and how to use the Filter menu. Example 3 describes how to pipe a XENIX command through a filter that you have written.

**Example 1: Running an Application**

To run Microsoft Multiplan, follow these steps:

1. Make sure that Multiplan exists on your computer. If it is on a floppy disk, mount the floppy disk before proceeding to step 2.

2. Choose the **Run** command from the main command menu.

3. When the **Run** command menu appears, type "Multiplan" in the "file:" command field. Your screen should look like this:

   ![Screen Screenshot]

   Options Filesystem Unmount (1) /dev/fd0
   Options Filesystem Mount (1) /dev/fd0 (2) /usr/diane/mnt
   RUN file: Multiplan parameters:    output:
   Enter a filename or select from list /usr/diane

4. Press the RETURN key.
Multiplan will appear on your screen. When you exit Multiplan, the Visual Shell main command screen will be redisplayed.

*Example 2: Running a Command With the Filter Menu*

You can sort a list of names and send the sorted output to a file named *myfile* by using the Run command with the Sort filter. To create a list of names, you'll invoke the *cat* command using Run. The *cat* command copies keyboard input directly to a filter or file. Follow these steps:

1. Choose the **Run** command from the main command menu.
2. Fill in the **Run** command menu with the word "cat" in the "file:" command field. Go to the "output:" field and place a bar (|) symbol in it. Your screen should look like this:

```
_options Filesystem Mount (1) /dev/fd0 (2) /usr/diane/mnt
Run (1) Multiplan (2) (3)
RUN file: cat parameters: output: |
Enter a filename or press | to view filter menu
/usr/diane date time XENIX
```

3. Press the RETURN key. The Filter menu will appear.
4. Choose the Sort filter. The Visual Shell will display the Filter Sort menu. Since an A-Z sort is the default, you do not need to change this command field.

5. Go to the "output:" field. Type the filename *myfile*. Your screen should look like this:

```
Run (1) Multiplan (2) (3)
Run (1) cat (2) (3);
SORT order: (<) Yes(No) numeric: Yes(No)
dictionary-order: Yes(No) output: myfile
Enter a filename or press ; to view filter menu
```

6. Press the RETURN key. The main command menu will reappear, and a message, "Run (1) cat (2) (3); Sort (1) < (2) No (3) No (4) No (5) myfile" will appear in the command output area of the screen.

7. Now type the lines:

```
fred
larry
albert
snowden
george
```
Using the Visual Shell

8. To end the test, type CTRL-D on a new line. Once you've ended the list, cat passes the names to the sort filter which sorts them alphabetically and places them in myfile. Use the View command to examine the myfile file.

Example 3: Using Your Own Filters

Assume that you have created a filter named unique that takes a sorted file, deletes duplicates, and displays the file without the duplicate entries. This filter is stored as a file called unique.s in your working directory. The file you want to view is named beta, and is not sorted. To access the filter, follow these steps:

1. Choose Run from the main command menu.
2. Type the XENIX sort command in the "file:" field.
3. Type "beta" in the "parameters:" command field.
4. Type a bar symbol (\) in the "output:" field to access the Filter menu.
5. Select Run from the Filter menu.
6. Type "unique.s" in the "file:" command field to access your filter.
7. Press RETURN.

The Visual Shell will display the beta file, sorted and without duplicate entries, on the screen.

3.8 Sending and Receiving Mail

You send and receive mail with the Mail command on the main command menu. When you choose the Mail command, a Mail menu appears. There are two commands on the Mail menu: Read and Send. Use the Read command to read any electronic mail you receive; use the Send command to send messages to other users of the system.

There are several commands you can perform while you are in Mail: deleting messages, saving messages in a file, editing a message you are composing, and canceling a message. These commands are discussed in the examples below. For more information about Mail, see the XENIX User's Guide.
Example

To read mail:

When you see the message "Mail" on the status line, choose the Mail command. A Mail menu will appear. Choose Read. A list of your mail messages will appear on the screen. To read message 1, type 1 and press RETURN. To read message 3, type 3 and press RETURN. When you have finished reading your mail, press CTRL-D to return to the main command menu.

To delete a message:

To delete a message from your mailbox, type:

    d number

where number is the number of the message you wish to delete. If you decide you want to save a deleted message, you can restore it before you quit Mail by typing:

    u number

where number is the number of the message you want restored. You cannot restore a message after you have exited Mail.

To save a message in a file:

To save a message in a file, type:

    s number path.name

where number is the number of the message being saved, and path.name is the path-name of the file in which you want to save the message.

To edit a message:

If you wish to edit a message you are composing, you can enter the ed editor from Mail by typing:

    -e

on a line by itself. See the XENIX User’s Guide for information on how to use ed.

When you exit the editor you will be back in Mail.

To cancel a message:

If, while composing a message, you decide not to send it, you can cancel the message by pressing the INTERRUPT key twice. After you have pressed INTERRUPT twice, you will return to the Mail menu.
To send mail:

1. Choose Mail from the main command menu.
2. Choose the Send command.

You are now in the XENIX mail system. To send mail, type the user's name in the "to" command field. Press RETURN. Next, type the subject in the "Subject" field. Press RETURN. Then, type a message. When you press CTRL-D, XENIX will send your message to the specified user or users.

To exit Mail:

If you are reading mail, press CTRL-D to exit Mail and return to the main command menu. If you are sending mail, you will return to the main command menu automatically; don't press CTRL-D again or you will log yourself out.

Example

This example sends the message, "Hello there" to users Sue and Joe.

1. Choose Mail from the main command menu.
2. Choose Send.
3. Type "Sue" and "Joe" in the "to:" command field.
4. Fill in the "Subject:" field. Press RETURN.
5. Type, "Hello there" in the message area.
6. Press RETURN.
7. Press CTRL-D.

When you exit the mail system, you will be returned to the XENIX Visual Shell. For more information on how to send and receive mail, refer to the XENIX User's Guide for instructions.
3.9 Getting Help: The Help Command

The Visual Shell includes a special Help command to assist you while using the XENIX operating system. This Help information is always available to you.

To access Help text, the Help command from the main command menu. You will see a Help menu that looks like this:

```
INTRODUCTION
You may ask for help at any time during your work....

If you need...

When you...

Right now...

You may...

HELP: Resume Next Previous Introduction
Commands Keyboard Filters Menus
Select option or type command letter
/usr/diane date time XENIX
```

Use this menu to view various parts of the Help information. If you press “C” (for Commands), a Command Overview appears on the screen. This describes how to choose commands with the Visual Shell. When you press “N” (for Next), more Command Overview help text is shown. You can use the Next command when the Help text is longer than one screen.
Using the Visual Shell

The following list describes the Help commands:

- **Resume**: Resumes state of screen before you asked for help.
- **Next**: Moves Help text forward by one screenful.
- **Previous**: Moves Help text backward by one screenful.
- **Introduction**: Moves you to the beginning of Help text.
- **Commands**: Gives you Visual Shell command information.
- **Keyboard**: Tells you how to use the keyboard.
- **Filters**: Describes operating system filters and command piping, and how to use filter menus.
- **Menus**: Illustrates how to change command menus.

You can access Visual Shell information with the Help command. For example, to find out which keys perform which functions, select the Help command, then type "K" (for Keyboard). The beginning of the list of keys appears. Type "N" (for Next) to view the rest of the list.

You can also access the Help command by pressing the question mark (?) key while you are selecting a Visual Shell command or filling in a command field. The example below illustrates this use of the Help command.

**Example**

To access Help text on the Copy command, follow these steps:

1. Choose the Copy command by using the SPACEBAR; do not type "C" and do not press RETURN.

2. When the Copy menu appears, press the question mark (?) key.

The screen display will be replaced by Help information on the Copy command. Your screen should look like this:
COPY

Copies directories and files.

HELP: Resume Next Previous Introduction
Commands Keyboard Filters Menus
Select option or type command letter
/usr/diane date XENIX

The information on the Copy command describes what happened when you copied the file temp1 to temp2 earlier in this manual. The Help menu appears at the bottom of the screen. You can use the "N" (for Next) command to view more of the Help text, or you can choose any of the subjects that you want to learn about. When you press "R" (for Resume), the main command menu is redisplayed.
3.10 Quitting

The Quit command is used to quit the XENIX session. To quit, choose the Quit command on the main command menu. Your screen will look like this:

```
/usr/diane  [-]  profile  [forms]
temp1  [sales]  [mnt]  myfile
```

QUIT
Enter Y to confirm
Enter a filename or select from list
```
/usr/diane  [date time XENIX]
```

The Visual Shell asks you to confirm that you want to quit. To quit, type "Y" (for Yes). If you press any other character or number, the Visual Shell will return to the main command menu. When you type "Y", the screen will clear and you will have exited the Visual Shell. To restart the shell, press the RETURN key.
Visual Shell

Example

To quit the session, follow these steps:

1. Choose the Quit command from the main command menu.

2. The Quit screen will appear. It asks you to "Type Y to confirm:". Type "Y".

You have now exited from the Visual Shell.
Chapter 4

Using Advanced Features

4.1 Introduction 4-1

4.2 Using the Window 4-1
  4.2.1 Showing the Directory 4-1
  4.2.2 Showing Text Files 4-3

4.3 Expanding the Window: The Window Command 4-3

4.4 Using the Window with Simple Commands 4-5

4.5 Changing the Menus 4-7
  4.5.1 Adding Commands to Menus 4-8
  4.5.2 Deleting Commands from Menus 4-11

4.6 Renaming Commands 4-12

4.7 Creating and Modifying Submenus 4-14

4.8 Changing Command Menus 4-15

4.9 .mnu Files 4-15
4.1 Introduction

The Visual Shell is more than just an operating system interface; it is designed to help you enter commands and perform functions efficiently. Two Visual Shell features give you flexibility and power: the window and a modifiable menu structure. You will learn about the window and how to change Visual Shell menus in this chapter.

4.2 Using the Window

The Visual Shell can set aside a window at the top of your screen in which you can display and access information. You can manipulate directories and text files in this window. The window can be permanent or temporary. A permanent window is one that has been explicitly opened and will remain open (with necessary redrawing) until explicitly closed. This is accomplished with the Window command. Refer to Section 4.3 for information on opening permanent windows on the screen. A temporary window will disappear after the next command is processed.

4.2.1 Showing the Directory

Just as you can view text files in the window, you can use the direction keys on your keyboard to view directories in the window. (Refer to Chapter 5, “Key Directory,” for information on the direction keys UP, DOWN, LEFT, and RIGHT.) When you use one of these keys, a temporary window appears on your screen and remains only until you execute a Visual Shell command.

To display a directory, press one of the direction keys when the main command menu appears on the screen. A temporary window will be drawn in the upper portion of the screen.

The window contains a directory listing for your working directory. Two kinds of information are shown: names of files and names of directories. Directories and subdirectories are shown in brackets ([ ]), and each executable file is preceded by an asterisk (*). Text files are not marked in any special way.

You can use the direction keys to select filenames and directory names in the window. The bottom border of a window always contains information about the selected directory or file. The border tells you the name of the directory (or file), its size in bytes, and the date it was last modified. For example:

```
____ myfile ______ 33 bytes ______ modified Aug. 2, 1985
```
Visual Shell

Two special keys are used with the window. These keys are the equal sign (\textasciitilde) and the hyphen (\textendash). For simplicity, we will call these the SHOW and GOAWAY keys. If the cursor is highlighting a directory, you can press the SHOW (\textasciitilde) key to see the listing for that subdirectory displayed in the window. Pressing the GOAWAY (\textendash) key returns the display to the parent directory. You can always access a parent directory by pressing the GOAWAY key. Using these two keys, you can change your current working directory. This is another way to perform a View command on a directory. (Refer to Section 3.4.2 in Chapter 3, “Using the Visual Shell,” for more information.) Notice that there are several subdirectories in your working directory. To view the directory named \texttt{/usr/diane/forms}, follow these steps:

1. Use the direction keys to select the \texttt{[forms]} subdirectory name.

2. Press the SHOW (\textasciitilde) key to view the \texttt{/usr/diane/forms} directory. Your screen will look like this:

   ```
   -/usr/diane/forms
   [.]
   [-]
   [memos]
   modified-date
   COMMAND: Copy Delete Edit Mail Name
   Options Print Quit Run View Window
   Select option or type command letter
   /usr/diane/forms
   date time XENIX
   ```

3. Press the GOAWAY (\textendash) key to redisplay the \texttt{/usr/diane} directory in the window.
4.2.2 Showing Text Files

You can also view text files in the window with the SHOW and GOAWAY keys. To view a text file, press one of the direction keys so that the working directory is displayed in the window. To view a text file, select the name of the file you want to view. Press the SHOW key. The directory will disappear and be replaced by the text file you selected. You can use the scrolling keys to view the file. (Refer to Chapter 5, "Key Directory," for information on keys that scroll through files.) When you press the GOAWAY key, the working directory is redisplayed in the window.

Note

You can only "show" text files that reside in the directory that is currently displayed on the screen. To display other text files, either change directories or use the View command and specify a full pathname.

Example

To view the temp1 file in your working directory, follow these steps:

1. Press one of the direction keys when you see the main command menu on the screen. Your working directory will appear in the window.
2. Select the filename temp1.
3. Press the SHOW key.

The temp1 file will be displayed in the window. To return to your working directory, press the GOAWAY key.

4.3 Expanding the Window: The Window Command

Windows that appear in response to pressing a direction key are temporary windows that disappear after the next command is pressed. The Window command can be used to create a permanent window on the screen, and to increase the size of the window.

To create a permanent window that is smaller than the default 15-line window, choose the Window command from the main command menu. The Window menu will appear. This menu asks you whether you want to redraw the window after each command. The default is "Yes." To establish a smaller window, go to the "height in lines:" command field. Type a number from 1 through 14. (The window cannot be more than 15 lines long.) When you press the RETURN key, the main command menu
will be redisplayed. A permanent window will appear on the screen until you close it with the Window command.

To close the window, choose the Window command from the main command menu. Choose the “No” option in the “redraw:” command field. Press RETURN. The display will return to the main command menu, and the window will not appear until you press a direction key.

Example

To create a permanent 10-line window on the screen, follow these steps:

1. Choose the Window command from the main command menu.

2. Go to the “redraw:” command field and choose “Yes”.

3. Go to the “height in lines:” command field. Type the value 10. Your screen should look like this:
Using Advanced Features

4. Press the RETURN key.

The main command menu will be redisplayed. A window 10 lines long will appear in the upper part of the screen. To close this permanent window, choose the Window command and go to the "redraw:" command field. Choose "No". When you press RETURN, the main command menu will be redisplayed and the window will be closed.

4.4 Using the Window with Simple Commands

One of the advantages of using a window is that you can fill in command menus with filenames and directory names by selecting them in the window. The following example duplicates the Copy File command described in Section 3.3.3 in Chapter 3, "Using the Visual Shell," when the temp1 file was copied to a file named temp2.
Example:

1. In the main command menu, type "C" (for Copy). The Copy menu will appear on the screen.

2. Select File from the Copy menu.

3. The cursor should be in the "from:" command field. Do not type the filename `temp1`. Instead, press the direction keys so that the working directory appears in the window. The following figure illustrates what your screen should look like:

```
/usr/diane
[.]    [..]    .profile    [forms]
temp1    [letters]    [mnt]    .myfile

COPY FILE from: to:

Enter one or more filenames or select from list
```

4. Now, using the direction keys, select the filename `temp1` in the window. Notice that as you press the direction keys, the command field changes in the Copy menu. Each filename that is selected in the window appears in the "from:" field at the bottom of the screen.
5. When the name temp1 appears in the "from:" field of the Copy menu, go to the "to:" field.

6. Type the filename temp2.

7. Press RETURN.

Output from the Copy command ("Copy file (1) temp1 (2) temp2") will appear in the command output section of the command screen.

Both filenames and directory names can be selected to fill in command menus. Experiment with various commands by using the window to fill in the command menus.

4.5 Changing the Menus

You can modify menu commands (except those in Help) at any time. While in a menu (for example, the main command menu), you can change the commands on the screen by pressing the MODIFY (@) key. When you press @, the following Modify menu is displayed:
The choices on this menu are: **Delete**, **Insert**, and **Rename**. The following sections discuss what happens when you choose each of these commands.

### 4.5.1 Adding Commands to Menus

You can add commands by using the **Modify** menu. First, press the **MODIFY** key. Choose the **Insert** option. Fill in the command fields with the following:

1. **The name of the command as you want it to appear on the menu.**
2. **The location of that command** (you must give the command’s full pathname) Refer to the XENIX *User’s Guide* for information on filesystems and the pathnames of commands. Refer to Appendix A, “Command Mapping,” for appropriate command names.
3. **Where you want the command to appear on the menu.**
When you press the RETURN key, the command will be added to the main command menu.

Example

Assume that you want to add a Look command to the main command menu. This command will perform the same function as the XENIX ls (for “list”) command. You want the command menu to contain 12 commands: Copy, Delete, Help, Look, Mail, Name, Options, Print, Quit, Run, View, and Window. To add the Look command, follow these steps:

1. When the main command menu is displayed, press the MODIFY (@) key. The Modify menu will appear.

2. Choose the Insert option.

3. The Modify Insert menu command will appear. This menu asks you what name you want to add to the main command menu and the command pathname that is associated with that name. The following figure illustrates what your screen should look like:
Copy File (1) temp1 (2) temp2

INSERT menu item: for command:
  before item: Copy

Enter text of new menu item
/usr/diane
date time  XENIX

4. Type "Look" in the "menu item:" field.

5. Go to the "command:" field. Type the full pathname of the XENIX command for the value of the Look command (/bin/ls).

6. Go to the "before item:" field. This asks you which command you want Look to come before on the menu. The Visual Shell automatically suggests Mail, the next item in the alphabetical list.

7. Press RETURN. The main command menu will include the new Look command between Help and Mail.

8. If you want to insert Look in a different place, press a direction key. The list of commands will appear at the top of the screen. Use direction keys to select the command you wish Look to precede.
Note

You must name your commands with unique first letters. Do not name your commands with letters that have already been used on the main command menu. If you choose a letter that is already taken, the Visual Shell will ask you to specify a different name for that command.

The Visual Shell recognizes all XENIX operating system commands and creates a submenu for each one you add to a command menu. To illustrate this, let’s use the new Look command. In the command menu, go to the Look command and press RETURN. A special default command menu for your Look command will appear on the screen. This menu asks you to specify the parameters for the Look command. Type the name of the directory you want to view in the “parameters:” command field. When you press RETURN, you will be returned to the command screen and the directory you specified will appear in the window.

Note

If the directory you want to view is not a subdirectory of your working directory, you must type the pathname of the directory in the “parameters:” command field.

4.5.2 Deleting Commands from Menus

To delete a command from the main command menu, press the MODIFY key while in the command menu. (You do not have to go to the command you want to delete.) The Modify menu will appear. Press RETURN to select the Delete option. The Modify Delete menu simply asks you which command you want to delete. Type the name of the command you want to delete in the “menu item:” field. You can also use the direction keys to enumerate which command you want to delete. When you press RETURN, the main command menu will be displayed. It will no longer contain the command you just deleted.

Example

To delete the Look command you just added to the main command menu, follow these steps:

1. Press the MODIFY key when the main command menu is displayed.
2. Choose the Delete option from the Modify menu.

3. Type the word "Look" in the "menu item" field.

4. Press the RETURN key.

The Visual Shell will redisplay the main command menu without the Look command.

Note
You cannot delete the Help command or any of the commands in the Help menu.

4.6 Renaming Commands

You can add and delete many commands with the Visual Shell. You can also change the name of any command on the menu. To do this, use the Rename command in the Modify menu.

For example, you may want to rename the View command to "see." (You might want to do this if you want to add a command that starts with the letter "V", which conflicts with the View command.) To rename a command, choose the Rename option in the Modify menu. The Modify Rename menu asks you which command to rename. Fill in the three command fields and press the RETURN key. The main command menu will be redisplayed and will include the new command name.

Example

The following steps illustrate how to rename the View command to See.

1. While in the command menu, press the MODIFY key. The Modify menu will appear on the screen.

2. Go to the Rename command and press RETURN. Your screen should look like this:
Using Advanced Features

3. There are three fields: "from:", "to:", and "place before item:". Type "View" in the "from:" field, and "See" in the "to:" field. The Visual Shell will check to see if there are any commands in the main command menu that begin with the letter "S".

4. Go to the "place before item:" field. The Visual Shell automatically suggests placing the renamed command in alphabetical order. Press RETURN to insert "See" in alphabetical order.

5. The View command is now renamed See.

   If you have chosen a letter that is already used on the menu, the Visual Shell prompts you to choose a different letter.
4.7 Creating and Modifying Submenus

Creating and modifying submenus is easy with the Visual Shell. You must first decide what to name the main menu item. The command and its associated submenu must have the same name. Use the MODIFY (@) key to display the Modify menu and choose the Insert menu.

There are three fields in the Modify Insert menu: “menu item:”, “for command:” and “before item:”. To add a submenu, type the name of the command in the “menu item:” field. Next, go to the “for command:” field. Instead of typing a filename, type the word “menu”. This tells the Visual Shell that you are planning to add a submenu to the system. When you press the RETURN key, the Visual Shell will display the main command menu with the new top-level command.

So far, you have created a command with a submenu, but there are no commands for the submenu. To add commands to your new submenu, choose the top-level command and press RETURN. You should see the name of your submenu displayed on the screen. You can use the MODIFY (@) key to call up the Menu Modify menu to add some commands to your submenu. Follow the steps described in Section 4.5.1 to add commands to the submenu. A copy of the special file containing Visual Shell menu instructions—menu.def—is automatically copied to your directory when you use Modify Insert command. This is an executable file and appears in your directory with an asterisk (*) in front of the filename.

Commands are deleted from a submenu the same way they are deleted from the main command menu. Refer to Section 4.5.2 for more information. You cannot delete a submenu until each command has been deleted from it.

**Example**

Assume that you want to be able to access several editors by using a submenu under a Text main command. These editors are named word, ed, and vi.

You must first add the main level command to the command screen using the MODIFY (@) key and the Insert option. Follow these steps:

1. When the main command menu is displayed, press the MODIFY (@) key. The Modify menu will appear.

2. Choose the Insert menu.

3. Type “Text” in response to the “menu item:” field, and “Menu” in response to the “for command:” field.

4. Press RETURN. The main command menu is now displayed. The Text command has been added to this menu.

5. Choose the Text command. The screen will display “TEXT”. Press the
MODIFY (@) key to display the Modify menu. Choose the Insert menu.

6. Add the first editor by typing the name of the editor (for example, "Word") in the "menu item:" field and the location of the editor on disk (for example, /bin/word) in the "for command:" field.

7. Press RETURN to display the main command screen.

8. Repeat steps 4, 5, and 6 to add ed and vi subcommands to the Text submenu.

To delete the submenu, select Text command, then use the Modify menu to delete the commands word, ed, and vi. Next, return to the command screen and use the MODIFY key to display the Modify menu. Choose the Delete menu and type "text" in response to the "command:" field. When you press RETURN, both the submenu (named Text) and the top level Text command will be deleted.

4.8 Changing Command Menus

In the previous section, you learned how to add, delete, and rename commands. You also learned how to create and delete submenus. This section describes how to change and create command menus. Command menus are the menus that you fill in once you have selected a command.

4.9 .mnu Files

All XENIX commands are actually executable files on disk. You can see the files when you do a directory listing for the directory that contains XENIX commands on your system (usually /bin). The instructions for Visual Shell command menus are found in a special file, /usr/bin/menu.def. When you add your own Visual Shell commands, a copy of this special file is automatically placed in your current directory and a default menu is assigned your command. However, you can create your own command menus by placing instructions in a .mnu file. For example, the instruction menu for your See command would be in see.mnu. An .mnu file contains the information necessary for the Visual Shell to create a command submenu and is stored in the /usr/bin directory. An .mnu file describes the following:

1. The submenu(s) for one operating system command.

2. The defaults and possible values of the fields within the submenu(s).

3. The actual command line arguments to be used once you press RETURN. These arguments act as a template into which values from the submenu are inserted.

4. Help text. This text appears on the screen if you press the HELP key (the ? key) while the command submenu is being displayed.
If you add commands to the Visual Shell using the MODIFY key, you do not have to add a corresponding command menu. When you choose the new command, the Visual Shell first searches in the /bin directory to find a .mnu file that corresponds to the command. (For example, a finger command might have an associated finger.mnu file.) If there is no associated .mnu file for the command, the Visual Shell displays a default command menu. The default command menu looks like this:

```
/usr/diane
[.]
[..]
.temp1
[letters]
[.profile]
[forms]
[.mnt]
[myfile]

SEE file: parameters:
Enter a filename or select from list
/usr/diane date time XENIX
```

You can create your own command menus by writing a .mnu file that corresponds to a command that you have added to the Visual Shell. Refer to Appendix B, “Making Your Own Menu Files,” for information on how to create a .mnu file.
Chapter 5
Key Directory

5.1 Introduction  5-1
5.2 Key Chart  5-1
5.1 Introduction

In this manual, the keys are referred to by their functional names (by what they do), rather than by what may be written on the key.

The following are the basic key assignments provided with your operating system. Depending on the keyboard you use, you may have additional function keys or different key assignments. An extended chart, which lists terminal-specific keys, is available in the Visual Shell by pressing the letter “H” (for Help) and then “K” (for Keyboard). (Press “N”, for Next, to view more of the chart.)

Note

These keys perform the following functions only in conjunction with Visual Shell menus. They may not work in the same manner if used during application programs or during operating system commands.

5.2 Key Chart

<table>
<thead>
<tr>
<th>Key Sequences</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL-E</td>
<td>UP DIRECTION. Moves the cursor up one line.</td>
</tr>
<tr>
<td>CTRL-X</td>
<td>DOWN DIRECTION. Moves the cursor down one line.</td>
</tr>
<tr>
<td>CTRL-S</td>
<td>LEFT DIRECTION. Moves the cursor left one character.</td>
</tr>
<tr>
<td>CTRL-D</td>
<td>RIGHT DIRECTION. Moves the cursor right one character.</td>
</tr>
<tr>
<td>CTRL-R-E</td>
<td>PAGE UP. Moves the cursor up one page.</td>
</tr>
<tr>
<td>CTRL-R-X</td>
<td>PAGE DOWN. Moves the cursor down one page.</td>
</tr>
<tr>
<td>CTRL-Q</td>
<td>HOME. Moves the cursor to the beginning of the file or directory listing.</td>
</tr>
<tr>
<td>CTRL-Z</td>
<td>END. Moves the cursor to the end of the file or directory listing.</td>
</tr>
<tr>
<td>CTRL-C</td>
<td>CANCEL. Cancels present operation and returns to main command menu.</td>
</tr>
</tbody>
</table>
Visual Shell

RETURN

RETURN. Starts a command selected from a menu or carries out a completed command.

SPACEBAR

Selects the next item on a menu.

BACKSPACE, CTRL-H

Selects the previous item on a menu. When editing responses in command fields, deletes selected characters.

TAB, CTRL-I, CTRL-A

TAB. Moves to and selects the entire contents of the next field in the command line.

CTRL-Y, DELETE

DELETE. Deletes selected characters.

CTRL-L

CHARACTER RIGHT. Selects the character to the right of the current character.

CTRL-K

CHARACTER LEFT. Selects the character to the left of the current character.

CTRL-P

WORD RIGHT. Selects the word to the right of the current word.

CTRL-O

WORD LEFT. Selects the word to the left of the current word.

? 

HELP. Requests information about the selected command or the command in progress at the time of the request.

= 

SHOW. Displays directories and text files; displays submenus for commands in window.

- 

GOAWAY. Returns window display to parent or current directory.

@ 

MODIFY. Displays the Modify menu.

! 

REDRAW. Redraws the screen.

! 

BAR. Displays the Filter menu.
Chapter 6
Command Directory

6.1 Introduction 6-1

6.2 Copy 6-2
   6.2.1 Copy Directory 6-3
   6.2.2 Copy File 6-4

6.3 Delete 6-5

6.4 Edit 6-6

6.5 Help 6-7

6.6 Mail 6-8
   6.6.1 Mail Read 6-8
   6.6.2 Mail Send 6-8

6.7 Name 6-9

6.8 Options 6-10

6.9 Options Directory 6-11
   6.9.1 Options Directory Make 6-11
   6.9.2 Options Directory Usage 6-11

6.10 Options Filesystem 6-12
   6.10.1 Options Filesystem Create 6-13
   6.10.2 Options Filesystem Filescheck 6-14
   6.10.3 Options Filesystem Mount 6-15
   6.10.4 Options Filesystem Spacefree 6-16
   6.10.5 Options Filesystem Unmount 6-16

6.11 Options Output 6-17
6.12 Options Permissions 6-18

6.13 Print 6-19

6.14 Quit 6-19

6.15 Run 6-20

6.16 View 6-21

6.17 Window 6-22
6.1 Introduction

This chapter describes the Microsoft Visual Shell commands. They are:

- Copy Directory
- Copy File
- Delete
- Edit
- Help
- Mail Read
- Mail Send
- Name
- Options Directory Make
- Options Directory Usage
- Options Filesystem Create
- Options Filesystem Filescheck
- Options Filesystem Mount
- Options Filesystem Spacefree
- Options Filesystem Unmount
- Options Output
- Options Permissions
- Print
- Quit
- Run
- View
- Window

The command descriptions explain the action of each command, the purpose of the command fields, and the meaning of the messages displayed by a command.

The two following definitions, which you will be using later on in this chapter, describe the required syntax for filenames and pathnames.

**Filename**
A filename is a string of up to 14 characters. Characters such as period (.) and hyphen (−) are allowed so you may create filename extensions that are used to identify types of files. An example of a filename with an extension is `newfile.mnu`. Refer to your XENIX User's Guide for more information on naming files.

**Pathname**
A pathname is a sequence of directory names followed by a simple filename, each separated from the previous one by a forward slash (/). Pathnames are used to uniquely identify files that may have the same name or that are not in your current directory. An example of a pathname is `/usr/joe/testfile`.

**Device**
A device is a special filename that refers to a peripheral device...
such as a hard or a floppy disk drive. These names are required in commands to specify the device containing the file system you are mounting, checking, or searching. For example, the filename /dev/fd0 refers to the floppy disk drive 0 on your computer.

6.2 Copy

COPY: File Directory

Purpose

The Copy command offers a choice of subcommands that perform the following tasks:

- Copy the contents of a file to a new file.
- Copy the contents of a directory to a new directory.

The Copy subcommands are described individually on the following pages.
6.2.1 Copy Directory

COPYDIRECTORY from: to: recursive: Yes (No)

Purpose
To copy the contents of the source directory to the destination directory.

Command Fields

from: Enter a directory name. The directory name must have the syntax described at the beginning of this chapter. If the directory specified in this field is not the working directory, make sure you supply an appropriate pathname.

to: Enter a directory name. The directory name must have the syntax described at the beginning of this chapter.

recursive: If you select "Yes" the Visual Shell will copy all subdirectories under the directory specified.
6.2.2 Copy File

COPY FILE from: to:

Purpose

To copy the contents of the specified source file to the specified destination file.

Remarks

You may copy the contents of any existing file to the destination file. If the destination file already exists, the old contents are deleted before the new contents are copied to it.

If you copy the source file to another directory, you may give the destination file the same name as the source. Otherwise, you must use a different name.

Command Fields

from: Enter a filename. The filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.

to: Enter a filename. The filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.
6.3 Delete

DELETE name:

Purpose
To perform the following delete operations:

- Delete a file from a directory
- Delete a subdirectory from a directory

Remarks
The command deletes a file from the current or specified directory, or deletes the directory specified by the pathname.

Command Fields

name: Choose one of the following:

1. Enter a filename. The filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.

2. Enter a directory name. It must have the syntax described at the beginning of this chapter. If the subdirectory is not in the working directory, make sure you supply an appropriate pathname.
6.4 Edit

EDIT filename:

Purpose

To load the system's interactive editor and edit the text file named after "filename:"

Remarks

The command relinquishes control to the system's interactive editor, so the command menu is erased from the screen and is replaced by the editor's own screen. The command menu is restored when you exit the editor.

Command Fields

filename: Enter a filename. The filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.
6.5 Help

HELP: Resume Next Previous Introduction Commands Filters
Keyboard Menus

Purpose
To display information about the Visual Shell and its commands.

Remarks
The commands in the Help menu provide the following Help information:
Resume            Exits Help and returns you to your previous screen.
Next              Scrolls Help text one screenful ahead.
Previous          Scrolls Help text one screenful backward.
Introduction      Displays the beginning of Visual Shell Help text.
Commands          Displays Visual Shell command information.
Keyboard          Displays information about the keyboard.
Filters           Displays information on the Visual Shell filters More, Sort, Head, Tail, Get and Count.
Menus             Displays information on how to change the Visual Shell menus.
6.6 Mail

Mail has two commands: Read and Send. These two commands are described in the following text.

6.6.1 Mail Read

Purpose
To read mail sent by other users of the system.

Remarks
Once you have selected Mail Read, you begin using the XENIX mail system to read your mail. Refer to the XENIX User's Guide for more information on the XENIX Mail command.

Command Fields
There are no command fields.

6.6.2 Mail Send

MAIL SEND to:

Purpose
To send mail to other users on the system.

Remarks
After you have filled in the “to:” command field, you begin using the XENIX Mail command. Refer to the XENIX User's Guide for more information on the Mail command.

Command Fields

to: Type one or more user names in this command field and press RETURN. If more than one user name is specified, separate the names with a space.
6.7 Name

NAME from: to:

Purpose
To rename a directory or file.

Remarks
The new name must not be the same name of a file or directory already in the same directory.

Command Fields

from: Enter a file or directory name. The file or directory name must have the syntax described at the beginning of this chapter. If the file or directory is not in the working directory, make sure you supply an appropriate pathname.

to: Enter a file or directory name. The file or directory name must have the syntax described at the beginning of this chapter. If the file or directory is not in the working directory, make sure you supply an appropriate pathname.
6.8 Options

OPTIONS: Directory Filesystem Output Permissions

Purpose

To offer a choice of subcommands to perform the following operations:

- Make a directory (under Directory).
- Determine disk usage (under Directory).
- Create a file system (under Filesystem).
- Check a file system (under Filesystem).
- Determine free space (under Filesystem).
- Mount a floppy disk (under Filesystem).
- Unmount a floppy disk (under Filesystem).
- Set permissions for directories and files (under Permissions).
- Change Visual Shell command output on the screen (under Output).

The commands are described individually on the following pages.
6.9 Options Directory

The Options Directory menu has two commands: Make and Usage. They are described below.

6.9.1 Options Directory Make

OPTIONS DIRECTORY MAKE directory:

Purpose
To make a new directory.

Command Fields

directory: Enter a directory name. The directory name must have the syntax described at the beginning of this chapter. The directory that you create will become a subdirectory of your working directory.

6.9.2 Options Directory Usage

OPTIONS DIRECTORY USAGE pathname:

Purpose
To determine the number of blocks contained in all files and directories within each directory and file specified by "name:"

Remarks
This command does not count directories that cannot be read or files that cannot be opened. Files with holes in them will result in an incorrect block count.

Command Fields

pathname: Specify the pathname of a directory. The directory name must have the syntax described at the beginning of this chapter.
6.10 Options Filesystem

The Options Filesystem menu contains 5 commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create</td>
<td>Creates a file system.</td>
</tr>
<tr>
<td>Filecheck</td>
<td>Checks and repairs file systems.</td>
</tr>
<tr>
<td>Spacefree</td>
<td>Reports number of free disk blocks.</td>
</tr>
<tr>
<td>Mount</td>
<td>Mounts a file structure.</td>
</tr>
<tr>
<td>Unmount</td>
<td>Dismounts a file structure.</td>
</tr>
</tbody>
</table>

These commands are described in the following pages.
6.10.1 Options Filesystem Create

OPTIONS FILESYSTEM CREATE  device name:  block number:
   gap number:  block number:

Purpose
To create a file system.

Remarks
The block size, gap number, and block number command fields require numbers that are given in the XENIX Operations Guide.

Command Fields

device name:  Specify a device name, such as /dev/fd0. The device name must have the syntax described at the beginning of this chapter.

block number:  Specify a block size or the size of the created system.

gap number:  Specify a gap number.

block number:  Specify a block number.
6.10.2 Options Filesystem Filescheck

OPTIONS FILESYSTEM FILESCHECK device:

Purpose

This command is usually run when you have problems mounting a floppy disk on a machine. Options Filesystem Filescheck audits and repairs inconsistent conditions for file systems. If the file system is consistent, the number of files, number of blocks used, and number of blocks free are reported.

Remarks

Most corrective actions of this command result in some loss of data.

Command Fields

device: Specify a device name. The device name must have the syntax described at the beginning of this chapter.
6.10.3 Options Filesystem Mount

OPTIONS FILESYSTEM MOUNT: device: directory:

Purpose
To mount a floppy disk on the machine.

Remarks
This command tells the system that a removable file structure (i.e., a floppy disk) is present. The file structure is mounted on a directory. The directory must already exist; it becomes the name of the root of the newly mounted file structure. Refer to the Options Directory Make command for information on how to create a directory.

If you have problems mounting a floppy disk, refer to the Options Filesystem Filescheck command.

Command Fields

device: Specify the name of the device you are mounting, such as /dev/fd0. The device name must have the syntax described at the beginning of this chapter.

directory: Specify the name of the directory in which the mounted file system will reside. The directory name must have the syntax described at the beginning of this chapter.

read only: Select "Yes" or "No". The default is "No".
6.10.4 Options Filesystem Spacefree

OPTIONS FILESYSTEM SPACEFREE device:

Purpose
Reports the number of free disk blocks.

Remarks
If the "device:" command field is not specified, Spacefree reports free space on all mounted file systems.

Command Fields

device: Specify a device name. The device name must have the syntax described at the beginning of this chapter.

6.10.5 Options Filesystem Unmount

OPTIONS FILESYSTEM UNMOUNT device:

Purpose
Dismounts a mounted file system (floppy disk).

Remarks
Busy file structures cannot be dismounted with Unmount.

Command Fields

device: Specify the mounted device name. The device name must have the syntax described at the beginning of this chapter.
6.11 Options Output

OPTIONS OUTPUT  commands like: VShell XENIX

Purpose
To set how the Visual Shell will display command syntax when a command has run.

Remarks
Normally, the Visual Shell will display its commands in the command output area of the screen. For example, when you have run Options Directory Make to create a directory, the Visual Shell will display, “Options Directory Make...” when the command has processed. If you want to see which XENIX command is running, select the “XENIX” field. The Visual Shell will display “mkdir ...” instead of Options Directory Make.

Command Fields

commands like: VShell XENIX

Choose “XENIX” to see actual XENIX commands displayed. The default is Visual Shell commands (“VShell”).
6.12 Options Permissions

OPTIONS PERMISSIONS name: who: (All) Me Group Others
read: (Yes) No write: (Yes) No execute: (Yes) No

Purpose

To change permissions on a file or directory.

Remarks

The following permissions groups are established:

<table>
<thead>
<tr>
<th>Group</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All</td>
<td>All users</td>
</tr>
<tr>
<td>Me</td>
<td>One user</td>
</tr>
<tr>
<td>Group</td>
<td>All users in a specified group</td>
</tr>
<tr>
<td>Others</td>
<td>All users other than group and me</td>
</tr>
</tbody>
</table>

Command Fields

- **name:** Type the name of a file or directory. The filename or directory name must have the syntax described at the beginning of this chapter.
- **who:** Enable the permissions group by selecting All, Me, Group, or Others.
- **read:** Select “Yes” or “No”. “Yes” is the default.
- **write:** Select “Yes” or “No”. “Yes” is the default.
- **execute:** Select “Yes” or “No”. “Yes” is the default.
6.13 Print

PRINT filename:

Purpose
To print a file or files on the system’s lineprinter.

Remarks
The command adds the specified file or files to the end of the printer queue. The file is printed when it reaches the top of the queue.

The specified file(s) must be text files.

Command Fields

filename: Enter a filename. The filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.

6.14 Quit

QUIT:

Enter Y to confirm:

Purpose
To leave the Visual Shell and return to the XENIX command shell.

Remarks
You must type the letter “Y” to confirm that you want to leave the Visual Shell. On exit from the shell, the system saves the current environment so you may return to the same point when you start the shell again.
6.15 Run

**RUN file:**  parameters:  output:

**Purpose**

To run the program or command specified by "name:"

**Remarks**

The specified file must be one of the following:

- An application program
- A XENIX file that is executable
- The name of a XENIX command

If you specify a filename, the filename must have the syntax described at the beginning of this chapter. If the file is not in the working directory, make sure you supply an appropriate pathname.

**Command Fields**

- **file:** Enter a filename, program name, or command name.
- **parameters:** Enter any arguments to the program or command, including switches.
- **output:** Specify a filename or device name to redirect output from the program or command. Specify a bar (|) symbol to access the Filter menu.
6.16 View

VIEW name:

Purpose

This command loads a file or directory into the window.

Remarks

If a file is loaded in the window, you can view the file by using the scrolling keys. If a directory is loaded in the window, you can travel around the directory by using the SHOW (=) and GOAWAY (−) keys. Refer to Chapter 5, “Key Directory,” for more information.

Command Fields

name: Enter a file or directory name. The file or directory name must have the syntax described at the beginning of this chapter. If the file or directory is not in the current directory, make sure you supply an appropriate pathname.
6.17 Window

WINDOW redraw: (Yes) No  height in lines:

Purpose
To turn the window display on or off and set the window height.

Remarks
When the window redraw is “Yes”, a permanent window appears at the top of your screen. The window contains the output from the View command and the SHOW and GOAWAY keys. When redraw is “No”, a window only appears when specifically requested with a View command or by pressing a direction key. The window “redraw:” command field is initially “Yes”.

You may use the “height in lines:” field to set the window height in lines. Initially, the height is 15 lines (the maximum height).

Command Fields

redraw: Choose an option. “Yes” turns the window display on. “No” turns it off.

height in lines: Enter a number. It may be any number from 1 to 15.
Appendix A

Command Mapping

A.1 Command Map  A-1
## Command Mapping

### A.1 Command Map

The following table maps all Visual Shell commands to XENIX commands.

<table>
<thead>
<tr>
<th>XENIX Command</th>
<th>Visual Shell Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>cp</td>
<td>Copy File</td>
</tr>
<tr>
<td>copy</td>
<td>Copy Directory</td>
</tr>
<tr>
<td>rm, rmdir</td>
<td>Delete</td>
</tr>
<tr>
<td>vi</td>
<td>Edit</td>
</tr>
<tr>
<td>--</td>
<td>Help</td>
</tr>
<tr>
<td>mail</td>
<td>Mail Read</td>
</tr>
<tr>
<td>mail</td>
<td>Mail Send</td>
</tr>
<tr>
<td>mv</td>
<td>Name</td>
</tr>
<tr>
<td>mkdir</td>
<td>Options Directory Make</td>
</tr>
<tr>
<td>du</td>
<td>Options Directory Usage</td>
</tr>
<tr>
<td>mkfs</td>
<td>Options Filesystem Create</td>
</tr>
<tr>
<td>fsck</td>
<td>Options Filesystem Filesccheck</td>
</tr>
<tr>
<td>df</td>
<td>Options Filesystem Spacefree</td>
</tr>
<tr>
<td>mount</td>
<td>Options Filesystem Mount</td>
</tr>
<tr>
<td>umount</td>
<td>Options Filesystem Unmount</td>
</tr>
<tr>
<td>chmod</td>
<td>Options Permissions</td>
</tr>
<tr>
<td>--</td>
<td>Options Output</td>
</tr>
<tr>
<td>pr</td>
<td>lp</td>
</tr>
<tr>
<td>CTRL-D</td>
<td>Quit</td>
</tr>
<tr>
<td>--</td>
<td>Run</td>
</tr>
<tr>
<td>cat, cd</td>
<td>View</td>
</tr>
<tr>
<td>--</td>
<td>Window</td>
</tr>
</tbody>
</table>
Appendix B
Making Your Own Menu Files

B.1 Introduction B-1
B.2 Command Menus B-3
B.3 .mnu Files B-3
B.4 Command Menu Prompts B-3
B.5 Command Menu Fields B-4
B.6 Command Lines B-5
B.7 Help Text B-5
B.8 Examples B-5
B.1 Introduction

When you use the Visual Shell, you select commands at the bottom of the screen. Each time you select a command, another screen appears. This screen is called a "command menu." For example, when you select the Copy command, a screen similar to the following appears:

```
    /usr/diane
    [.]     [..]     .profile     [forms]
temp1

COPY FILE from: to:
Enter a filename or select from list /usr/diane
```

A command menu contains fields that give information, such as a filename, to the command. To run the Copy command, you fill in the "from:" and "to:" fields and then press the RETURN key.
If the Visual Shell does not recognize the command you run (for example, if you have added a command to the menu), a default command menu appears for you to fill in. The default command menu looks like this:

```
 TEXT name: parameters: output:
Enter a filename or select from list
/usr/diane [ ] [ ] .profile [ ] [ ] forms
modified date
```

```bash
B-2
```
B.2 Command Menus

Each Visual Shell command calls up a different command menu. Some command menus are defined in a special file named `/usr/bin/Menu.def`. The command menus for user-added commands are stored in individual files with `.mnu` extensions, one for each command. For example, if you add a command named *Spread* (for Spreadsheet), you can define your own command menu with a file named `spread.mnu`. If the Visual Shell does not find a corresponding `.mnu` file for a command, it displays the default command menu.

B.3 `.mnu` Files

A `.mnu` file describes:

1. Prompts that will be displayed on command menus.
2. Fields within command menus.
3. Operating system command-line arguments.
4. Help text for a command (optional).

You create a `.mnu` file by using an editor in XENIX such as vi, or by using the XENIX `cat` command. (See `cat(C)` in the XENIX Reference Manual for more information on the `cat` command.) All `.mnu` files should be stored in the `/bin` directory. The `/bin` directory must be a defined search path.

B.4 Command Menu Prompts

If you want the command menu to contain prompts, they should be inserted in the `.mnu` file just as they will appear on the screen. You may need to insert special characters to delimit fields. See the example `.mnu` files at the end of this appendix for more information.
B.5 Command Menu Fields

There are two types of fields in a command menu:

1. **Menu fields**: Field selection is with a menu and you choose one of the options. Example:

   
   who: Me All Group Others

2. **Fill-in fields**: The response is text and you type a response, such as a filename. Example:

   
   filename:

A `.menu` file contains a description for each field, whether it is a menu field or a fill-in field. Each field description describes the field's type, default value, and any other type-specific information. The following is a list of field types:

<table>
<thead>
<tr>
<th>Field type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SELECT</td>
<td>Selection is from a menu.</td>
</tr>
<tr>
<td>FILENAME</td>
<td>Allows directory window selection and text.</td>
</tr>
<tr>
<td>FILENAMELIST</td>
<td>Allows directory window selection and text.</td>
</tr>
<tr>
<td>PARAMETERS</td>
<td>This is a text field.</td>
</tr>
<tr>
<td>OUTPUT*</td>
<td>This field is for output information.</td>
</tr>
<tr>
<td>NUMBER</td>
<td>This is an integer field (number).</td>
</tr>
<tr>
<td>DIRECTORY</td>
<td>Allows directory window selection and text.</td>
</tr>
</tbody>
</table>

OUTPUT* fields determine redirection of I/O. If used, the Visual Shell adds the necessary symbols, commands, and file names to the command line that is processed by XENIX. SELECT field types must always be followed by a series of text strings, one for each option in the field. These are generally used to specify switches.

Each field type has a fixed prompt that will appear at the bottom of the menu when the field is selected; for example, "Enter a filename."

You can include a default response for each field type. That is, the Visual Shell can automatically display a response to a field when the command menu first appears. There are several different kinds of defaults for fields:
Making Your Own Menu Files

Default Value      Description

POINT             File or directory from directory window (if open).

<number>           Indicates option in menu-type selection.

'any string'       A string for a fill-in field. Quotation marks will be stripped. For example, note that a <number> field is a fill-in field, so its default is a quoted string.

B.6 Command Lines

After you have described the command menu prompts and fields, the .mnu file must contain a description of the command line. The Visual Shell uses this information to build the line that will be executed by XENIX. The command line description is a line with placeholders for variables that the Visual Shell will provide. The placeholders take the form “x”, where “x” is an integer that indicates the command menu field that supplies the value. The line appears as “exec = template” in the .mnu file, where “template” stands for the executable command line. See the .mnu files at the end of this appendix for examples of the “exec=” line.

B.7 Help Text

Help text appears whenever you press the HELP key or use the Help command. This text will only be displayed if you ask the Visual Shell for help when choosing the top-level command or while in the command menu. You can type any text after the command argument line (exec=) in the .mnu file. Your text should begin after this line.

Help text must be separated from the .mnu file description by a line consisting of five hyphens.

B.8 Examples

The following examples show two typical .mnu files. The first .mnu file is named /bin/get.mnu, and provides a unique command menu for the XENIX command get that a user has added to the top-level Visual Shell menu. The second .mnu file is named /bin/spread.mnu, and provides a unique command menu for a spreadsheet application that a user wishes to select from the top-level menu. Each .mnu file contains Help text.
Note

Both of these examples assume that the user has already added the commands Get and Spread to the top-level menu. See Section 4.5 in Chapter 4, “Using Advanced Features,” for details on adding user commands to the Visual Shell.

Example 1: get.mnu

GET string: ^ fieldenam e: ^ linenum bers: ^ Yes No ^
   casesensitive: ^ Yes No ^ output: ^
   fields
   1 parameters
   2 filename
   3 select = 2
      "-n"
      ""
   4 select = 1
      "-y"
   5 output OPT
   exec = "fgrep "3 "4 "1 "2"

GET finds a string in a file. If the "linenumbers:" command field is set to "Yes", GET reports the line numbers that contain the string. If the "casesensitive:" command field is set to "Yes", GET reports strings that exactly match the string and does not ignore case. You can direct output to a file or printer by specifying a filename or device name in the "output:" command field.

Typing a bar symbol (|) in the "output:" command field brings up the Filter menu.

Example 2: spread.mnu

SPREAD filename: ^
   fields
      1 filename OPT
      exec = "/bin/mp /bin/mp ^1"

SPREAD runs the electronic spreadsheet named Multiplan. Specify the filename of the worksheet in the field. If no worksheet is specified, Multiplan starts with a blank spreadsheet.
Appendix C
Message Directory

C.1 Messages C-1
C.1 Messages

The Visual Shell displays the following messages on the message line:

Already at bottom of directory
Already at top of directory
At first character in field
At last character in field
Bad Help file
Cannot write to Help pointer file
Command is too long
Command not found
Default specifier not recognized
Enter Y to confirm
Enter Y to retry access to
Enter a filename or press \ to view filter menu
Enter a filename or select from list
Enter an integer
Enter name of command
Enter name of menu item or select from list
Enter new path
Enter one or more filenames or select from list
Enter options
Enter text of new menu item
Error changing directories
Field has too many words
Field not optional
Field number greater than limit
Field number less than one
Field type not defined
File is empty
File not found
First letter conflict with existing menu item
Help file not available
Inappropriate field type for fill-in field
Inappropriate field type for menu field
Insufficient memory
Menu item not on current menu
Menu must be empty to be deleted
Missing "=
Missing command field type
Missing default specifier
Missing end quote
Missing field number
Missing quoted menu value descriptions
Missing sheet name in property sheet
Multiple responses are not allowed
Name list is empty
No character to delete
No character to delete
Not a valid character
Not a valid default for a menu
Not a valid default function
Not a valid integer
Not a valid key
Not a valid option
Not a valid path name
Path is too long
Permission denied
Select option
Select option or type command letter
Too few command field definitions
Too many command field definitions
Trailing characters not valid in
Unexpected end-of-file
Unexpected end of line
Unknown internal function
Word not recognized
Wrong command field number
Wrong number of field type
You cannot modify this menu
Index - Visual Shell User’s Guide

Adding commands to menus 4-8
Appending responses 2-2
Applications, running 3-25
Arguments 3-26
Asterisk (*) 1-4

BACKSPACE key 2-1
Bar ([]) symbol 1-5
Bar ([]) symbol 3-26
Batch files 3-25

CANCEL key 2-1
CANCEL key 2-2
Canceling a Mail message 3-32
Changing command menus 4-15
Changing the menus 4-7
Closing the window 4-4
Command screen 1-1
Command
  line 1-1
  line B-5
  mapping A-1
  menus, changing 4-15
  output 1-2
Copy command 6-2
Copy Directory command 3-17
Copy Directory command 6-3
Copy File command 3-6
Copy File command 6-4
Copy File menu 3-8
Copying directories 3-17
Copying files 3-6
Count 3-27
Creating files 3-1

Date 1-3
Definitions 1-4
Delete command 3-18
Delete command 3-8
Delete command 6-5
Deleting a Mail message 3-32
Deleting commands from menus 4-11
Deleting directories 3-18
Deleting files 3-8
Deleting responses 2-1
Deleting text 2-2
Directories 1-4
Directories
copying 3-17
deleting 3-18
Managing 3-12
Showing 4-1
transferring to other 3-15
Directory Make Menu 3-14
Directory tree 3-12

Edit command 3-1
Edit command 6-6
Edit cursor 2-2
Editing a Mail message 3-32
Editing responses 2-1
Equal sign (=) key 4-2
Error messages 1-4
Error messages C-1
Expanding the window 4-3

Filenames 1-4
Files 1-4
Files
copying 3-6
Creating 3-1
deleting 3-8
managing 3-3
printing 3-9
renaming 3-5
Showing 4-3
viewing 3-3
Filter menu 1-5
Filter menu 3-26
Filter menu 3-30
Filters 1-5
Filters 3-27
Filters
Filters (continued)
  Count 3-30
  custom 3-27
  Get 1-5
  Get 3-30
  Head 3-30
  More 1-5
  More 3-30
  Sort 1-5
  Sort 3-30
Floppy disks
  managing 3-20

Get 3-27
Getting Help 3-34
GOAWAY key 4-2
GOAWAY key 4-3

Head 3-27
Help Next 3-35
Help
  command 1-1
  command 3-34
  command 6-7
  Introduction 3-35
  Keyboard 3-35
  menu 3-34
  Menus 3-35
  Previous 3-35
  Resume 3-35
How to choose commands 2-1
Hyphen (−)key 4-2

Illegal option 2-1
Increasing size of window 4-3
Inserting text 2-2

Key directory 5-1

Mail 1-3
Mail
  canceling a message 3-32
  deleting a message 3-32

Mail (continued)
  editing a message 3-32
  reading 3-32
  saving a message 3-32
  sending 3-33
  Main command menu 1-3
  Managing directories 3-12
  Managing disks 3-20
  Managing files 3-3
  Menu
    adding commands 4-8
    deleting commands 4-11
  Message directory C-1
  Message line 1-4
  .mnu files 4-15
  mnu files
    Help text B-5
    OUTPUT fields B-4
  MODIFY (@) key 4-11
  MODIFY (@/key 4-7
  Modify Delete menu 4-11
  Modify Insert menu 4-10
  Modify menu 4-8
  Modify Rename menu 4-13
  More 3-27

Name command 3-5
Name command 6-9
Name menu 3-6

Options command 6-10
Options Directory Make command 6-11
Options Directory Usage command 6-11
Options Filesystem Create command 6-13
Options Output command 1-3
Options Output command 6-17
Output: command field 1-5
Output: command field 3-27

Pathnames 1-4
Piping 1-5
Piping 3-27
Print command 3-9
Print command 6-19
Print menu 3-10
Printer 3-9
Printing files 3-9

Question mark (?) key 3-35
Question mark (?) special character 1-4
Quit command 3-37
Quit command 6-19
Quit screen 3-37

Reading mail 3-32
REDRAW key 2-2
Renaming commands 4-12
Renaming files 3-5
Replacing text 2-2
RETURN key 2-1
RETURN key 2-2
Run command 3-25
Run command 3-27
Run command 6-20
Run menu 3-28
Running applications 3-25

Saving a Mail message 3-32
Sending mail 3-33
SHOW key 4-2
SHOW key 4-3
Showing a directory 4-1
Sort 3-27
SPACEBAR 2-1
Special characters 1-4
Status line 1-2
Status line 1-3
Submenus
creating 4-14
modifying 4-14
Switches 1-5
Switches 3-26
Switches B-4

Tail 3-27
Text files, showing 4-3
Time 1-3
Transferring directories 3-15

View 3-16
View command 3-15
View command 3-3
View command 6-21
View menu 3-5
Viewing files 3-3

Window
closing 4-4
command 6-22
expanding 4-3
menu 4-5
permanent 4-3
temporary 4-3
using 3-3
using 4-1
Working directory 1-4