SCO ImageBuilder™

Composition and Business Graphics for Xenix

Communication Dynamics, Inc.
Tigard, Oregon

The Santa Cruz Operation, Inc.
Santa Cruz, California
Information in this document is subject to change without notice and does not represent a commitment on the part of The Santa Cruz Operation, Inc. The software described in this document is furnished under a license agreement or nondisclosure agreement. The software may be used or copied only in accordance with the terms of the agreement.

ALL USE, DUPLICATION, OR DISCLOSURE WHATSOEVER BY THE GOVERNMENT SHALL BE EXPRESSLY SUBJECT TO RESTRICTIONS AS SET FORTH IN SUBDIVISION (b) (3) (ii) FOR RESTRICTED RIGHTS IN COMPUTER SOFTWARE AND SUBDIVISION (b) (2) FOR LIMITED RIGHTS IN TECHNICAL DATA, BOTH AS SET FORTH IN FAR 52.227-7013.

© 1988 The Santa Cruz Operation, Inc.

SCO The Santa Cruz Operation and the SCO logo are trademarks of The Santa Cruz Operation, Inc.

ImageBuilder is a trademark of Communication Dynamics, Inc.
MAGICorp is a registered trademark of MAGICorp, Ltd.
FoxBASE is a trademark of Fox Software, Inc.
SCO Lyrix is a registered trademark of The Santa Cruz Operation, Inc.
SCO Professional is a trademark of The Santa Cruz Operation, Inc.

Product: IB-01-01-88-1.0.0
Processed: Tue March 8 12:24:11 PST 1988
Welcome

Welcome to the SCO ImageBuilder drawing and charting program. Now you can easily create professional-looking graphics for your presentations and publications. SCO ImageBuilder turns your information into impressive 35mm slides, transparencies, or printed and plotted output.

Create text charts, organization charts, diagrams, and free-form drawings with the program's Draw menu. Combine pictures, enhance data charts or incorporate pre-drawn symbols into your images. Produce attractive bar, line, area, pie, scatterplot, and mixed-type charts with the program's powerful Chart capability. Enter your data directly or import values from an SCO Professional™ worksheet.

Produce output on a printer or plotter attached to your computer, or transmit images to the MAGICorp™ slide service for fast processing as high-quality 35mm slides and transparencies.

SCO ImageBuilder works with other SCO applications. Transfer SCO ImageBuilder images to SCO Lyrix™ for integration with text in a document. If you wish, bring data from SCO Professional or SCO FoxBASE™ into the program's charting area.
About This Guide

The *SCO ImageBuilder User's Guide* is designed to provide both beginning and expert users with easy access to program information. The *User's Guide* is divided into three sections:

**Part One: Introduction**

Introduces you to the basics of creating good graphics. Discusses using visuals to enhance written and verbal presentations. Provides an overview on how to use the program, including such basics as selecting menu items and getting Help. Read this section first.

**Part Two: SCO ImageBuilder Tutorial**

Takes you through four exercises, about 15 minutes each, to acquaint you with fundamental program functions. Going through the exercises in the tutorial is the best way to quickly become familiar with operating the program.

**Part Three: Command Reference**

Describes each command and gives step-by-step instructions for performing tasks. Refer to this section for detailed information on using the program.
TABLE OF CONTENTS

PART ONE: Introduction

Good Graphics Get Noticed ................................................................. 1-1
Choosing the Right Medium ................................................................. 1-1
   Paper Output .................................................................................. 1-2
   35mm Slides ................................................................................ 1-2
   Transparencies ............................................................................. 1-3
Giving a Good Presentation ................................................................. 1-4
Building a Better Text Chart ................................................................. 1-5
Building a Better Data Chart ................................................................. 1-7
Using the Program............................................................................. 1-9
   Setting Up and Starting the Program ............................................ 1-10
   Using the Screen ........................................................................ 1-10
   Using Menus ............................................................................. 1-13
   Using the Keyboard .................................................................. 1-14
   Using a Mouse or Tablet ............................................................ 1-18
   Getting Help ............................................................................. 1-18

PART TWO: SCO ImageBuilder™ Tutorial

Exercise 1: Creating a Text Chart......................................................... 2-2
Exercise 2: Creating a Data Chart......................................................... 2-8
Exercise 3: Enhancing Your Chart....................................................... 2-12
Exercise 4: Making 35mm Slides ......................................................... 2-18
PART THREE: Command Reference

Main Menu Commands .......................................................... 3-1
Drawing Commands ............................................................. 3-3
  Create ........................................................................... 3-5
  Modify .......................................................................... 3-28
  Erase ........................................................................... 3-43
  Transfer ......................................................................... 3-43
  Print ............................................................................. 3-46
  File ............................................................................. 3-47
  Zoom ........................................................................... 3-54
  AddChart ....................................................................... 3-56
  Quit .............................................................................. 3-60
Charting Commands ............................................................... 3-61
  Data ............................................................................ 3-63
  ChartType ..................................................................... 3-66
  Options ......................................................................... 3-76
  Layout .......................................................................... 3-83
  Erase ........................................................................... 3-98
  Transfer ......................................................................... 3-99
  Print ............................................................................. 3-101
  File ............................................................................. 3-102
  Quit .............................................................................. 3-106
Background and Palette Commands ........................................ 3-107
  Background ................................................................. 3-107
  Palette ......................................................................... 3-109
MakeSlide and Quit Commands .................................................. 3-121
MakeSlide ............................................................................. 3-121
SlideList .................................................................................. 3-122
Orderform ............................................................................. 3-126
Quit or ReturnToPro ............................................................... 3-136

APPENDIX A

SCO ImageBuilder Keys .......................................................... A-1

APPENDIX B

Messages ............................................................................... B-1

APPENDIX C

Command Structure ............................................................... C-1

APPENDIX D

Symbol Library ........................................................................ D-1

INDEX
Replace this Page with Tab Marked:

Introduction
Good Graphics Get Noticed

Good graphics strengthen your presentations. Many studies have shown that attractive projected visuals, such as 35mm slides and transparencies, actually increase a speaker’s power to persuade. Printed charts and diagrams can be equally beneficial. An illustrated report, for instance, is more likely to receive favorable attention than a report with no graphics.

You can easily create the graphics you need for presentations and publications with SCO ImageBuilder. To use the program successfully, you don’t need to have artistic talent, just the ability to follow a few simple graphic rules. This section presents some tips on how to create the most effective graphic images possible.

Choosing The Right Medium

Once your images are created, you can transform them into output in one of several ways. A printer or plotter attached to your computer creates paper hardcopy. Images can be transferred to SCO Lyrix™ to publish in a document. Or, you can automatically transmit your images to the MAGICorp™ slide service for processing as high-quality 35mm slides, transparencies, color prints, or black-and-white copies.
Paper Output

Paper output can be used to illustrate reports, display on the wall, supply camera-ready art, or serve as a record of a slide presentation. A quickly printed chart may clarify complex data for your own use in writing a letter or report. A budget request you supplement with graphics may elicit more dollars than one presented without visuals. As a speaker, you can make a lasting impression by supplying your audience with handouts of your most important projected images.

You can use a graphics printer or plotter to create paper hardcopy, or obtain color photographs or black-and-white printed copies of your images from the MAGICorp slide service. In addition, you can integrate graphics and text in documents by transferring a picture or chart to SCO Lyrix.

35mm Slides

No medium makes you look more professional than 35mm slides. Slides help you convey an image of polish and credibility. Projected slides are sharp, colorful, and impressive. Your audience is more likely to remember you and your message when you back up your ideas with vivid slide images.

If you have a large audience, slides are the best media choice. Images with dark-colored backgrounds and lighter, contrasting text and charts make the best slides. If possible, do a test run with a slide projector in the room you plan to use, to make sure
your graphics are legible from the back of the room, and that your slides are all upright in the carousel. The MakeSlide command lets you transmit your images to the MAGICorp slide service for expert processing. Slides come back to you via overnight courier. ("Exercise 4: Making Slides" in Part Two: SCO ImageBuilder Tutorial gives step-by-step instructions for sending images to MAGICorp.)

Transparencies

If you are presenting information to a small audience, consider using overhead transparencies. Transparencies allow you to use normal room lighting, so audience members can easily make notes, and you can maintain eye contact with people. You create a friendly atmosphere with transparencies.

It's a good idea to use more intense colors for transparency graphics, as pastels may become washed out when projected. Choose neutral to medium-dark background colors like gray, white and blue. Test your transparencies by positioning them against a light wall. If you can read them at a distance of 10 feet, they will project well.

You can produce transparencies on a plotter or obtain them from the MAGICorp slide service. Transparencies require an extra day of processing.
Giving a Good Presentation

You can use SCO ImageBuilder to enhance your next presentation with professional-looking 35mm slides or transparencies. Visuals will support you, but there's nothing like planning ahead and knowing what you're going to say for making a sound presentation.

Plan your presentation

Be sure of your purpose. State your main point when you begin and end your presentation. Focus on a few major concepts. Develop a logical flow of material, presenting information from simple to complex, familiar to new, factual to theoretical.

Create well-designed visuals

This program has everything you need to turn your data into professional-looking visuals, especially if you are aware of some simple rules for creating good graphics. The following tips may help you avoid creating ho-hum or bad graphics that could distract audience attention from you and your message:

- **Keep it simple.** Use only a few words or a small amount of data in each graphic. The visual is there to support you, not to entertain. The more direct the image, the easier it is for the audience to absorb.
• Make the page look good. Keep the visual weight between text and graphics balanced. Leave plenty of white space around text and graphics. Make bottom margins larger than top margins.

• Unify your presentation. Use only a few colors from the same color palette throughout your presentation. Keep text styles and text sizes the same for all your images. A border or a simple logo added to every visual provides pleasing consistency.

Rehearse your presentation

Make sure your equipment works and that each visual is legible at a distance (and right side up!) when projected. Check to ensure that your slides or transparencies are in the right order. Be comfortable with your graphics, so you can focus your attention on your listeners. Good, well-rehearsed graphics give you confidence -- an attitude you'll naturally convey to the audience.

Building a Better Text Chart

Text charts are graphic images composed of words and simple graphics, as shown in Figure 1-1. Text charts may comprise as much as 80% of a presentation. You can use text charts to cue your topics and focus the audience on your key points. Showing a series of text chart slides, each with a line of text added, until a complete text chart is presented, rivets interest on your next
point. ("Exercise One: Creating a Text Chart" in Part Two: SCO ImageBuilder Tutorial tells you how to create a text chart.)

Keep in mind the following tips as you create text chart images:

- Layout of a text chart should be clear and simple, so the audience can quickly read and understand its contents. The most effective text charts are composed of 1 or 2 titles and up to 6 lines of text with no more than 6 words per line. Use key words and phrases instead of sentences. Separate each concept with an identifying number or bullet.
(symbol marker). Leave ample margins and plenty of white space between lines.

- **Fonts** are lettering styles. Limit yourself to 2 fonts used consistently in all text charts. Use one font for titles and text, and a second only when you need to emphasize a key word or phrase. In general, boldface fonts are easiest to read. Text that combines upper- and lower-case letters is most legible. Make your letters large enough to be seen from the back of the room when projected.

- **Color** works best if you limit yourself to 2 colors for your text, and use the same colors for all the text charts throughout your presentation. Now and then, you can use a third, brighter color to call attention to key points. A good contrast between background and text colors is essential for legibility.

**Building a Better Data Chart**

Numbers scrawled on a board at the front of a room mean little to viewers who still have to calculate their relationship. Even if you are showing findings informally to peers, the program’s attractive line, bar, area, pie, scatter, and mixed charts allow others to understand quickly the meaning behind the numbers.

Use SCO ImageBuilder to construct your charts, and you will find that most of the work has been done for you. **Figure 1-2** shows a default vertical bar chart, which is automatically drawn when
data is entered into the program. The program automatically creates color-coordinated charts and graphically correct labels, legends and axes. You can easily see your data plotted in a variety of chart types. You can even bring SCO Professional™ spreadsheet data or SCO FoxBASE™ data into the program's data area.

("Exercise Two: Creating a Data Chart" and "Exercise Three: Enhancing Your Chart" in Part Two: SCO ImageBuilder Tutorial give step-by-step instructions for creating and enhancing data charts.)

Keep in mind the following tips as you create your charts:

- **Layout** for charts should have a big, bold, "clean" look that can be read easily from a distance. Keep your chart simple, so viewers can quickly understand its meaning. You can emphasize a particular aspect of your data with graphic enhancements like arrows or bright colors.
Introduction

- **Data** should be kept to a minimum in a chart. Make sure your data is correct before you project it for the world to see. Put the source of your data at the bottom of the chart. Even if it's not truly legible from the back of the room, the audience knows it's there and finds the chart more credible.

- **Labels** used sparingly give your chart an uncluttered appearance. Position labels to read from left to right. You may elect to remove or simplify some of the finer text that appears along the axes. In lieu of a legend, you can opt to label individual bars, lines, and areas directly.

- **Color** has impact. Choose colors that seem appropriate to the type of audience you will be addressing. Limit yourself to a few colors per chart. Display the most important part of the chart in the brightest color, so the eye will be drawn to it first. Arrange darker colors, like blue and green, before lighter colors, like yellow and orange. Avoid use of red and green to compare crucial values on a chart, because some people have difficulty distinguishing between those colors.

**Using the Program**

This section describes the basics of operating the SCO ImageBuilder. It familiarizes you with the overall structure of the program and tells you how to perform general tasks.
Setting Up and Starting the Program

You need a graphics terminal to run the program, and a graphics printer or plotter to produce paper output. (For instructions on setting up the program with your output device, refer to the Release and Installation Notes that came with the SCO ImageBuilder manual, or contact your system administrator.)

To start the program: type `image` at the prompt, and press `<Return>`.

Using the Screen

SCO ImageBuilder is composed of several levels of menus. A *menu* is a list of choices. The choices are called *commands*. At the top of the screen, as shown in Figure 1-3, there are three lines of information:

![Figure 1-3 The SCO ImageBuilder screen](image)

**Status line**
**Menu line**
**Prompt line**

Graphics Area
• The first line is called the *status line*. It shows all the menu commands you have selected to reach your current place in the program. You can see how deep you are in the program's menu levels with a glance at the *status line*. For example, if the status line reads "Draw/Create/Text," you are three levels deep. (To move up through menu levels, press `<ESC>` until you reach the menu you want.)

• The second line is called the *menu line*. It displays the menu of the currently selected command. For example, if you had just selected Draw, the *menu line* would show the Draw menu: "Create, Modify, Erase, Transfer, Print, File, Zoom, AddChart, and Quit." You select a command on the *menu line* to continue performing a function.

• The third line is called the *prompt line*. It describes the action you can perform with the command that the cursor currently touches. When you reach a point of entering information into the program, the *prompt line* tells you what to do next.

Below the three lines of information, the main portion of the screen contains one of the following:

• A *graphics area*, which is a blank area on the screen in which a picture or chart is drawn. The screen sidebar on the right side of the graphics
area contains information about the current picture or chart.

- A display in which you select or enter information. Some displays contain fields in which you enter information or select a choice. There are also lists from which you select items.

**NOTE:** Help is available on any menu command, option, or field in a display the cursor touches, by pressing `<F1>`.

**Selecting an Object or Location in the Graphics Area**

To create pictures in the Draw graphics area, you move the cursor to an object or location, and then press `<Return>`. You can move the cursor in a number of ways to create objects:

Use the arrow keys to move the cursor up, down, left, or right. Use the `<Home>`, `<End>`, `<PGUP>`, and `<PGDN>` keys to move the cursor diagonally. Press and hold the `<Shift>` key while pressing one of the cursor keys to move the cursor in very small steps, for precision drawing.

You can instantly center the cursor in the graphics area by pressing `<Shift> <Numeric Pad 5>`. When you are selecting an object to modify, move the cursor to a corner of the object, to ensure selection of the right object.
Using Menus

The SCO ImageBuilder main menu is the top level menu that appears when you start the program. All other menus branch off from the main menu.

To perform a function, you select (activate) one command from each of several menus until you reach a point where you are asked to enter information into the program. For example: to create text, you select the Draw command from the main menu. Then you select Create from the Draw menu. The Create menu appears, and you select Text. At that point, you begin the process of actual text entry.

Selecting a Menu Command

There are two ways to select a menu command:

- Move the cursor along the menu line (with the <Right> and <Left> arrow keys or a mouse) to the command of your choice, and press the <Return> key.

- Press the first letter key of the command.

Selecting From Options Menus

Some menus are made up of options (drawing characteristics for objects or charts). Options menus may contain more choices than fit on the menu line. A small arrow appears on the right end
of the visible choices. To scroll the menu line so that you may see all the choices, move the cursor over the arrow.

NOTE: Some options menus contain more than one item beginning with the same first letter. Select the option by typing the first letter until the cursor highlights the option you want, then press <Return>.

Using the Keyboard

You can perform special functions with certain keys on the keyboard. Each of these keys is designated by the name of the key surrounded by brackets (< >). Some key names are abbreviated, such as <ESC> for the Escape key and <BKSP> for the Backspace key.

The following keys perform the functions described below:

<Return>
Select highlighted commands or options on the menu line, fields in the displays, and objects in the Draw graphics area. Complete some actions.

<BKSP>
Undo the last action. Erase text to the left of the cursor, one character at a time.

<ESC>
Return to a menu one level above the current menu.
Leave the online Help system.
Complete some actions in the graphics area.

<!>
Perform a Shell Escape to leave SCO ImageBuilder temporarily and return to the operating system. (Type "exit" and press <Return> to reenter the program.)

< ? >
Get Help on any highlighted command or option.

< Space Bar >
Interrupt redrawing of the graphics area. Erase a value or label in the Data display.

< Arrow Keys >
Move the cursor to a command on the menu line, to a field in a display, or to a location in the Draw graphics area.

< Right >
Move the cursor to the right.

< Left >
Move the cursor to the left.

< Up >
Move the cursor up.

< Down >
Move the cursor down.
<Arrow Keys>
Move the cursor very small steps in the Draw graphics area.

<PGUP>
Move the cursor diagonally (up and right) in the Draw graphics area. Go to the previous page of Help. Scroll up some lists.

<PGDN>
Move the cursor diagonally (down and right) in the Draw graphics area. Go to the next page of Help. Scroll down some lists.

<Home>
Move the cursor diagonally (up and left) in the Draw graphics area. Go to the first command, option, or field in a display or list.

<End>
Move the cursor diagonally (down and left) in the Draw graphics area. Go to the last command, option or field in a display or list.

<Numeric Pad 5>
Center the cursor in the Draw graphics area.
[F1] (HELP)
   Get Help on any command or option on the menu line, or on fields in the displays.

<F2> (MOUSE)
   Turn on a mouse or tablet attached to your computer.
   Turn off the mouse or tablet.

<F3> (INSERT)
   Insert a value or label in a data set.

<F4> (DELETE)
   Delete a value or label in the Data display to shorten a data set. Delete a text character as you enter text.

<F5> (AUTOMATIC REDRAW)
   Automatically redraw the screen each time you modify an object in the Draw graphics area. Turn off the automatic redraw function.

<F6> (PREVIEW)
   Preview picture or chart file listed in the MakeSlide or File displays.

<F9> (REDRAW)
   Redraw the screen.

<F10> (QUICK EXIT)
   If you entered SCO ImageBuilder from SCO Professional, immediately exit SCO ImageBuilder and return to SCO Professional.
Using a Mouse or Tablet

A mouse or tablet makes SCO ImageBuilder even easier to use. You can move the cursor around the screen rapidly. Simply slide the hand device across a smooth surface, in any direction.

If you have a mouse or tablet attached to your computer, it is automatically activated. Press the <F2> key if you want to turn off the device. (Press <F2> again to turn the device on.)

On a mouse or tablet, button functions are the following:

- 1st button <Return>
- 2nd button <ESC>
- 3rd button <Undo>
- 4th button <Redraw>

Getting Help

You can get help on any command, option, or field in a display the cursor touches by pressing <F1>. The program displays a screen containing useful information on the item your cursor currently touches. The page number of each Help screen appears in the upper right corner of the screen. The following keys are active in Help:
Introduction

- <PGDN> Go to the next screen.
- <PGUP> Return to the previous screen.
- <ESC> Return to your place in the program.
- <F1> Get Help on general topics. (To select a general topic: move the cursor bar to the topic of your choice, and press <Return>.)
Replace this Page with Tab Marked:

Tutorial
SCO ImageBuilder TUTORIAL

Take this short tutorial before you need to give a presentation or create illustrations for a report. To gain an understanding of the program's continuity, we recommend you do the tutorial in a single session. It takes about one hour. You will learn to:

- Create a text chart.
- Create a bar chart from your data.
- Enhance a chart with additional text and graphics.
- Send your images to a slide service for processing as 35mm slides.

Before You Begin . . .

To do the tutorial, you'll need a graphics terminal. A graphics printer or plotter to produce output is optional. (To set up the program with your output device, refer to the output variable information in the Release and Installation Notes, or contact your system administrator.)

To start the program: type image at the prompt, and press <Return>.

The four tutorial exercises that follow are to be taken together. One exercise builds upon another. Each takes about 15 minutes.
It's a good idea to skim the information contained in *Part One: Introduction* before you take the tutorial. That way, you'll have the necessary background to move rapidly through the exercises. By the time you complete the tutorial, you'll be ready to begin creating graphics for professional use.

Commands you are asked to select, or information you type into the program are described in **boldface** text.

**To Select a Menu Command**

Move the cursor along the menu line (with the `<Right>` and `<Left>` arrow keys or a mouse) to the command of your choice, and press the `<Return>` key. Alternatively, press the first letter key of the command.

**To Get Help**

Place the cursor over any command or display you don't understand, and press `<F1>`. Useful information appears on the screen. Press `<ESC>` to return to your place in the program.

**EXERCISE 1: Creating a Text Chart**

We'll begin by creating a text chart, a graphic image composed mostly of words. When you are finished with this exercise, your screen will resemble Figure 2-1, although some variation is possible, due to hardware differences.

Before entering your text, you'll set the text options (drawing characteristics) that will determine how your text looks.
1. Move the cursor to the Draw command (if it is not already there). Press <Return> to select Draw. The Draw graphics area appears. This is where your picture will be drawn on the screen. Press <Return> again to select Create.

2. Select Options, followed by Text.

3. Select Font, followed by Bold. (Fonts are lettering styles.)

4. Select Height, followed by 7.

5. Select Justify, followed by Left.

6. Select Quit to return to the Options menu, followed by <ESC> to return to the Create menu.
Now you can enter your text, beginning with the title of your text chart.

1. Select **Text**. (*Notice that the text options you just set appear in the screen sidebar on the right side of the screen.*) The text cursor appears in the graphics area.

2. Move the cursor with the `<Up>` and `<Left>` arrow keys to a location in the upper left corner of the graphics area, where you want the first letter of your title to appear. Press `<Return>`. The cursor appears on the menu line.

3. Type **Agenda**. (*If you make a mistake while typing, press the `<BKSP>` key to erase text one character at a time.*) Press `<Return>` to see the text written in the graphics area.

Now, you will learn how to change options while in the middle of creating text.

4. Press `<ESC>` to put the cursor back in the graphics area. Type "0" to select text options automatically.

5. Select **Height**, followed by 6. Press `<ESC>` to return to creating your text.

6. Press the `<Right>` arrow key one time to indent the next line of text. Press `<Return>`. The cursor appears on the menu line.
7. Type **New Product**, and press `<Return>`. (The dash provides a *bullet* marker that defines the line as a separate unit of text.)

8. Type **Demonstration**, and press `<Return>`.


Now, let's add a ruling bar to give your text chart a more finished appearance.

1. Press `<ESC>` two times to return to the Create menu, then select **Box**.

2. Type "o" to select box options.

3. Select **Pattern**. Pattern names appear on the menu line. Move the cursor over the arrow at the end of the line to view all the patterns. Select **MedSlant**. Press `<ESC>` to continue creating a box.

4. Move the cursor against the left edge of the graphics area (about 1" below your text), and press `<Return>`.

5. Press and hold the `<Shift>` key while you press the `<Down>` arrow key eight times. (*Notice that pressing the `<Shift>` key along with the arrow key allows you to move the cursor in much smaller steps.*)
6. Press and hold the <Right> arrow key to draw the box across the screen until it stops against the right edge of the graphics area.

7. Press <Return> to complete the box. (If, for some reason, you don't like the ruling bar you just created, you can press <BKSP> to undo the box and begin again by going back to Step 4.)

Company initials (or a logo) add a final touch to a text chart. This time, we'll use a short-cut method of selecting text options.

1. Press <ESC> to return to the Create menu. Type "o" to select Options.

2. Select Text.

3. Type "f" to select Font. Type "c" to select Classic.

4. Type "h" to select Height. Type "7" to select a new height.

5. Type "j" to select Justify. Type "r" to select Right. Press <ESC> twice. Type "t" to select Text. (Notice that the text options in the screen sidebar have changed to reflect the selections you just made.)

6. Move the cursor to a location about 1" from the right edge of the graphics area and about 1/4" from the bottom edge of the graphics area. (Remember that you
can press and hold the <Shift> key while pressing the arrow keys to position the cursor more precisely.)

7. Press <Return> to select this location. (Since your text is right-justified, the last letter of text will appear at the location you just selected.)

8. Type SCO, or your company's name, and press <Return>.

Your text chart is complete. Now you can save it with the File command.

1. Press <ESC> three times to return to the Draw menu. Select File. The File display appears.

2. Select Save. Press <Return> to select the NewFile box, so that you can save your text chart under a new name.

3. Type Agenda, and press <Return>. Press <ESC>. Your screen should now look somewhat like Figure 2-1, although some variation is possible, due to hardware differences.

Now you can turn your text chart into printed or plotted hardcopy, if you have an output device attached to your computer. (For instructions on setting up SCO ImageBuilder with your output device, refer to the output variable information in the Release and Installation Notes that came with the SCO ImageBuilder manual, or contact your system administrator.)
If you don't have an output device currently set up, you can still see what your text chart will look like as output in the following steps.

1. Select Print.

2. Do one of the following:

   If you have an output device set up: select Output. When your text chart is done printing, press <Space Bar> to stop the screen from redrawing.

   If you don't have an output device, select Preview. When you are done previewing, press <ESC> and then <Space Bar> to stop the screen from redrawing.

EXERCISE 2: Creating a Data Chart

Now you'll learn to create data charts. With SCO ImageBuilder, you can create several types of charts from your data.

1. Press <ESC> to reach the main menu. Select Chart. The Chart graphics area appears. This is where your chart will be drawn on the screen. But first, you must enter data for the chart. Data consists of values and labels.

2. Select Data. The Data display appears.
3. Select Calendar. (Monthly labels automatically appear in the label column on the left side of the display.)

4. Select DataEntry. The cursor appears in the first value location.

Before entering data, let’s take brief tour of the SCO ImageBuilder Help system. (You can get Help on any command, option, or display the cursor touches.)

1. Press <F1> to get Help on the Data display.

2. Press <F1> again to reach the program’s General Help Topics.

3. Move the cursor with the <Down> arrow key to any topic, and press <Return>.

4. Press <ESC> to return to your place in the program.

Now, you can enter your data into the Data display.

1. Press the <Up> arrow key. Type West. (If you make a mistake, press <BKSP> to erase text characters.)

2. Press the <Right> arrow key. Type East.

3. Move the cursor to the first space below West. (If you mis-entered "West" or "East," simply move the cursor to the mistake and retype the correct entry.) Type the fol-
lowing numbers, pressing `<Return>` after each one: 10 5 30.

4. Move the cursor to the first space below East. Type the following numbers, pressing `<Return>` after each one: 15 10 35. Press `<ESC>`.

5. Press `<ESC>` once more to see your data displayed as a vertical bar chart.

Now, let's simplify the Y axis (the vertical axis) to clarify the chart. First, you'll rescale the axis, then you'll simplify the axis labels. Finally, you'll place a legend on the chart.

1. Select **Layout**.

2. Select **YAxis**, followed by **Scale**.
3. Respond to prompts asking you to enter new Y axis values by typing the following numbers, pressing <Return> after each one:
0 40 20.

4. Select Precision, followed by NoDecimals. Press <ESC> to see your simplified Y axis.

5. Select Legend, followed by LegendInside.

Although SCO ImageBuilder's default (preset) chart type is the vertical bar, you can display your data as one of several chart types, depending on the message you want to convey. For example, a pie chart shows values as percentages of a whole. Let's see what some of your data looks like as a pie chart.

1. Press <ESC> to return to the Chart menu. Select ChartType, followed by Pie. Since a pie chart shows only one data set (column of values in the Data display), you will now select the name of a data set to plot as a pie chart.

2. Select East. The East data is drawn as a pie chart. Press <ESC>. Now, let's emphasize one of the pie slices by "exploding" (separating) it from the whole pie.

3. Select Options, followed by Explode.

4. Select Feb, as the slice to explode, followed by Explode-On. Press <ESC> to see the exploded pie slice. Now let's return to the vertical bar chart.
5. Select Chart Type, followed by Vertical Bar. Your vertical bar chart is redrawn. Press <ESC>.

Next, you can add titles to identify the contents of your chart.

1. Select Layout, followed by Titles.

2. Select Main, followed by Enter.

3. Type Sales Are Up. (Press <BKSP> if you make a mistake while typing.) Press <Return>.

Now, let’s enter a second title before seeing your title drawn on the screen.

1. Press <ESC> to return to the Titles menu. Select YAxis, followed by Enter.

2. Type In Millions, and press <Return>. Press <ESC> two times to see your titles.

**EXERCISE 3: Enhancing Your Chart**

Now you can transform your chart into a graphic image that really gets your message across. SCO ImageBuilder lets you add text and graphics to data charts in the Draw menu. Your screen will look somewhat like Figure 2-3 when you are done, depending on the type of display you have.
First, let's change the color palette and put a background color into the Draw graphics area.

![An enhanced chart](image)

**Figure 2-3** An enhanced chart

1. Press `<ESC>` two times to reach the main menu. Select **Draw**, followed by **Erase**. Select **Clear Picture** to erase the graphics area. (Your text chart has already been saved in the file, so it's all right to erase it now.)

2. Press `<ESC>` to return to the main menu. Select **Palette**. The Palette menu appears.

3. Select **Get**. *(The colors of the current palette appear at the bottom of a color display. Color names are listed if you have a black-and-white display.)* Move the cursor (with the arrow keys) to several palette names, until you see one you like. Press `<Return>` to make that
palette the current one.

4. Press <ESC> to return to the main menu. Select Background, followed by Solid. The colors of the current palette appear on the menu line. Move the cursor over the arrow at the end of the line to view all 16 colors.

5. Select a dark, neutral color. The background color is listed in the screen sidebar.

Now you're ready to add your bar chart to the Draw graphics area for enhancement.

1. Select Draw.

2. Select AddChart.

3. Select Add.

(A chart is added to the Draw graphics area as a whole unit called a symbol, so you can scale or move it. If you were going to modify its individual graphic elements -- change the color of a set of bars, for example -- you would have to undo the symbol. For the purpose of this tutorial, you will let the chart remain a symbol.)

Now let's add a large arrow to call attention to the point you intend to make. You'll learn cursor keys that move the cursor diagonally.

1. Press <ESC> to return to the Draw menu. Select Create.
2. Select Polygon. Type "o" to select polygon options.

3. Type "b" to select BorderColor. Select a light color like yellow. Type "l" to select InteriorColor, and select the same light color.

4. Type "p" to select Pattern, followed by s to select Solid. Press <ESC> to continue entering your polygon.

Now, you're ready to draw the arrow.

1. Press <Shift>, then the <5> key (on your keyboard's number pad) to center the cursor in the graphics area. (If you make a mistake while drawing this arrow, you can press <BKSP> to undo it, point by point.)

2. Press the <Up> arrow key two times, then <Return>.

3. Press <PGDN> two times, then <Return>.

4. Press <End> two times, then <Return>.

5. Press the <Up> arrow key one time, then <Return>.

6. Press the <Left> arrow key two times, then <Return>.

7. Press the <Up> arrow key two times, then <Return>.
8. Press the <Right> arrow key two times, then <Return>.

9. Press <ESC> to complete the polygon. (Notice that *SCO ImageBuilder automatically completes your polygon, for greater drawing precision.*)

Now, you can modify the arrow. (If you wish to redraw the picture after each modification, press <F5> to activate the automatic redraw feature. Then press <ESC> to continue.)

1. Press <ESC> two more times to return to the Draw menu. Select Modify, followed by Scale.

2. Move the cursor to the outer edge of the arrow, and press <Return>. A box appears around the arrow. (If you selected another object by mistake, press <BKSP> to undo your selection and reselect the arrow.)

3. Press and hold the <Shift> key while pressing the <Right> arrow key five times to scale the arrow smaller. Press <Return>.

4. Press <ESC> to return to the Modify menu. Select Rotate. Move the cursor to the outer edge of the arrow, and press <Return>. Press the <Right> arrow key to rotate the arrow to point toward the lower right of the graphics area. Then press <Return>.

5. Press <ESC>, and select Move. Move the cursor to the outer edge of the arrow, and press <Return>. Use the
<Up> and <Right> arrow keys to move the cursor to a location that will allow the arrow to point directly at the bar cluster labeled "Mar." Press <Return> to move the arrow.

6. Press <ESC> two times to return to the Draw menu.

Finally, you can add a line of text explaining the sales increase represented by the bars labeled "Mar."

1. Select Create, followed by Text. Type "o" to select text options.

2. Type "f" to select Font, then select ItalicLight. Type "h" to select Height, then Type "4." (Text justification should still be set at Right. If it is not, set that option now.) Press <ESC> to continue creating text.

3. Move the text cursor about 1/8" to the left of the arrow, and press <Return>. Since your text is right-justified, the last letter will appear at the location you just selected.

4. Type After ad campaign. (If you make a mistake, press <BKSP> to delete text characters.) Press <Return> to see the text appear on the chart.

Your enhanced data chart is now ready to save.

1. Press <ESC> three times to reach the Draw menu. Type "f" to select File. Type "s" to select Save. Press
<Return> to select the NewFile box to save your chart under a new name.

2. Type Sales, and press <Return> to save the enhanced version of your chart in the Draw file. Press <ESC> two times to return to the main menu.

EXERCISE 4: Making 35mm Slides

Now that you’ve created both a text and a data chart, you can easily transmit them to the MAGICorp slide service for expert processing as high-quality 35mm slides or transparencies. For the purposes of this tutorial, you will proceed up to the point of sending your images to MAGICorp.

Let’s prepare your images for a hypothetical transmission to MAGICorp.

1. Select MakeSlide. The MakeSlide display appears.

2. Select SlideList.

3. Select Add. The cursor appears on the first picture file, Agenda, listed on the left side of the display. Press <Return> to add Agenda to the Slide List on the right side of the display. (The Slide List is a list of images you assemble to send to MAGICorp.)

4. Press the <Down> arrow key, then press <Return> to add Sales to the Slide List. Your screen should now look like Figure 2-4. (Notice that Sales is listed as a
Next, you will enter important customer order information.

1. Press <ESC> two times to return to the MakeSlide menu. Select OrderForm, followed by Customer. A customer order form appears on the screen.

2. Type the correct information for each empty field in the form, and press <Return>.

(The first field, Site code, is for your customer identification code. If you don't already have a MAGICorp site code, call 1-800-FOR-MAGI (1-800-367-6244) now to obtain a code.)
3. After you have entered information in all the fields of the form, press <ESC> to return to the Order Form menu. The program saves the customer information you just entered, so you may never have to enter it again.

Now, you can specify the media you want to order.

1. Select Media. A media order information form appears on the screen. The cursor appears in the first field, *Number of slides*.

2. Type "2" in the *Number of slides* field, and press <Return>. This entry tells SCO ImageBuilder that you want to order two slides of each item in the Slide List. Notice that the *Total* box to the right of the field now lists "4." This means you’ve ordered two slides of the text chart and two slides of the bar chart, for a total of four slides.

3. Move the cursor with the <Down> arrow key to the *Slide mounting* field. (Since you are ordering slides and no other media, the *Slide mounting* field is the only other field in the form you’ll need to address.) The cursor highlights the currently selected choice.

4. Move the cursor to the *Wess* choice. Let’s assume for a moment that you aren’t familiar with slide-making and don’t know what Wess mounting is.

5. Press <F1> to access the program’s Help system. A description of the Wess mounting appears on the screen.
6. Press <ESC> to return to your place in the program.

NOTE: As you work with the program in the future, remember that you can get Help on any MakeSlide order form field you don’t understand by pressing <F1>.

Finally, you’ll enter some presentation order information.

1. Press <ESC> to return to the Order Form menu. Select Presentation. The presentation order form appears on the screen, with the cursor in the Priority field.

2. Move the cursor to the Normal choice (if it’s not already there). You are telling MAGICorp that you want normal priority processing (two-day turnaround).

3. Move the cursor with the <Down> arrow key to the Presentation name field. Type Tutorial, and press <Return>. Press <ESC> to return to the Order Form menu.

Now that you have prepared your images for processing as 35mm slides, you’ll see how simple it is to transmit them to MAGICorp.

1. Select Send. A summary of your order appears on the screen for your verification.

2. For the purposes of this tutorial, select No. Normally, you would select Yes to transmit the images in the Slide List to MAGICorp for processing.

You have just completed the tutorial.
To continue working with the program

Press <ESC> two times to return to the SCO ImageBuilder main menu.

To exit the program

1. Press <ESC>, followed by <Space Bar> to stop the screen from redrawing.

2. Select Quit. You receive a warning message telling you that the current chart is not saved. Since there is no need to preserve the unenhanced bar chart still in the Chart graphics area, press <ESC> to continue your exit.

3. Select Quit, and then press <Return> to select Quit-Program.
Replace this Page with Tab Marked:

Command Reference
Main Menu Commands

DRAW

Draw allows you to create and edit pictures. Pictures are composed of objects you draw on the screen. You can create text charts, organization charts, diagrams, and free-form drawings with the Draw command.

CHART

Chart allows you to create and edit data charts. First, you enter your data into the program. Then, you choose a chart type to represent your data. You can create line, bar, area, pie, scatter, or mixed charts with the Chart command.

BACKGROUND

Background allows you to give a picture or chart a solid background, or to create a gradated background.

PALETTE

Palette allows you to create, change, and manage color palettes. A color palette is a collection of 16 colors.
MAKESLIDE

MakeSlide allows you to transmit picture and chart files to the MAGICorp slide service for processing as high-quality 35mm slides, transparencies, color prints, or black & white copies.

QUIT or RETURNTOPRO

Quit allows you to exit SCO ImageBuilder and return to either the operating system or SCO Professional, depending on the location from which you entered the program.
Drawing Commands

Draw

Draw allows you to create a picture in the Draw graphics area. The graphics area is a blank area on the screen for drawing pictures.

Create a text chart, design an organization chart or logo for your company, draw a diagram, or doodle a free-form drawing with the Draw menu. You can add pre-drawn clip art from the program’s symbol library to your images. You can also combine pictures and enhance data charts in the Draw graphics area.

A picture may contain the following elements:

- Background color
- Text
- Lines
- Boxes
- Circles
- Polygons
- Symbols

Draw functions are performed on the current picture in the graphics area, which appears when Draw is selected.
The current picture may be an empty graphics area, a newly-created picture, or a picture you retrieve with the Draw File command, Get.

Figure 3-1 shows some sample pictures.
Select **Draw** to produce a picture by choosing from these items:

- **CREATE**  Add new objects to the current picture
- **MODIFY**  Edit the current picture
- **ERASE**   Erase the current picture
- **TRANSFER**  Transfer all or part of a picture to or from other programs
- **PRINT**   Preview the current picture on the screen, or produce final output
- **FILE** Get, add, save, or delete picture files
- **ZOOM** Magnify a portion of the current picture for precision-drawing
- **ADDCART**  Add the current chart to the picture
- **QUIT** Return to the main menu

**CREATE**

Create allows you to draw objects in the graphics area, such as those shown in Figure 3-2, and to change their options. Select **Create** to choose from these menu items:

- **TEXT** Add text to a picture
- **LINE** Add lines to a picture
- **BOX** Add boxes to a picture
- CIRCLE  Add circles to a picture
- POLYGON  Add polygons to a picture
- OPTIONS  Set default options for text, lines, or shapes
- QUIT     Return to the Draw menu

Figure 3-2  Pictures are composed of objects
Text

Text allows you to add text to a picture, or to create a text chart. You can create text of various colors, fonts (lettering styles), and heights. You can align text on the page to be left-justified, centered, or right-justified. (For tips on creating graphically good text charts, see the section "Building a Better Text Chart" in Part One: Introduction, Presentation Graphics.)

Text is drawn on the screen in a draft mode (outline only) to speed drawing time. Text appears in final mode (filled-in) when you select Print to preview a picture or print a picture on an output device.

To create text:

1. Select Text.

2. Select a location for text. The cursor moves to the menu line for text entry.

3. Type a line of text of up to 130 characters. (If you make a mistake, press <BKSP> to delete characters to the left of the cursor.)

4. Press <Return> to complete the text line entry.

5. Continue entering lines of text until you are done. The second line of text appears directly below the first, and so on. Press <ESC> to quit entering text. Press
Text Options

Text options (drawing characteristics) you can change include color, font, height, and justification.

To change default text options after you have selected Text, but before you select a location for text:

1. Type "o."
2. Select an option to change.
3. Select a variation of the option.
4. Press <ESC> or select Quit to make a new text entry.
   The next text you create changes to show the new option. The option appears on the screen sidebar.

NOTE: To change text options after you have completed a text entry, select: Draw/Modify/Alter/ObjectOptions. To change wording or spelling of existing text: select Draw/Modify/Alter/WordIng.

Line

Line allows you to add lines to a picture. You can create lines of various colors, patterns, and thicknesses. You can draw lines with sharp corners or smooth, rounded corners. You can even add arrowheads to lines.
To create lines:

1. Select **Line**.

2. Select a starting location.

3. Continue selecting points of a line (up to 250 points). (To delete the line, point by point, press `<BKSP>`.) Press `<ESC>` to end the line.

4. Continue to create lines, or press `<ESC>` to return to the Create menu.

**Line Options**

Line options (drawing characteristics) you can change include color, pattern, arrows, smoothing (on corners), and width.

To change default line options while creating lines:

1. Type "o."

2. Select an option to change. Variations of the option appear on the menu line.

3. Select a variation.

4. Press `<ESC>` or select **Quit** to continue drawing the line. The line you create changes to show the new option. The option appears on the screen sidebar.

**NOTE:** To change line options of existing lines, select: **Draw/Modify/Alter/ObjectOptions**.
Box

Box allows you to add boxes to a picture. You can create boxes of various border colors, inside colors, and patterns.

To create a box:

1. Select Box.

2. Select a location for one corner of the box.

3. Select a location for the diagonal corner of the box. (To delete this box, press <BKSP>. To delete other boxes you just created, continue pressing <BKSP>.)

Continue to create boxes, or press <ESC> to return to the Create menu.

Box Options

Box options (drawing characteristics) you can change include border color, interior color, and pattern.

To change default box options while creating boxes:

1. Type "o."

2. Select an option to change. Variations of the option appear on the menu line.
3. Select a variation.

4. Press <ESC> or select Quit to continue drawing the box. The box you create changes to show the new option. The option appears on the screen sidebar.

NOTE: To change box options of existing boxes, select: Draw/Modify/Alter/ObjectOptions.

Circle

Circle allows you to add circles to a picture. You can create circles of various border colors, inside colors, and patterns.

To create a circle:

1. Select Circle.

2. Select a location for the center of the circle.

3. Select a location for the radius of the circle. (To delete this circle, press <BKSP>. To delete other circles you just created, continue pressing <BKSP>.)

4. Continue to create circles, or press <ESC> to return to the Create menu.

Circle Options

Circle options (drawing characteristics) you can change include border color, interior color, and pattern.
To change default circle options while creating circles:

1. Type "o."

2. Select an option to change. Variations of the option appear on the menu line.

3. Select a variation.

4. Press \(<\text{ESC}>\) or select Quit to continue drawing the circle. The circle you create changes to show the new option. The option appears on the screen sidebar.

NOTE: To change circle options of existing circles, select: Draw/Modify/Alter/ObjectOptions.

Polygon

Polygon allows you to add polygons to a picture. You can create polygons of various border colors, inside colors, and patterns.

To create a polygon:

1. Select Polygon.

2. Select a starting location.

3. Continue to select up to 250 points to make a polygon. (To delete this polygon, press \(<\text{BKSP}>\). To delete any other polygons you just created, continue pressing \(<\text{BKSP}>) .)
4. Press <ESC> to complete the polygon.

5. Continue to create polygons, or press <ESC> to return to the Create menu.

**Polygon Options**

Polygon options (drawing characteristics) you can change include border color, interior color, and pattern.

To change default polygon options while creating polygons:

1. Type "o."

2. Select an option to change. Variations of the option appear on the menu line.

3. Select a variation.

4. Press <ESC> or select Quit to continue drawing the polygon. The polygon you create changes to show the new option. The option appears on the screen sidebar.

**NOTE:** To change polygon options of existing polygons, select: **Draw/Modify/Alter/ObjectOptions**.

**Options**

Options allows you to select default (preset) drawing characteristics for objects you subsequently create. You can change default
options at any time, even while in the midst of creating an object. Object options include:

Text -- Color, font, height, justification
Lines -- Color, pattern, arrows, smoothing, width
Boxes -- Border color, interior color, pattern
Circles -- Border color, interior color, pattern
Polygons -- Border color, interior color, pattern

NOTE: To change the options of objects that already exist in the graphics area: select Draw/Modify/Alter/ObjectOptions.

Select Options to choose from the following items:

- TEXT Change default text options
- LINES Change default line options
- SHAPES Change default box, circle, and polygon options
- QUIT Exit the Options menu and return to the Create menu

Text

Select Text to choose from these menu items:

- COLOR Change default text color
- FONT Change default text font (lettering style)
• HEIGHT  Change default text height
• JUSTIFY  Change default text justification
• QUIT    Return to the Options menu

Options you set for text affect all text you subsequently create. You can change text options at any time with the Options command. (To change options while in the midst of creating text, simply type "o" before selecting a location for text.)

Text options appear on the screen sidebar whenever you create or modify text.

NOTE: To change the options of text that already exists in the graphics area: select Draw/Modify/Alter/ObjectOptions.

Color

Color allows you to change text color. There are 16 colors in the current color palette.

To set the color:

1. Select Color.

2. Select a color choice. (Scroll the arrows at either end of the line to view all the color choices.)

The color you set appears on the screen sidebar.
NOTE: To change color palettes or edit the colors of the current palette: select Palette from the main menu.

Font

Font allows you to change text font. Fonts are lettering styles, as shown in Figure 3-3. It's best to use only one or two fonts in a graphic image.

Fonts are drawn on the screen in a draft mode (outline only) to speed drawing time. Fonts appear in final mode (filled-in) when you select Print to preview a picture or print it to an output device.

![Figure 3-3 Font styles](image)

Figure 3-3 Font styles
You have six choices:

- **LIGHT** Lightweight lettering (good for bullet points on text charts and chart axis titles)
- **BOLD** Heavy lettering (excellent for main titles)
- **CLASSIC** Looks like schoolbook text (good for titles and labels)
- **ITALICLIGHT** Light, slanted lettering (good for fine labeling)
- **ITALICBOLD** Heavy, slanted lettering (good for emphasizing a point)
- **SCRIPT** Cursive lettering (lends an artistic touch)

To set text font:

1. Select Font.
2. Select a font style.

The font you set appears on the screen sidebar.

**Height**

Height allows you to change text size. There are ten text heights, ranging from small to large.
Generally, text in the middle range (between 5 and 8) is the most visible and readable for projected visuals. Text for the printed page is legible at any size. The larger the text height, the less text you will be able to fit in the graphics area.

To set text height:

1. Select **Height**.
2. Select a text size.

The height you set appears on the screen sidebar.

**Justify**

Justify allows you to change text justification. Justification aligns your text on the page from a starting location you select, as illustrated by Figure 3-4.

![Figure 3-4 Text justifications](image)
There are three text justifications:

- **LEFT** Begin text at the starting location, writing from left to right
- **CENTER** Center text on the starting location
- **RIGHT** End text at the starting location, writing from right to left

To set text justification:

1. Select **Justify**.
2. Select a justification.

The justification you set appears on the screen sidebar.

**Quit**

Select **Quit** when you have finished changing the options for text.

**Lines**

Select **Lines** to choose from these menu items:

- **COLOR** Change default line color
- **PATTERN** Change default line pattern
- **ARROWS** Change default line arrows
SMOOTHING Change default line smoothing
WIDTH Change default line width
QUIT Return to the Options menu

Options you set for lines affect all lines you subsequently create. You can change line options at any time with the Options command. (If you are in the midst of creating a line, simply type "o" to change its options.)

Line options appear on the screen sidebar whenever you create or modify lines.

NOTE: To change the options of lines already in the graphics area, select Draw/Modify/Alter/ObjectOptions.

Color

Color allows you to change line color. There are 16 colors in the current color palette.

To set the color:

1. Select Color.

2. Select a color choice. (Move the cursor over the arrows at either end of the line to view all the color choices.)

The color you select appears on the screen sidebar.
Pattern

Pattern allows you to change line pattern. Line patterns include: solid, long dash, medium dash, short dash, dotted, dash-dot, dash-double-dot, and double-dot.

To set line pattern:

1. Select Pattern.

2. Select a line pattern.

The pattern you select appears on the screen sidebar.

Arrows

Arrows allows you to add arrows to a line, or to remove arrows.

- **NOARROWS**  Removes arrows from lines
- **STARTARROW**  Gives lines an arrow at the first line point you select
- **ENDARROW**  Gives lines an arrow at the last line point you select
- **BOTHARROWS**  Gives lines arrows at both the first and last line points you select
To set line arrows:

1. Select Arrows.

2. Select an arrow style.

The arrows you set appear on the screen sidebar.

**Smoothing**

Smoothing allows you to change a line to show smooth curves or sharp angles, as shown in Figure 3-5. You can draw free-form

![Figure 3-5 Line smoothing](image)

straight line

curved line
drawings more easily with smooth lines.

You have two choices:

- CURVEDLINE  Draws lines as smooth curves
- STRAIGHTLINE Draws lines as pointed angles

To set line smoothing:

1. Select Smooth.

2. Select StraightLine to draw a sharp line, or CurvedLine to draw a smooth line.

The smoothing you set appears on the screen sidebar.

NOTE: As you create a line, the program draws it with sharp corners. If you have set the CurvedLine option, the line is redrawn with curved corners when you complete it.

Width

Width allows you to set the width of a line. There are six line widths, ranging from narrow to wide.

To set line width:

1. Select Width.
2. Select a width choice.

The width you set appears on the screen sidebar.

**Quit**

Select **Quit** when you have finished changing options for lines.

**Shapes**

Select **Shapes** to change the colors and patterns of boxes, circles, and polygons by choosing from these menu items:

- **BORDERCOLOR**
  Change default frame color for shapes

- **INTERIORCOLOR**
  Change default inside color for shapes

- **PATTERN**
  Change default pattern for shapes

- **QUIT**
  Return to the Options menu

Options you set for shapes affect all shapes you subsequently create. You can change shape options at any time with the Options command. (If you are in the midst of creating a shape, simply type "o" to change its options.)
Shape options appear on the screen sidebar whenever you create or modify boxes, circles or polygons.

NOTE: To change the options of shapes already in the graphics area: select Draw/Modify/Alter/ObjectOptions.

**BorderColor**

BorderColor allows you to set the default outline color for boxes, circles and polygons.

To set border color:

1. Select **BorderColor**. The 16 colors of the current palette appear on the menu line. (Move the cursor over the arrows at either end of the menu line to view all the color choices.)

2. Select a color choice.

The border color you set appears on the screen sidebar.

(To change the palette: select **Palette** from the main menu.)

**InteriorColor**

InteriorColor allows you to set the default inside color for boxes, circles and polygons.
To set interior color:

1. Select **InteriorColor**. The 16 colors of the current palette appear on the menu line. (Move the cursor over the arrows at either end of the menu line to view all the color choices.)

2. Select a color choice.

The interior color you set appears on the screen sidebar.

**NOTE:** If the pattern of a shape is **hollow**, the interior color will not appear.

(To change the palette: select **Palette** from the main menu.)

**Pattern**

Pattern allows you to set the default pattern for boxes, circles, and polygons. Patterns fill in the interior areas of shapes, creating diversity among objects.

Patterns for shapes include: hollow, solid, wide slant, medium slant, narrow slant, wide hatch, medium hatch, narrow hatch, vertical line and horizontal line. Finer patterns (such as **narrow hatch**) add texture to a color, toning it down to resemble a gray scale.

Patterns other than **hollow** and **solid** do not appear on 35mm slides or transparencies. In addition, some displays and output
devices may not have the capability to display all the pattern choices.

To set shape pattern:

1. Select Pattern. (Scroll the patterns that appear on the menu line by moving the cursor over the arrows at either end of the line.)

2. Select a pattern style.

The pattern you set appears on the screen sidebar.

NOTE: Patterned objects (except solid) are "transparent," in the sense that you can see through them to any objects that may be in back of them.

Quit

Select Quit when you have finished changing the options for boxes, circles and polygons.

Quit

Select Quit to exit the Options menu and return to the Create menu.

Quit

Select Quit to exit the Create menu and return to the Draw menu.
MODIFY

Modify allows you to change objects in the graphics area. After you modify objects, you may want to redraw the screen with the <F9> key, if the automatic redraw function is off.

Select Modify to choose from these items:

- **ALTER** Change options for existing objects, or change wording of existing text
- **COPY** Copy an object
- **ROTATE** Rotate an object to a different angle
- **MOVE** Move an object to another location
- **SCALE** Make an object larger or smaller
- **WARP** Stretch or shrink an object to different proportions
- **DELETE** Erase an object from the graphics area
- **GROUP** Group objects into a symbol, or undo a symbol
- **ORDER** Order overlapping objects to the front or the back
- **QUIT** Return to the Draw menu
Figure 3-6  Modifying an object to create a drawing
You may use the Modify commands to add finishing touches to a picture, or to produce particular effects as you create a picture. For example, you might perform the following tasks to create the effects shown in Figure 3-6:

Copy an object. (Modify/Copy)
Group objects into a symbol. (Group/InBox)
Warp the symbol. (Warp)
Scale the symbol larger. (Scale)
Undo the symbol. (Group/Undo)
Rotate one of the objects. (Rotate)
Make another copy of the object. (Copy)
Rotate and move the second copy. (Rotate and Move)

NOTE: Modify is not selectable when the graphics area is empty.
To create a picture: select Draw/Create. To retrieve a saved picture: select Draw/File/Get.

Alter

Alter allows you to change the options of individual objects that already exist in the graphics area. You can also edit the wording or spelling of existing text. Select Alter to choose from these items:

- **OBJECTOPTIONS**
  Change drawing characteristics of an existing object

- **WORDING**
  Edit existing text
**ObjectOptions**

ObjectOptions allows you to change the drawing characteristics of objects that currently exist in the graphics area. (You cannot change the options of a symbol until you undo the symbol by selecting Group/Undo.)

To change the options of an object:

1. Select **ObjectOptions**.

2. Select an object in the graphics area.


4. Select a variation.

5. Select other options to change for the object, or press `<ESC>` to see the object redrawn with the new attributes.

6. Select other objects of the same type for the same change, and press `<ESC>`.

7. Select another object for which to change options, or press `<ESC>` to return to the Alter menu.

(To change default options for objects, select **Draw/Create/Options**.)
Wording

Wording allows you to edit the wording or change the spelling of text that already exists in the graphics area.

To change wording or spelling:

1. Select **Wording**.

2. Select a line of text in the graphics area. The text appears on the menu line with the cursor after the last character.

3. Press `<BKSP>` to erase text characters, one at a time. (You can position the cursor within the line of text using the `<Home>`, `<End>`, and arrow keys.)

4. Type new text on the menu line, and press `<Return>`. The new text you type replaces the old text.

5. Select another line of text to change, or press `<ESC>` to return to the Alter menu.

(To change options (drawing characteristics) of text that already exists in the graphics area: select **Draw/Alter/Object-Options/Text**.)
Quit

Select Quit to exit the Alter menu and return to the Modify menu.

Copy

Copy allows you to copy an object in the graphics area. Copy can save you drawing time if your picture is composed of several similar objects. You can copy an object, then change options on one object (Alter/ObjectOptions) to differentiate it from the copy.

To copy an object to a new location:

1. Select Copy. Move the cursor to the outer edge of the object you want to copy, and press <Return>. A box surrounds the object.

2. Move the box to a location for the copy, and press <Return>. (To delete this copy, press <BKSP>. To delete other copies you just made, continue pressing <BKSP>.)

3. Make more copies of the same object, or press <ESC> to select another object to copy. Press <ESC> again to return to the Modify menu.
Rotate

Rotate allows you to rotate an object to a different angle, in either direction. When you select an object to rotate, a box appears around the object, and its angle of rotation (0 degrees) appears on the prompt line. First, you rotate the box to a new angle. When you select the new angle, the object then rotates to fit into the box again.

The angle degrees on the prompt line can help you rotate the box more precisely. Full circle is 360 degrees. Use the following degrees for reference points:

- 0 degrees -- Starting vertical
- 180 degrees -- Reverse vertical
- 90 degrees -- Counterclockwise horizontal
- 270 degrees -- Clockwise horizontal

To rotate an object:

1. Select Rotate.

2. Move the cursor to the outer edge of the object you want to rotate, and press <Return>. A box appears around the object.
3. Use the cursor keys to move the box to a new angle, and press \texttt{<Return>}. (To undo the rotation, press \texttt{<BKSP>}.)

4. Select another object to rotate, or press \texttt{<ESC>} to return to the Modify menu.

**Move**

Move allows you to move an object to a new location in the graphics area.

To move an object:

1. Select \texttt{Move}.

2. Move the cursor to the outer edge of the object you want to move, and press \texttt{<Return>}. A box appears surrounding the object.

3. Use the cursor keys to move the box to a new location, and press \texttt{<Return>}. (To undo the move, press \texttt{<BKSP>}.)

4. Select another object to move, or press \texttt{<ESC>} to return to the Modify menu.

**Scale**

Scale allows you to make an object larger or smaller. The object you scale changes size, but retains its proportions.
To scale an object:

1. Select **Scale**.

2. Move the cursor to the outer edge of the object you want to scale, and press `<Return>`. A box appears surrounding the object.

3. Move the cursor with the arrow keys to increase or decrease the size of the box. When it is the size you want, press `<Return>`.

   (To return the object to its former size, press `<BKSP>`.)

4. Select another object to scale, or press `<ESC>` to return to the Modify menu.

**Warp**

Warp allows you to stretch or compress an object in one direction to change its proportions. For example, you can warp a circle to form an ellipse (oval) shape. You can warp objects and symbols, but not text or symbols that contain only text.

To warp an object:

1. Select **Warp**.

2. Move the cursor to the outer edge of the object you want to warp, and press `<Return>`. A box surrounds the object.
3. Move the cursor to stretch or compress the box to new proportions, and press <Return>. The object is redrawn to the size and shape of the box. (To undo the warp, press <BKSP>.)

4. Select another object to warp, or press <ESC> to return to the Modify menu.

Delete

Delete allows you to erase an object from the graphics area.

To delete an object:

1. Select Delete.

2. Move the cursor to the outer edge of the object you want to delete, and press <Return>. (To undo the deletion, press <BKSP>.)

3. Continue selecting objects to delete, or press <ESC> to return to the Modify menu.

Group

A symbol is a group of objects you can modify as one unit. You can group several objects into a symbol in order to move or scale them all at once. Grouping objects in a box is the fastest method of creating a symbol. However, selecting individual objects to form a symbol lets you modify objects that may not be easily grouped into a box.
Select Group to choose from these menu items:

- **INBOX** Group objects into a symbol by making a box around the objects the symbol will contain
- **OBJECT** Group objects into a symbol by selecting each object the symbol will contain
- **UNDOSYMBOL** Ungroup the objects of a symbol
- **QUIT** Return to the Modify menu

**NOTE:** You cannot change the options of objects contained in a symbol until you undo the symbol by selecting Group/Undo.

**InBox**

InBox allows you to create a symbol by surrounding objects you want to include in the symbol with a box.

To group objects in a box:

1. Select **InBox**.
2. Select a starting point for the box.
3. Select a location for the diagonal corner of the box, so that it completely contains the objects you want in the symbol. (Press `<BKSP>` to undo the box.)
4. Continue creating symbols, or press <ESC> to return to the Group menu.

Object

Object allows you to create a symbol by selecting each object the symbol will contain. You can group objects from any part of the graphics area into a single symbol.

To create a symbol by selecting objects:

1. Select Object.
2. Select the outer edge of an object you want to include. (To remove this object from the symbol, press <BKSP>.)
3. Continue selecting objects to include in the symbol, or press <ESC> to complete the symbol. (To undo the symbol, press <BKSP>.)
4. Continue creating symbols, or press <ESC> again to return to the Group menu.

UndoSymbol

UndoSymbol allows you to ungroup a symbol into separate objects, which you can then modify individually.

To undo a symbol:
1. Select UndoSymbol.

2. Select a symbol to undo. (To reunite the symbol, press <BKSP>.)

3. Continue selecting symbols to undo, or press <ESC> to return to the Group menu.

Quit

Select Quit to exit the Group menu and return to the Modify menu.

Order

Order allows you to rearrange the order of overlapping objects in the graphics area, as shown in Figure 3-7. As you create and modify objects, you can use the Order command to "layer" objects, one in front of another, to achieve a final order for your picture. Select Order to choose from these items:

- FRONT  
  Pull an object in front of all other objects

- BACK  
  Push an object behind all other objects

- QUIT  
  Return to the Modify menu

NOTE: If objects in front have patterns other than solid, you will be able to see through them to those in the back.
Front

Front allows you to pull an object from behind other objects to the front of the screen.

To pull an object to the front:

1. Select Front.

2. Move the cursor to the outer edge of the object you want to pull forward, and press <Return>. The object appears at the front of the screen. (To undo the reorder, press <BKSP>.)
3. Continue pulling objects forward, or press <ESC> to return to the Order menu.

**Back**

Back allows you to push an overlapping object behind other objects.

To push an object behind another:

1. Select **Back**.

2. Move the cursor to the outer edge of the object you want to push back, and press <Return>. (To undo the reorder, press <BKSP>.)

3. Continue pushing objects back, or press <ESC> to return to the Order menu.

**Quit**

Select **Quit** to exit the Order menu and return to the Modify menu.

**Quit**

Select **Quit** to exit the Modify menu and return to the Draw menu.
ERASE

Erase allows you to erase the current picture. If the current picture is unsaved, you may want to save it before you erase it permanently. (An unsaved picture is one you have just created or modified.) Once you select Erase, you have two choices:

- CANCEL Resume work in the Draw menu or save your picture with the File command
- CLEARPICTURE Completely erase the current picture in the graphics area

To erase the current picture:

1. Select Erase.

2. Select Cancel to return to the Draw menu without erasing, or select ClearPicture to erase the picture.

TRANSFER

Transfer allows you to import or export a picture between SCO ImageBuilder and other programs, via the Clipboard. (Contact your system administrator for more information on the Clipboard.)

Select Transfer to choose from these items:
Copy

Copy allows you to copy a picture (or a portion of a picture) to the Clipboard by making a box around the objects you want to copy.

To copy a picture to the Clipboard:

1. Select Copy.

2. Select a location for one corner of the box.

3. Select a location for the diagonal corner of the box.

4. Type in a description for the picture (of up to 14 characters), and press <Return>. A copy of the picture contained in the box is transferred to the Clipboard. From there, you can transfer the picture to other programs.
Paste

Paste allows you to bring a picture from the Clipboard to paste into the graphics area. The picture you paste is added to the current picture.

To paste a picture in the graphics area:

1. Select Paste.

2. Select an item from the Clipboard to paste. The picture you select is added to the current picture.

Remove

Remove allows you to erase a picture from the Clipboard.

To remove a picture:

1. Select Remove.

2. Select the name of a picture to remove.

Quit

Select Quit to exit the Transfer menu and return to the Draw menu.
PRINT

Select Print to preview the current picture on a full screen or produce finished output on a printer or plotter. You have two choices:

- **PREVIEW** View the current picture, enlarged to full-screen size
- **OUTPUT** Produce final output

**Preview**

Preview allows you to see the current picture on a full screen, so that you can get a better idea of how the finished picture will look.

To preview the current picture:

1. Select Preview.
2. Press `<Space Bar>` to stop the preview.

**NOTE:** If you have a color monitor that displays at least 32 colors, Preview allows you to view a gradated background.

**Output**

Output allows you to produce final output on the printer, plotter or camera device. (For instructions on setting up SCO Image-3-46

3-46
Builder with your output device, refer to the *Release and Installation Notes* that came with the manual, or contact your system administrator.

To produce output:

1. Select **Output**.

2. Select the name of an output device.

**NOTE:** You may continue working with SCO ImageBuilder while your output is being produced.

**Quit**

Select **Quit** to exit the Print menu and return to the Draw menu.

**FILE**

File allows you to organize and manage your picture files. You can get, save, or delete picture files. In addition, you can add a picture from the file to the current picture or change the current directory to access picture files in other directories.

Select **File** to choose from these menu items:

- **GET** Get a picture
- **ADD** Add a picture from the file to the current picture
- SAVE       Save the current picture
- DELETE     Erase a saved picture
- CHANGEDIR  Change the current directory to access different picture files
- QUIT       Return to the Draw menu

Figure 3-8   Getting a picture file

Get

Get allows you to retrieve a picture file. Pictures in the file are shown in Figure 3-8. The picture you get replaces the current picture in the graphics area. The name of the picture appears on the screen sidebar.
Since you are actually getting a *copy* of the picture file, you can make changes to it and even erase it from the graphics area without affecting the original picture.

The original version of your picture remains unaffected, unless you delete it from the file or replace it when you save the revised version.

To get a picture:

1. Select **Get**. If the current picture is unsaved, select one of the following:
   - **Stop**  Return to the File menu
   - **Continue**  Replace the current picture

2. Select the name of a file to get. (Press `<PGDN>` to scroll the File Display if the file does not appear on the screen.)

3. Press `<ESC>` to leave the File menu and see the picture drawn in the graphics area.

**NOTE:** When you get a picture, the palette that was saved with that picture becomes the current palette.
Add

Add allows you to combine a picture file with the current picture. For example, you might perform the following steps to add your company logo to the current picture, as shown in Figure 3-9:

Create a text chart. (Create/Text)
Add a saved picture (the logo) to the text chart. (File/Add)
To add a picture:

1. Select Add.

2. Select the name of a picture to add. (Press <PGDN> to scroll the File Display, if the file does not appear on the screen.)

3. Press <ESC> to leave the File menu and see the picture added to the current picture.

**NOTE:** When you add a picture, the current picture’s palette remains the current palette.

**Save**

Save allows you to save the current picture to produce as output or revise later on.

To save the current picture:

1. Select Save.

2. Do one of the following:

   - *To save the picture under a new name*

     Select NewFile, type a name, and press <Return>.
- To save the picture by replacing a file

Select the name of a file you want to replace. Then, select Replace to replace the original file, or Quit to return to the File menu.

Delete

Delete allows you to delete a picture file.

To delete a picture file:

1. Select Delete.

2. Select a file name. (Press <PGDN> to scroll the File Display, if the file does not appear on the screen.)

ChangeDir

ChangeDir allows you to change the current directory, in order to get files from or save images into other directories.

To change the current directory:

1. Select ChangeDir.

2. Do one of the following:

   - If you see the name of the directory you want
Select the name. (The single dot (.) in the list of directory names is the current directory. The double dot (..) is the parent directory.)

- If you do not see the name of the directory

Select NewDirectory, then type the directory name, and press <Return>.

Figure 3-10  Zooming in on a portion of the picture
The name of the directory and the files it contains appear on the screen.

Quit

Select Quit to exit the File menu and return to the Draw menu.

ZOOM

Zoom allows you to zoom in on (magnify) a portion of the picture in the graphics area, in order to see more detail or draw with greater precision. Select Zoom to choose from these items:

- FULLSIZE Zoom out to a full-size picture
- MAGNIFY Zoom in to magnify a portion of the picture to the full size of the graphics area
- PAN Move the zoomed area to magnify a different portion of the picture
- QUIT Return to the Draw menu

For example, you might perform the following steps to add fine detail to a picture, as shown in Figure 3-10:

Create a picture. (Create)
Zoom in on a portion of the picture to add fine detail. (Zoom/Magnify)
NOTE: In some cases, you may be able to magnify a zoomed picture further, depending on the size of the objects in the zoomed area.

**FullSize**

FullSize allows you to return a zoomed picture to its full size in the graphics area.

To return a picture to the full size of the graphics area: select **FullSize**. The current picture zooms out to its original size.

**Magnify**

Magnify allows you to magnify a portion of the current picture to the size of the graphics area. You can view fine detail and draw with much greater precision on a zoomed picture.

To zoom a picture:

1. Select **Magnify**. A box appears on the screen.

2. Use the arrow keys to make the box smaller or larger, and press `<Return>`. (The smaller the box, the greater the magnification will be.)

3. Use the arrow keys to move the box to a location that contains the portion of the picture you want to magnify, and press `<Return>`.
NOTE: You cannot modify a zoomed object that extends beyond the graphics area. Select FullSize before modifying the object.

Pan

Pan allows you to magnify a different portion of a zoomed picture. Pan is not selectable unless the current picture has been zoomed with the Magnify command.

To pan a zoomed picture:


2. Use the arrow keys to move the box so that it moves off the screen to contain a new portion of the picture, and press <Return>. The new portion of the picture is magnified.

Quit

Select Quit to leave the Zoom menu and return to the Draw menu.

ADDCART

AddChart allows you to add a copy of the current chart to the Draw graphics area, in order to enhance it with additional text and graphics. There must be a current chart in the Chart graphics area for AddChart to be selectable.
Select **AddChart** to choose from these items:

- **ADD** Add the current chart to the Draw graphics area
- **REPLACE** Replace an object in the Draw graphics area with the current chart
- **QUIT** Return to the Draw menu

![Figure 3-11](image)  
**Figure 3-11**  
Placing two charts on a page
For example, you might perform the following steps to place two charts on one page, as shown in Figure 3-11:

Create a vertical bar chart. (Chart/Data)

Add the chart to the Draw graphics area. (Draw/AddChart/Add)

Scale the chart smaller. (Modify/Scale)

Move the chart to a corner of the graphics area. (Modify/Move)

Draw a box in the opposite corner of the graphics area. (Create/Box)

Create a pie chart from one of your data sets. (Chart/ChartType/Pie)

Replace the box you drew with the pie chart. (Draw/AddChart/Replace)

Draw a frame around the pie chart and add text to explain charts. (Create/Box, Create/Text).
Add

Add allows you to add a copy of the current chart to the Draw graphics area. If there is a picture in the Draw graphics area, the chart is added to it.

To add a chart:

1. Select AddChart.

NOTE: A chart you add to the Draw graphics area appears as a symbol. To modify the chart’s graphic elements, you must first undo the symbol. To undo the symbol: select Draw/Modify/Group/UndoSymbol.

Replace

Replace allows you replace an object in the Draw graphics area with the current chart. For example, you can arrange multiple charts on a page, then replace them with different charts. A chart approximates the size and shape of the object it replaces.

To replace an object with the current chart:

1. Select Replace.

2. Select the outer edge of the object you want to replace.

3. Select one of the following:
- ReplaceObject
  Replace the object with the current chart

- SelectNewObject
  Select a different object to replace

NOTE: A chart you add to the graphics area appears as a symbol. To modify the chart's graphic elements, you must first undo the symbol by selecting UndoSymbol.

Quit

Select Quit to leave the AddChart menu and return to the Draw menu.

QUIT

Select Quit to leave the Draw menu and return to the SCO ImageBuilder main menu.
Charting Commands

Chart

Chart allows you to create line, bar, area, pie, scatter, or mixed charts from your data. Charts are drawn in the Chart graphics area, a blank area on the screen.

You may enter your data directly or import it from an SCO Professional worksheet. Your data is automatically drawn as a vertical bar chart, but you can easily create several types of charts from the same data. Once you have created a chart, you can add it to the Draw graphics area for further enhancement.

A chart may contain the following graphic elements, some of which are illustrated by Figure 3-12:

- Background color
- X axis and Y axis
- Axis labels
- Titles
- Legend
- Pie slice labels
- A grid

Chart functions are performed on the current chart, which appears when Chart is selected. The current chart may be an empty graphics area, a newly-created chart, or a chart you retrieve with the Chart File command, Get.
Select **Chart** to choose from these menu items:

- **DATA** Enter and edit data for a chart
- **CHARTTYPE** Choose a chart type
- **OPTIONS** Set chart options
- **LAYOUT** Add titles and determine graphic layout
- **ERASE** Erase the current chart
- **TRANSFER** Transfer a chart between SCO ImageBuilder and other programs
- **PRINT** Preview or print the current chart
- **FILE** Get, add, save, or delete charts
- **QUIT** Return to the main ImageBuilder menu
DATA

Data allows you to enter data into the Data display. To create a chart, you must first enter values and labels into the Data display. Whether you obtain your data from a spreadsheet, a report, or compile it from several sources, the Data display allows you to organize and label it for charting. For example, you might perform the following tasks to enter data for a chart, as illustrated by Figure 3-13:

Enter X-axis labels for quarterly data. (Data/DataEntry)
Enter legend labels for two products. (Data/DataEntry)
Enter values for quarterly sales. (Data/DataEntry)

![Figure 3-13 Values and labels in the Data display](image-url)
SCO ImageBuilder automatically plots your data as a vertical bar chart. You can see your data plotted in a variety of chart types by selecting ChartType. You can bring SCO Professional spreadsheet data or SCO FoxBASE data into the Data display by selecting Transfer/Paste.

Select Data to choose from these items:

- DATAENTRY Enter data values
- CALENDAR Automatically add monthly labels
- ERASEDATA Clear the Data display
- QUIT Return to the Chart menu

**DataEntry**

DataEntry allows you to enter your chart data. You add, change, or delete values and labels in specific areas of the Data display.

- You enter values in vertical columns in the unbracketed locations of the Data display. A *data set* is a column of values. Values must be between -9,999,999.99 and 9,999,999.99. You can have up to 50 values in a data set. A chart can have up to five data sets.

- You enter *X axis labels* (of up to 10 characters) in the brackets at the left side of the display. (These labels are also *pie slice labels.*)
- You enter *data set names* (of up to 10 characters) in the brackets at the top of each column of values. Data set names appear in a chart's legend.

To enter or replace a value or label:

1. Select *DataEntry*. Use the arrow keys and `<Home>`, `<End>`, `<PGUP>`, or `<PGDN>` to move the cursor to a value or label location.

2. Type a value or label, and press `<Return>`.
   (To insert a value or label in a data set: press `<F3>`, type in the new entry, and press `<Return>`. To delete an entry: press `<F4>`.)

3. Press `<ESC>` twice to see a chart drawn from your data.

**Calendar**

Calendar allows you to automatically add monthly labels in the left column of the Data display.

To add monthly labels:

1. Select *Calendar*.

2. Press `<ESC>` to see your chart drawn with monthly labels.
EraseData

EraseData allows you to erase all values and labels from the Data display. Once you select EraseData, you have a chance to cancel your request to erase the contents of the Data display. If the current chart is unsaved, you may want to save it before you erase it permanently. Once you select Erase, you have two choices:

- CANCEL Return to the Data menu without erasing the Data display
- CLEARDATA Completely clear the Data display of both values and labels

To erase the Data display:

1. Select Erase.
2. Select Cancel to return to the Data menu without erasing, or ClearData to erase the chart data.

NOTE: EraseData does not erase the current chart's type or options. To change chart type for the next chart: select ChartType. To change chart options: select Options.

CHARTTYPE

ChartType allows you to create several different chart types from your data. The chart type you choose depends on the kind of data
you have and the message you want to convey. You might choose to create more than one chart type from your data for an in-depth look at the numbers. Decide what you want to show, and then let SCO ImageBuilder expertly draw one or more chart types from the data you enter.

For tips on creating good graphic chart images, see the section "Building a Better Data Chart" in Part One: Introduction, Presentation Graphics.

Select ChartType to choose from these items:

- **VERTICALBAR**
  Create a vertical bar chart

- **LINE**
  Create a line chart

- **SCATTERPLOT**
  Create a scatter chart

- **AREA**
  Create an area chart

- **MIXED**
  Create a mixed chart by combining vertical bar, line, area, or scatterplot

- **HORIZONTALBAR**
  Create a horizontal bar chart

- **PIE**
  Create a pie chart from a single data set

- **QUIT**
  Return to the Chart menu
VerticalBar

VerticalBar allows you to create a vertical bar chart from your data. Vertical bar charts are useful for comparing quantities or for showing values at corresponding intervals. Considered the business standard, bar charts are easiest to read. Data you enter into the Data display is automatically turned into a vertical bar chart, unless you have selected another chart type before entering your data.

Figure 3-14 compares 1st quarter monthly sales by city. Each group of bars shows a quantitative difference, while a trend over time is also evident.

![Regional Volume Graph](image)

**Figure 3-14** A vertical bar chart
To create a vertical bar chart: select **VerticalBar**.
The current chart is redrawn as a vertical bar chart.

Options you can change for vertical bar charts include color, pattern, and visibility. To change options: select **Chart/Options**.

**Line**

Line allows you to create a line chart from your data. Line charts are useful for tracking trends over time, or for showing larger amounts of data. You can use them to chart the differences between variables, showing frequency or distribution. Keep the number of lines per chart small for clarity. If you have only one line in a chart, plot it as an area chart for more graphic impact.

![Sales History Chart](image)

**Figure 3-15** A line chart
Figure 3-15 traces sales trends for two regions over a four year period.

To create a line chart: select Line. The current chart is redrawn as a line chart.

Options you can change for line charts include color, pattern, and visibility. To change options: select Chart/Options.

ScatterPlot

ScatterPlot allows you to create a scatter chart from your data. Scatter charts plot each value as a marker symbol. They are useful for showing data as distinct points in time, or for plotting

![Scatterplot Chart](image)

Figure 3-16 A scatterplot chart
coordinates of two sets of data not directly related to time, such as advertising costs and sales.

**Figure 3-16** shows the rise in temperature of a test substance in relation to increasing units of gas.

To create a scatter chart: select ScatterPlot. The current chart is redrawn as a scatter chart.

Options you can change for scatter charts include color, marker style, and visibility. To change options: select Chart/Options.

**Area**

Area allows you to create an area chart from your data. Area charts are line charts with the area below the line filled in. They
are useful for comparing volume trends over time. Plot the data for the product with the highest values first, because the second area is drawn over the first.

**Figure 3-17** compares quarterly sales of two products.

To create an area chart: select Area. The current chart is redrawn as an area chart.

Options you can change for area charts include color, pattern, and visibility. To change options: select Chart/Options.

**Mixed**

Mixed allows you to create a chart that combines vertical bar, line, area, or scatter chart types. Mixing chart types lets you tell a more complex story about your data.

**Figure 3-18** shows projected sales as an area chart and actual sales as a bar chart.

To create a mixed chart:

1. Select Mixed.

2. Select a chart type for the first data set in your chart. Continue to select a chart type for each data set in the chart.

3. Select Done to see your chart drawn on the screen.
Figure 3-18  A mixed chart

Options you can change for mixed charts include color, data set type, pattern, marker style, and visibility, depending on the chart types you have combined. To change options: select Chart/Options.

NOTE: Horizontal bar and pie charts cannot be mixed with other chart types.

HorizontalBar

HorizontalBar allows you to create a horizontal bar chart from your data. In this chart, the X and Y axes are reversed, so that the bars grow from the left side of the chart to the right. Horizon-
tal bar charts are useful for comparing values, such as lengths of time or amounts of money, against a time line.

Figure 3-19 shows the number of new accounts at two banks over a five-year period.

To create a horizontal bar chart: select HorizontalBar. The current chart is redrawn as a horizontal bar chart.

Options you can change for horizontal bar charts include color, pattern, and visibility. To change options: select Chart/Options.)

![New Accounts](image)

Figure 3-19  A horizontal bar chart

NOTE: Since the X and Y axes are reversed in this chart, functions you perform on the X axis (such as scaling or entering an axis title) apply to the *vertical* axis. Functions you perform on the
Y axis apply to the horizontal axis. Because of the reversed axes, a horizontal bar cannot be included in a mixed chart.

Pie

Pie allows you to create a pie chart from one of the data sets in the Data display. Each value is represented as a pie slice showing the percentage of the value in relation to the whole (100%). You can have up to 16 slices, but a pie composed of six or less slices is easiest to read. The largest slice often looks best displayed in the lightest tone.

Figure 3-20 shows the proportional contribution of three salespeople to a company’s annual sales.

Sales Performance

P. Brown 37%  J. Smith 21%  E. Jones 42%

Figure 3-20  A pie chart
To create a pie chart:


2. Select the name of a data set. The chart is redrawn as a pie chart using the data from the data set you selected.

(To see data set values: select Chart/Data. To change pie chart drawing characteristics: select Chart/Options.)

Quit

Quit allows you to exit the ChartType menu and return to the Chart menu.

OPTIONS

Select Options to set chart options. Options determine the drawing characteristics of the current chart. Each chart type has a unique set of options.

You change most options by data set. (A data set is a vertical column of values in the Data display.) For example, in a bar chart, all bars for a single data set are the same color and pattern. Options for pie charts are set by the pie slice.

Depending on the current chart’s type, you can set the following options:

- COLOR Select chart colors [all chart types]
• **EXPLODE**  Separate a pie slice from the whole pie chart  [Pie only]

• **PATTERN**  Change the pattern of a line, bar, area, or pie slice  [all chart types except ScatterPlot]

• **VISIBILITY**  Make a data set visible or invisible on a chart  [all chart types except Pie]

• **MARKERSTYLE**  Change the style of a marker  [ScatterPlot and Mixed only]

• **DATASETTYPE**  Change chart type for individual data sets  [Mixed only]

• **QUIT**  Return to the Chart menu  [all chart types]

**Color**

Color allows you to change the color of a data set or pie slice.

To change data set or pie slice color:

1. Select **Color**.

2. Select a data set or pie slice name.

3. Select the color you want.  (Move the cursor over the arrows at either end of the line to view all the color choices.)
4. Press `<ESC>` to see your chart redrawn.

(To change the palette: select Palette from the main menu.)

**Explode**

Explode allows you to emphasize a pie slice by separating it from the whole pie, as shown in Figure 3-21, or to reunite an exploded slice with the whole pie. For each slice you have two choices:

- **EXPLODEON** Separate a slice from the whole pie
- **EXPLODEOFF** Recombine an exploded slice with the whole pie

![Figure 3-21 An exploded pie slice](image)
To explode a pie slice:

1. Select **Explode**. Pie slice names appear on the menu line.

2. Select the name of a pie slice. (To see pie slice data values: select **Chart/Data**.)

3. Select **ExplodeOn** to separate the slice from the pie, or select **ExplodeOff** to join the slice with the pie.

4. Press **<ESC>** to see the pie chart redrawn with the exploded slice.

**Visibility**

Visibility allows you to make a data set visible or invisible (not used) in the current chart.

Visibility controls whether or not a data set in the Data display actually appears in the current chart. For each data set, you have two choices:

- **VISIBILITYON**
  
  Ensure that the data set is plotted and visible on the chart

- **VISIBILITYOFF**
  
  Make the data set invisible by not using it in the chart
To set visibility:

1. Select **Visibility**.
2. Select a data set name. (To see data set values: select **Chart/Data**.)
3. Select **VisibilityOn** to make the data set visible. Select **VisibilityOff** to make the data set invisible.
4. Press <ESC> to see your chart redrawn.

(Changing visibility may affect the chart axis limits. To set your own axis limits, select **XAxis/Scale** or **YAxes/Scale**.)

**Pattern**

Pattern allows you to change the pattern of lines on a line or mixed chart, or the interior areas of bar, area, mixed, and pie charts.

Patterns other than **hollow** and **solid** do not appear on 35mm slides or transparencies. In addition, some displays and output devices may not have the capability to display all the pattern choices.

**NOTE:** Patterned objects (except **solid**) are "transparent" in the sense that you can see through them to any objects that may be in back of them.
**Line Patterns**

Line patterns include: solid, long dash, medium dash, short dash, dotted, dash-dot, dash-double-dot, and double-dot.

To change line pattern:

1. Select **Pattern**.

2. Select the name of a data set.

3. Select a line pattern.

4. Press `<ESC>` to see your chart drawn with a new line pattern, or select **Pattern** again to change the pattern of another line.

**Interior Patterns**

Interior area patterns include: hollow, solid, wide slant, medium slant, narrow slant, wide hatch, medium hatch, narrow hatch, vertical line and horizontal line.

Finer patterns (such as narrow hatch) add texture to a color, toning it down to resemble a gray scale. Some displays and output devices may not have the capability to display all the pattern choices.

To change interior pattern:

1. Select **Pattern**.

2. Select the name of a data set.
3. Select an interior pattern. (Scroll the patterns that appear on the menu line by moving the cursor over the arrows at either end of the line.)

4. Press <ESC> to see your chart drawn with a new pattern, or select Pattern again to change the pattern of another bar, area, or pie slice.

**MarkerStyle**

MarkerStyle allows you to choose a marker style for scatter charts. Marker styles include: solid box, hollow box, diamond, triangle, plus, and X.

1. Select MarkerStyle.

2. Select the name of a data set.

3. Select a marker style.

4. Press <ESC> to see your chart drawn with a new marker style, or select MarkerStyle again to change the style of another data set.

**DataSetType**

DataSetType allows you to change the chart type for a data set in a mixed chart.

To change data set type:

1. Select DataSetType.
2. Select the name of a data set to change. (To see data set values: select Chart/Data.)

3. Select a chart type for the data set.

4. Press <ESC> to see your chart drawn with a new chart type.

Quit

Select Quit to exit the Options menu and return to the Chart menu.

LAYOUT

Layout allows you to lay out the look of a chart. You can add titles, place a legend, add a grid, reformat the axes, or create stacked bar and area charts.

Select Layout to choose from these items:

- TITLES Add or edit chart titles
- XAXIS Set X axis attributes
- YAXIS Set Y axis attributes
- LEGEND Place or remove a chart legend
- STACK Arrange bars or areas one above the other
- QUIT Return to the Chart menu
For example, you might perform the following tasks to improve the graphic layout of a line chart, as shown in Figure 3-22:

Rescale the Y axis to smooth out up-and-down sales figures. (Layout/YAxis/Scale)
Change Yaxis labels to whole numbers to simplify chart. (YAxis/Precision/NoDecimals)
Remove the legend, because the chart plots only one data set. (Legend/LegendOff)
Change the chart’s type to an area chart. (ChartType/Area)
Add a grid. (YAxis/Grid)
Add a main title. (Titles/Main)

Figure 3-22 Changing chart layout
Titles

Titles allows you to add four types of titles to a chart, as illustrated by Figure 3-23. Titles are drawn on the screen in a draft mode (outline only) to speed drawing time. Titles appear in final mode (filled-in) when you select Print to preview a chart or print it to an output device.

Select Titles to choose from these items:

- MAIN Add or edit a main title
- SUBTITLE Add or edit a subtitle
- **XAXIS**: Add or edit an X-axis title
- **YAXIS**: Add or edit a Y-axis title
- **QUIT**: Return to the Layout menu

**NOTE:** To move or change the size of chart titles, add the chart to the Draw graphics area by selecting **Draw/AddChart**.

**Main**

The main title appears at the top left of the chart. Select **Main** to choose from these items:

- **ENTER**: Enter text for the main title
- **COLOR**: Select color for the main title
- **FONT**: Select font style for the main title
- **DELETE**: Erase the main title
- **QUIT**: Return to the Titles menu

**Subtitle**

The subtitle appears at the top left of the chart, beneath the main title (if one exists). Select **Subtitle** to choose from these items:

- **ENTER**: Enter text for the subtitle
- **FONT**: Select font style for the subtitle
COLOR Select color for the subtitle
DELETE Erase the subtitle
QUIT Return to the Titles menu

XAxis

The X-axis title appears at the bottom center of the chart, beneath the X axis. Select XAxis to choose from these items:

ENTER Enter text for the X-axis title
FONT Select font style for the X-axis title
COLOR Select color for the X-axis title
DELETE Erase the X-axis title
QUIT Return to the Titles menu

NOTE: On a horizontal bar chart, the X and Y axes are reversed. Therefore, the X-axis title appears at the top left of this chart.

YAxis

The Y-axis title appears at the top left of the chart, close to the Y axis. Select YAxis to choose from these menu items:
**SCO ImageBuilder User's Guide**

- **ENTER** Enter text for the Y-axis title
- **FONT** Select font style for the Y-axis title
- **COLOR** Select color for the Y-axis title
- **DELETE** Erase the Y-axis title
- **QUIT** Return to the Titles menu

**NOTE:** On a horizontal bar chart, the X and Y axes are reversed. Therefore, the Y-axis title appears at the bottom center of this chart.

**Enter**

Enter allows you to type in the text of a title.

To create a title:

1. Select **Enter**. Type a title (of up to 31 characters), and press <Return>.
2. Press <F9> to see your chart redrawn with the title.
3. Press <ESC> to return to the Titles menu.

**Color**

Color allows you to change the color of a chart title.
To change title color:

1. Select Color.

2. Move the cursor to the color you want, and press <Return>. (Move the cursor over the arrows at either end of the line to view all the color choices.)

3. Press <F9> to see your chart title redrawn in a new color.

4. Press <ESC> to return to the Titles menu.

(To change color palettes: select Palette from the main menu.)

Font

Font allows you to change the font for a chart title. Fonts include light, bold, classic, italic light, italic bold, and script.

Fonts are drawn on the screen in a draft mode (outline only) to speed drawing time. Fonts appear in final mode (filled-in) when you select Print to preview a chart or print it on an output device.

To change a title font:

1. Select Font.

2. Select a font.

3. Press <F9> to see your chart title redrawn in a new font.
4. Press <ESC> to return to the Titles menu.

**Delete**

Delete allows you to delete a title.

To delete a title:

1. Select Delete.
2. Press <F9> to see the chart redrawn without the title.
3. Press <ESC> to return to the Titles menu.

**Quit**

Select Quit to exit a specific title menu and return to the Titles menu.

**XAxis**

Select XAxis to choose from these items:

- **AUTOSCALE** Let SCO ImageBuilder automatically set the range of the X axis
- **SCALE** Set your own range for the X axis
- **GRID** Add or remove a vertical grid
- **QUIT** Return to the Layout menu
YAxis

Select YAxis to choose from these menu items:

- AUTOSCALE  Let SCO ImageBuilder automatically set the range of the Y axis
- SCALE      Set your own range for the Y axis
- PRECISION  Select the format of Y-axis labels
- GRID       Add or remove a horizontal grid
- QUIT       Return to the Layout menu

AutoScale

AutoScale allows you to have the program automatically set the range for the X or Y axis.

AutoScale for the X axis plots all the values in the Data display. AutoScale for the Y axis calculates the lowest and highest values of the Y axis and determines the spacing of Y axis labels.

To let the program automatically scale an axis: select Autoscale.

(To set your own limits for the X and Y axes: select XAxis/Scale or YAxis/Scale.)
Scale

Scale allows you to set your own limits for the X or Y axis, as shown in Figure 3-24. You can change the way your chart looks when it is plotted, or choose to show only a portion of your data by rescaling an axis.

To scale the X Axis:

1. Select Scale.

2. Type the number of the horizontal row of values in the Data display with which you want to start the X axis.

3. Type the number of the horizontal row of values in the Data display with which you want to end the X axis.

4. Type an X-axis step size (incremental spacing of X-axis labels), and press <Return>.

5. Press <ESC> to see a portion of your data plotted along the rescaled X axis.

To scale the Y Axis:

1. Select Scale.

2. Type a value to start the Y axis, and press <Return>.

3. Type a value to end the Y axis, and press <Return>.
4. Type a Y-axis step size (incremental spacing of Y-axis labels), and press <Return>.

5. Press <ESC> to see your chart drawn with a rescaled Y axis.

Figure 3-24 Axis scaling
Precision

Precision allows you to change the appearance of Y-axis labels. Select Precision to choose from these items:

- **NODECIMALS**
  Show Y-axis labels as whole numbers

- **ONEDECIMAL**
  Give Y-axis labels one decimal place

- **TWODECIMALS**
  Give Y-axis labels two decimal places

- **DOLLARS**
  Show Y-axis labels as dollars

To set Y-axis label precision:

1. Select **Precision**.

2. Select a precision choice. Press `<ESC>` to see your chart with new label precision.

Grid

Grid allows you to create or remove a background grid for a chart. A grid provides visual reference points for plotted data. An X-axis grid creates vertical grid lines, while a Y-axis grid creates horizontal grid lines. Using both an X- and a Y-axis grid creates a grid of intersecting lines.
For each axis, you have two choices:

- **OFF**  
  Show no grid lines

- **ON**  
  Show grid lines

**NOTE:** On horizontal bar charts, the X and Y axes are reversed, so that an X-axis grid creates horizontal lines and a Y-axis grid creates vertical lines.

To set a grid:

1. Select **Grid**.
2. Select **On**. (An X-axis grid shows vertical lines, while a Y-axis grid shows horizontal lines.)
3. Press `<ESC>` to see your chart drawn with a grid.

(To remove a grid: select **Off**.)

**Quit**

Select **Quit** to exit the XAxis or YAxis menu and return to the Layout menu.

**Legend**

Legend allows you to place a legend in or remove it from the current chart. A legend identifies the data sets represented in the
chart. (Pie charts do not have legends.) You have three choices:

- **LEGENDOFF**  Show no legend on the chart
- **LEGENDINSIDE**  Place a legend inside the perimeter of a chart
- **LEGENDOUTSIDE**  Place a legend outside the perimeter of a chart

To place a legend:

1. Select **Legend**.
2. Select **LegendInside** (to place the legend inside the chart frame), or **LegendOutside** (to place the legend outside the chart frame).

To remove a legend:

1. Select **Legend**.
2. Select **LegendOff**.

**Stack**

Stack allows you to arrange bars or areas one above the other to show a total, cumulative amount, as shown in Figure 3-25. Each bar or area uses the top of the previous bar or area as its base. Stacking shows the contribution of each part to the whole, but un-
like pie charts, stacked charts reflect actual values, not percentages.

You have two choices:

- STACKINGON Turn on stacking of bars or areas
- STACKINGOFF Turn off stacking of bars or areas

To set stacking:

1. Select Stack.

2. Select STACKINGON to show bars and areas one above the other, or STACKINGOFF to show bars and areas without
stacking.

**NOTE:** Horizontal bar charts stack bars one after the other.

**ERASE**

Erase allows you to erase the current chart. Once you select Erase, you have a chance to cancel your request to erase the graphics area. If the current chart is unsaved, you may want to save it before you erase it permanently. There are two choices:

- **CANCEL**  
  Cancel the request to erase the current chart and data, in order to resume work in the Chart menu, or save your chart with the File command

- **CLEARCHART**  
  Completely erase the current chart and data

To erase the current chart:

1. Select **Erase**.

2. Select **Cancel** to return to the Chart menu without erasing, or **ClearChart** to erase the current chart.
TRANSFER

Transfer allows you to import or export the current chart between SCO ImageBuilder and other programs, via the Clipboard. Select Transfer to choose from these items:

- COPY Copy the current chart to the Clipboard
- PASTE Transfer a chart from the Clipboard to the Chart graphics area
- REMOVE Remove a chart from the Clipboard
- QUIT Return to the Chart menu

Copy

Copy allows you to copy the current chart to the Clipboard.

To copy a chart to the Clipboard:

1. Select Copy.

2. Type in a description of the chart (of up to 14 characters), and press <Return>. A copy of the chart is transferred to the Clipboard. From there, you can transfer the chart to other programs.
Paste

Paste allows you to bring a chart from the Clipboard to paste into the Chart graphics area. The chart you paste replaces the current chart.

To paste a chart into the Chart graphics area:

1. Select Paste. If the current chart is unsaved, select one of the following:
   - Stop Return to the Transfer menu
   - Continue Replace the current chart

2. Select an item from the Clipboard to paste. The chart you select becomes the current chart.

Remove

Remove allows you to erase a chart from the Clipboard.

To remove a chart:

1. Select Remove.

2. Select the name of a chart to remove.
Quit

Quit allows you to exit the Transfer menu and return to the Chart menu.

PRINT

Select Print to preview the current chart on a full screen or produce finished output.

- PREVIEW  Preview the current chart, enlarged to the size of the screen
- OUTPUT  Produce final output

Preview

Preview allows you to see the current chart on a full screen, so that you can get a better idea of how the finished chart will look.

To preview the current chart:

1. Select Preview.
2. Press <Space Bar> to stop the preview.

NOTE: If you have a color monitor that displays at least 32 colors, Preview allows you to view a gradated background.
Output

Output allows you to produce output on a printer, plotter, or camera device. (For instructions on setting up SCO ImageBuilder with your output device, refer to the Release and Installation Notes that came with the manual, or contact your system administrator.)

To produce output:

1. Select Output.
2. Select the name of an output device.

NOTE: You may continue working with SCO ImageBuilder while your output is being produced.

FILE

Select File to choose from these menu items:

- GET Get a chart
- SAVE Save the current chart
- DELETE Remove a chart file
- CHANGEDIR Change the current directory
- IMPORT Import data from an SCO Professional worksheet
• QUIT   Return to the Chart menu

Get

Get allows you to retrieve a chart file. The chart you get replaces the current chart in the graphics area. The name of the chart appears on the screen sidebar.

Since you are actually getting a copy of the chart file, you can make changes to it and even erase it from the graphics area without affecting the original chart. The original version remains unaffected, unless you delete it from the file or replace it when you save the revised version.

To get a chart:

1. Select Get. If the current chart is unsaved, select one of the following:
   - Stop   Return to the File menu
   - Continue Replace the current chart

2. Select the name of a file to get. (Press <PGDN> to scroll the File display if the file does not appear on the screen.)

3. Press <ESC> to see the chart drawn on the screen.
Save

Save allows you to save the current chart to produce as output or revise later on.

To save the current chart:

1. Select Save.

2. Do one of the following:

   - To save the chart under a new name
     
     Select NewFile, type a name, and press <Return>.

   - To save the chart by replacing a file
     
     Select the name of a file you want to replace. Then, select Replace to replace the file, or Quit to return to the File menu.

Delete

Delete allows you to remove a chart file.

To delete a chart file:

1. Select Delete.
2. Select the name of the file to delete. (Press <PGDN> to scroll the File display if the file does not appear on the screen.)

**ChangeDir**

ChangeDir allows you to change the current directory, in order to get files from or save images into other directories.

To change the current directory:

1. Select **ChangeDir**.

2. Do one of the following:

   - *If you see the name of the directory you want*

     Select the name. (The single dot (.) in the list of directory names is the current directory. The double dot (..) is the parent directory.)

   - *If you do not see the name of the directory*

     Select **NewDirectory**, then type the directory name, and press <Return>.

**ImportWKS**

ImportWKS allows you to import data from an SCO Professional worksheet into the SCO ImageBuilder Data display. You can im-
port up to five data sets of 50 values each. Worksheet data replaces any data you may have in the Data display, but does not alter the current chart type or chart options.

To import data from SCO Professional:

1. Select **ImportWKS**. The names of WKS files appear on the screen.

2. Select the name of the WKS file you want to import.

QUIT

Select Quit to exit the Chart menu and return to the SCO ImageBuilder main menu.
Background & Palette Commands

BACKGROUND

Background allows you to change the color of the background, or to create a gradated background between two colors. You can change the background color at any time. The background color is listed on the screen sidebar on the right side of the graphics area.

The default background color is black. A black background on the screen appears white on printed output. A gradated background can be produced by printers and cameras capable of displaying at least 32 colors. Plotter output does not show background color.

Select Background to choose from these items:

- SOLID
  - Create a solid background color
- SHADED
  - Create a gradated background

Solid

Solid allows you to display a background composed of one solid color.

To create a solid background:
1. Select **Background**.

2. Select **Solid**. The 16 colors of the current palette appear on the menu line. (Move the cursor over the arrows on the menu line to view all the color choices.)

3. Select a color. The background color changes.

**Shaded**

Shaded allows you to create a gradated background.

To create a gradated background:

1. Select **Background**.

2. Select **Shaded**. The 16 colors of the current palette appear on the menu line. (Move the cursor over the arrows on the menu line to view all the color choices.)

3. Select a top background color.

4. Select a bottom background color.

**NOTE:** Only the top color of a gradated background appears in the graphics area on a color screen. To view a gradated background on a display with the necessary color capability: select **Print/Preview**, once a current picture or chart exists.
PALETTE

Palette allows you to get, change, save, or delete a color palette. A color palette is set of 16 colors. SCO ImageBuilder comes with a collection of eight palettes. You can change the colors of a palette by "mixing" colors, just as an artist would, to create new shades.

Each shade is a unique mixture of hue (color family), saturation (amount of white mixed in), and intensity (brightness). To create a new palette, you can change the colors of a palette and save it under a new name.

It's a good idea to create sample color output, so that you can see what colors actually look like on your output device. Although SCO ImageBuilder stores the colors you set with the Palette command, you may not see their exact shades if your screen or output device displays 64 colors or less. For example, SCO ImageBuilder supports thousands of colors, while an EGA shows 64 colors.

Select Palette to choose from these items:

- GET Get a palette
- CHANGE Modify the colors of the current palette
- SAVE Save the current palette
- DELETE Delete a saved palette
Get

Get allows you to retrieve a saved color palette, as shown in Figure 3-26. If you have a picture or chart in the graphics area, it changes to reflect the new palette. Since you are actually getting a copy of the palette file, you can make changes to it without affecting the original palette. The original version remains unaffected, unless you delete it from the file or replace it when you save the revised version.

To get a color palette:

1. Select Get.
2. Move the cursor to the name of the palette you want, and press <Return>.

If you have a color display, the 16 colors of the current palette appear across the bottom of the screen. If you have a black-and-white display, color names are listed at the bottom of the screen.

**Change**

Change allows you to modify the colors of the current palette. Once you have selected a color to change, you create a new color to take its place.

For example, you might perform the following tasks to change a color, as shown in Figure 3-27:

Choose a color from the current palette to change.
(Palette/Change)

Change the hue. (DesignAColor)

Choose a different saturation and intensity.
(Change/DesignAColor)

Replace the original color with the new one.
(DesignAColor/AddNewColor)

There are three methods for creating a color:

- **DESIGNACOLOR**
  Create a color by mixing it in the DesignAColor display
Figure 3-27  Changing a color in the DesignAColor display

- **RGB**  Create a color by entering RGB (red, green and blue) values

- **HSI**  Create a color by entering HSI (hue, saturation and intensity) values
To change a color:

1. Select **Change**.

   The 16 colors of the current palette are listed in two columns on the screen. A cursor box surrounds the first selectable color. (You cannot change black or white, which appear in every palette.)

2. Move the cursor box with the arrow keys to the name of a color to change.

   (If you have a color monitor, the colors of the current palette appear across the bottom of the screen. An arrow points to the color that corresponds to the color name you touch with the cursor.)

3. Press **< Return >**. You are asked to select a method to create a new color.

4. Select **DesignAColor**, **RGB**, or **HSI**.

**DesignAColor**

To change a color in the DesignAColor display, you select a hue, a saturation, and an intensity to mix a new color.

1. Select **DesignAColor**.

   Three lists appear on the screen: Hues, Saturation, and Intensity. (You do not have to press **< Return >** to select from the lists. Simply move the cursor check mark to
2. Select a hue, saturation, and/or intensity to create a new color. The name of the new color appears in the lower right of the DesignAColor display. If you have a color display, the color block shows the newly mixed color.

**Changing a Color's Hue**

You select a color from the HUES list to replace a color in the current palette, or to use as a base for continued color mixing. There are seven color families in the Hues list: Reds, Oranges, Yellows, Greens, Blues, Purples, and Neutrals.

The cursor appears as a checkmark, on the name of the color you selected to change.

To change hue:

1. Use the arrow keys to move the cursor to a different hue. (To scroll to different color families: press \(< \text{PGUP}>\) and \(< \text{PGDN}>\).) The name of the currently checked color appears at the lower right of the display. (On a color screen, a color block displays each color the cursor touches in the HUES list.)

2. Do one of the following:
   - *If you want to continue mixing the color*
     
     Press the \(< \text{Right}>\) arrow key to reach the SATURATION or INTENSITY lists. Press
<F1> to select Help for either list and receive further instructions on mixing the color.

- If you are satisfied with the color

Press <Return>.

Changing a Color's Saturation

Saturation is the amount of white mixed in with a color. There are four degrees of saturation with white: Vivid has no white; Normal has a little white; Pastel includes lots of white; and Milky is mostly white.

The cursor appears as a check mark on the saturation of the original color you selected to change.

To change saturation:

1. Use the <Up> and <Down> arrow keys to move the cursor to the saturation you want. The name of the current color changes to include the saturation you selected. (On a color screen, the color block reflects each saturation the cursor touches.)

2. Do one of the following:

- If you want to continue mixing the color

Press an arrow key to reach the HUES or INTENSITY list. Press <F1> to select Help
for the list and receive further instructions on mixing the color.

- If you are satisfied with the color

Press <Return>.

Changing a Color’s Intensity

Intensity is the amount of light filtered through a color. There are four degrees of intensity: Bright shows the most light; Normal shows some light; Subdued is dimmed with gray; and Dark has most of the light blocked.

The cursor appears as a check mark on the intensity of the original color you selected to change.

To change intensity:

1. Use the <Up> and <Down> arrow keys to move the cursor to other intensities, until you find the intensity you want. The name of the current color changes to include the intensity you selected. (On a color screen, the color block reflects each intensity the cursor touches.)

2. Do one of the following:

- If you want to continue mixing the color

Press the <Left> arrow key to reach the SATURATION or HUE lists.
If you are satisfied with the color
Press <Return>.

Confirming Addition of a Color to the Palette

Once you have mixed a new color in the DesignAColor display, select one of the following:

- **ADDNEWCOLOR**
  Add the new color to the current palette to replace the original color

- **KEEPORIGINALCOLOR**
  Return to the current palette without changing the original color

- **CONTINUEMIXINGCOLOR**
  Continue mixing the color in the DesignAColor display

**RGB**

RGB values are the degrees of red, green and blue you can mix together to form a color.

To change a color by entering RGB values:

1. Select RGB.

2. Type a degree of red value (from 0 to 100), and press <Return>.
3. Type a degree of green value (from 0 to 100), and press <Return>.

4. Type a degree of blue value (from 0 to 100), and press <Return>. The RGB name replaces the color in the current palette.

NOTE: The RGB values are listed as the color name in the current palette. For example, "R050G020B070" is an RGB name of a color composed of a red that is 50% red, a green that is 20% green, and a blue that is 70% blue.

**HSI**

HSI values are values that represent a hue, a level of saturation, and a degree of intensity that form a color.

To change a color by entering HSI values:

1. Select HSI.

2. Type a hue value (from 0 to 360), and press <Return>. (Some hue values are: 0 = blue, 60 = violet, 120 = red, 150 = orange, 180 = yellow, and 240 = green.)

3. Type a saturation value (from 0 to 100), and press <Return>. (0 = the most white mixed in; 100 = pure color.)

4. Type an intensity value (from 0 to 100), and press <Return>. (0 = the darkest color; 100 = the brightest color.)
The HSI name replaces the color in the current palette.

**NOTE:** The HSI values are listed as the color name in the current palette. For example, "H080S030I040" is the HSI color name.

**Save**

Save allows you to store the current palette permanently. You can have up to 20 palettes in the Palette file.

**To save a palette:**

1. Select Save.

2. Do one of the following:

   - **To save the palette under a new name**
     
     Select NewPalette, type a name (of up to 10 characters), and press **<Return>**.

   - **To save the palette under the name of an existing palette**
     
     Select the name of a palette you want to replace. Then, select Replace to replace that palette, or Quit to return to the Palette menu.

**NOTE:** When you save a picture or chart, the current palette is saved with it. This is an additional way of saving a palette. If you do not save the changes you have made to a palette, the program
discards the changes when you get another palette or another picture with a different palette.

Delete

Delete allows you to remove a saved palette.

To delete a palette:

1. Select **Delete**.

2. Move the cursor to the name of the palette to delete, and press **< Return >**.

Quit

Select **Quit** to exit the Palette menu and return to the main menu.
MakeSlide & Quit Commands

MakeSlide

MakeSlide allows you to transmit images to the MAGICorp slide service bureau for processing as high-quality 35mm slides, transparencies, prints, or black & white copies.

MAGICorp’s network of $250,000 Celco film recorders produce images with high resolution (no jagged edges), rich colors and typeset-quality fonts. You can transmit up to 99 images at one time. Your MAGICorp output comes back to you via overnight courier. In some cases, you can specify next day delivery. Prints and transparencies require an additional day for processing.

Before transmitting your images, you must have a MAGICorp customer site code. If your company or department does not already have one, call MAGICorp at the following number to obtain one:

1-800-FOR-MAGIC (1-800-367-6244)

Select MakeSlide to choose from these menu items:

- **SLIDELIST** Assemble a list of images to transmit
- **ORDERFORM** Prepare and send images to MAGICorp
- **QUIT** Return to the ImageBuilder main menu
SLIDELIST

SlideList allows you to assemble a list of picture and chart files to be sent to MAGICorp for processing. The Slide List appears on the right side of the MakeSlide display. It contains the images you select for transmission and shows the directory from which they came.

You can have up to 99 files in the Slide List. Press <PGUP> and <PGDN> to scroll the list.

Select SlideList to choose from these items:

- **ADD** Add picture and chart files to the Slide List
- **VIEWLIST** Scroll the Slide List to view all the files it contains
- **ERASE** Clear the the Slide List
- **CHANGEDIR** Change the current directory
- **QUIT** Return to the MakeSlide menu

Add

Add allows you to add up to 99 picture and chart files to the Slide List to be sent to MAGICorp for processing. The cursor appears in the list of picture and chart files on the left side of the MakeSlide display. Files you add to the Slide List appear on the right
side of the display, as shown in Figure 3-28. Use the arrow keys to move the cursor up, down and between the lists.

To preview a picture or chart file before adding it to the Slide List, place the cursor over the file name and press <F6>.

To add a file to the Slide List:

1. Select **Add**.

2. Select the name of a picture or chart file on the left side of the display.

3. Continue selecting files until you are done. Press <ESC> to return to the SlideList menu.

**NOTE:** To add the current picture or chart to the list, you must first save it by selecting **File/Save**.
ViewList

ViewList allows you to scroll the Slide List, in order to see picture and chart files not currently visible on the screen. The Slide List may contain up to 99 files.

To preview a picture or chart file in the Slide List, place the cursor over the file name and press <F6>.

To view the Slide List:

1. Select ViewList.
2. Use the arrow keys to move up and down the Slide List. Press <ESC> to return to the SlideList menu.

Erase

Erase allows you to clear the Slide List of picture and chart files. Select Erase to choose from these menu items:

- CANCEL Cancel the request to erase the Slide List
- CLEARLIST Erase all picture and chart files from the Slide List

To clear the Slide List:
1. Select **Erase**.

2. Select **Cancel** to return to the SlideList menu without erasing, or select **ClearList** to erase the Slide List.

**NOTE:** Erase does not affect the list of picture and chart files in the current directory on the left side of the display.

**ChangeDir**

*ChangeDir* allows you to change the current directory in order to add different picture and chart files to the Slide List. The new directory name and the files it contains appear on the left side of the display.

To change the current directory:

1. Select **ChangeDir**.

2. Do one of the following:

   - *If you see the name of the directory you want*

     Select the name. (The single dot (.) in the list of directory names is the current directory. The double dot (..) is the parent directory.)

   - *If you do not see the name of the directory*

     Select **NewDirectory**, then type the directory name, and press <**Return**>.
The name of the directory and the files it contains appear on the screen.

Quit

Select Quit to exit the SlideList menu and return to the MakeSlide menu.

ORDERFORM

OrderForm allows you to prepare your images for processing and to transmit them automatically to MAGICorp. OrderForm provides three forms for you to fill out before sending your images. SCO ImageBuilder saves some of the more standard customer and media information, so you may not have to enter it again.

Select OrderForm to choose from these items:

- CUSTOMER Enter customer mailing and billing information
- MEDIA Specify quantity, type, and format of media desired
- PRESENTATION Enter turnaround time, presentation name, and comments
- SEND Transmit images to MAGICorp
- QUIT Return to the MakeSlide menu
Customer

Customer allows you to enter customer mailing and billing information for MAGICorp. Customer information includes your name, department, company name, address, phone number, and site code. You only need to enter this information once.

To enter customer information:

1. Select Customer. A form appears on the screen. (To get Help on any field in the form: press <F1>.)

2. Fill out the form by typing the required information in each blank field, and pressing <Return>.

3. Press <ESC> to return to the Order Form menu.

Site Code

"Site code" identifies your company as a MAGICorp customer. If your company or department does not already have a site code, call MAGICorp to obtain one at: 1-800-FOR-MAGI (1-800-367-6244).

You will not be able to transmit images to MAGICorp until you have entered a site code in the "Site code" field. You only have to enter this information once.
To enter a site code:

1. Type your code in the "Site code" field.
2. Press <Return>.

Name & Address

You must enter customer mailing and billing information in the "Name," "Company," "Department," "Street," "City," "State," "Zip code" and "Phone number" fields before transmitting your images to MAGICorp. You only have to enter this information once.

To enter customer information:

1. Type the required information in each field.
2. Press <Return>.

Media

Media allows you to specify the number and format of slides, transparencies, color prints, or black & white copies you want processed from the images in the Slide List.

To enter media information:

1. Select Media. A form appears on the screen. (To get Help on any field in the form: press <F1>.)
2. Type the number of each type of media you want processed, and press <Return>.

3. Select a format choice for each type of media.

4. Press <ESC> to return to the OrderForm menu.

Number of Slides

"Number of slides" allows you to specify the number of 35mm slides you want made of the images in the Slide List.

For example, if you have five files in the list and you enter "2," the Total box tells you that you will receive a total of 10 slides.

To order slides from MAGICorp:

1. Type the number of slides you want in the box to the right of "Number of slides."

2. Press <Return>.

Number of Transparencies

"Number of transparencies" allows you to specify the number of overhead transparencies you want made of the images in the Slide List. (Allow one additional day for processing of transparencies.)
For example, if you have five files in the Slide List and you enter "1," the total box tells you that you will receive a total of 5 transparencies.

To order transparencies from MAGICorp:

1. Type the number of transparencies you want in the box to the right of "Number of transparencies."
2. Press <Return>.

Number of Prints

"Number of prints" allows you to specify the number of color prints (8 1/2 x 11 1/2") you want made of the images in the Slide List. (Allow one additional day for processing of prints.)

For example, if you have five files in the Slide List and you enter "2," the Total box tells you that you will receive a total of 10 prints.

To order prints from MAGICorp:

1. Type the number of prints you want in the box to the right of "Number of prints."
2. Press <Return>. 
Number of Black & Whites

"Number of black & whites" allows you to specify the number of black and white copies you want made of the images in the Slide List.

For example, if you have four files in the Slide List and you enter "2", the Total box tells you that you will receive a total of 8 black & white copies.

Black & whites can serve as a record of a slide presentation, or as hardcopy handouts or camera ready copy.

To order black & whites from MAGICorp:

1. Type the number of black & white copies you want in the box to the right of "Number of black & whites."

2. Press <Return>.

Slide Mounting

"Slide mounting" allows you to select a slide mounting (frame style). Move the cursor to the style you want, and press <Return>:

- Standard  Give slides a standard plastic frame
- Wess  Give slides a heat-resistant glass frame that protects them from warping from
repeated use in a slide projector
(good for frequently used slides)

- Unmounted Give slides no frame

Transparency Mounting

"Transparencies" allows you to select a transparency mounting (frame style). Move the cursor to the style you want, and press <Return>:

- Mounted Give transparencies a cardboard frame
- Unmounted Give transparencies no frame

Print Finish

"Print finish" allows you to select a print finish for your colored prints. Move the cursor to the finish you want, and press <Return>:

- Glossy Give prints a shiny surface
- Matte Give prints a flat, nonreflecting surface

Black & White Foreground

"Black & white foreground" allows you to select a drawing style for objects in your black & white copies. Move the cursor to the drawing style you want, and press <Return>: 

3-132
Patterns
Represent the colors of objects as patterns

Black
Represent the colors of objects as black
(good selection for text charts)

Black & White Header

"Black & white header" gives you the option of adding a header to your black & white copies. Headers consist of the name of your picture or chart, your site code, and the presentation name (if you have one).

To add or remove headers from your black & whites, move the cursor to one of these choices, and press <Return>:

- Not Printed
  Omit a header on black & white copies

- Printed
  Print a header on black & white copies

Presentation

Presentation allows you to enter information about your presentation and to specify a turnaround time.

To enter presentation information:

1. Select Presentation. A form appears on the screen. (To get Help on any field in the form: press <F1>.)

2. Select a turnaround-time priority.

3. Enter a presentation name and comments (optional).
4. Press <ESC> to return to the Order Form menu.

Priority

"Priority" allows you to select a turnaround-time priority for the processing and delivery of your order.

To select a priority, move the cursor to one of the following choices, and press <Return>:

- **Normal**
  Orders received by MAGICorp any business day are shipped to you the next day by overnight courier

- **Rush**
  Orders received by MAGICorp by 9:00 a.m. (EST) any business day are shipped to you the same day by overnight courier

**NOTE:** Transparencies and color prints require an additional day for processing.

Presentation Name

"Presentation name" allows you to enter an optional name for your presentation. The presentation name appears on the work-order summary sheet you receive with your returned order.
To enter a presentation name:

1. Type a name (up to 15 characters) in the "Presentation name" field.
2. Press < Return >.

Comments

"Comments" allows you to enter optional comments to communicate requests to MAGICorp or make notes to yourself. MAGICorp reads your comments before processing your order. Comments appear on the work-order summary sheet when your order is returned.

To enter comments:

1. Type a line of text (up to 40 characters) on the first "Comments" line.
2. Press < Return >.

You can enter up to three lines of comments.

Send

Send allows you to transmit the images in the Slide List to MAGICorp for processing.

To send your images:
1. Select Send. The total number of each media you have ordered appears on the screen for your reference. Check to be sure this is the correct number of slides, transparencies, prints, and/or black & white copies you want to receive from MAGICorp.

2. Select Yes to transmit the images, or No to return to the OrderForm menu without transmitting.

Quit

Select Quit to exit the OrderForm menu and return to the Make-Slide menu.

QUIT

Select Quit to exit the MakeSlide menu and return to the SCO ImageBuilder main menu.

QUIT or RETURNTOPRO

Quit allows you to exit SCO ImageBuilder.

If you entered the program from SCO Professional, you can instantly select ReturnTo Pro by pressing \(<F10>\). (The cursor must be in a menu when you press \(<F10>\).) You return to SCO Professional.

If you entered the program from the operating system, press \(<\text{ESC}>\) or select Quit until you return to the main menu. Select
Quit from the main menu. You are presented with two choices:

- **RESUMEPGRAM**
  Cancel the request to exit the program

- **QUIT PROGRAM**
  Exit SCO ImageBuilder

To exit the program:

1. Select Quit. (If your picture or chart is unsaved, you receive a warning message. Press <ESC> to continue.)

2. Select QuitProgram to leave the program, or ResumeProgram to return to the SCO ImageBuilder main menu.
Replace this Page with Tab Marked:

Appendix A
Keys
APPENDIX A: SCO ImageBuilder Keys

The following keys perform the functions described below:

< Return >
Select highlighted commands or options on the menu line, fields in a display, and objects in the Draw graphics area. Complete some actions.

<BKSP>
Undo the last action. Erase text to the left of the cursor, one character at a time.

<ESC>
Return to a menu one level above the current menu. Leave the online Help system. Complete some actions in the graphics area.

<ARROW KEYS>
Move the cursor to a menu command or option on the menu line, to a field in a display, or to a different location in the Draw graphics area.

→ <RIGHT> Move the cursor to the right.

← <LEFT> Move the cursor to the left.

↑ <UP> Move the cursor up.

↓ <DOWN> Move the cursor down.
<Shift> <Arrow Keys>
Move the cursor very small steps in the Draw graphics area.

<?>
Get Help on any highlighted command or option.

<!>
Perform a Shell Escape to temporarily leave SCO ImageBuilder and return to the operating system. (Type "exit" and press <Return> to reenter the program.)

<Space Bar>
Interrupt redrawing of the graphics area. Erase a value or label in the Data display.

<PGUP>
Move the cursor diagonally (up and right) in the Draw graphics area. Go to the previous page of Help. Scroll up some lists.

<PGDN>
Move the cursor diagonally (down and right) in the Draw graphics area. Go to the next page of Help. Scroll down some lists.

<Home>
Move the cursor diagonally (up and left) in the Draw graphics area. Go to the first command, option, or field in a display or list.

<End>
Move the cursor diagonally (down and left) in the Draw graphics area. Go to the last command, option, or field in a display or list.
< Shift > < Numeric Pad 5 >
Center the cursor in the Draw graphics area.

**Function Keys**

(If your keyboard does not have function keys, you can perform the functions by typing: < Ctrl > < F > < 1-2-3-4-5-6-7-8-9 or 0. >)

**< F1 > (HELP)**
Get Help on any command or option on the menu line, or field in a display.

**< F2 > (MOUSE)**
Turn on a mouse or tablet attached to your computer. Turn off the mouse or tablet.

**< F3 > (INSERT)**
Insert a value or label in a data set.

**< F4 > (DELETE)**
Delete a value or label in the Data display to shorten a data set.
Delete a text character as you enter text.

**< F5 > (AUTOMATIC REDRAW)**
Automatically redraw the screen each time you modify an object in the Draw graphics area. Turn off the automatic redraw function.

**< F6 > (PREVIEW)**
Preview picture or chart file listed in the MakeSlide or File displays.
<F9> (REDRAW)
Redraw the screen.

<F10> (QUICK EXIT)
Quickly exit SCO ImageBuilder, if you entered SCO ImageBuilder from SCO Professional.
Replace this Page with Tab Marked:

Appendix B
Messages
APPENDIX B: Messages

SCO ImageBuilder’s messages appear on the prompt line if you inadvertently make an error while operating the program. The following is an alphabetical list of messages that may require explanation:

**Cannot create file**

Either you have run out of disk space, or the file exists and is a "read only" file, or you have a directory by the same name.

**Cannot delete file**

This file cannot be removed, because you have a directory of the same name, or the file is write protected by the operating system.

**Cannot modify options of a symbol**

You cannot change the options of objects that have been grouped into a symbol. You must undo the symbol first. To undo a symbol, select **Draw/Modify/Group/UndoSymbol**.

**Cannot warp text**

You cannot stretch lines of text or a symbol that contains only text.
Current picture is too complex to add picture

Either the current picture or the picture you are attempting to add is too complex to be combined with another picture.

Directory not found

Check to make sure this directory exists, and is on the expected drive. You may have misspelled the directory name.

GRAPHICS ERROR: No graphic support for display, CGI Error #

For some reason, CGI graphics support is not properly set up. For more information on how to correct this situation, look up the error number you see on the prompt line in the CGI manual.

Invalid file format

This file is not the correct type of file for this action, or it is damaged.

INNVOCATION ERROR: IBPATH variable not set

You are not starting the program correctly. Follow the instructions for starting the program in the section, "Setting Up and Starting the Program" in Part One: Introduction.
No files found

There are no files of the desired type in the designated directory.

Not the same type of object

The object you selected was not the same type as the last object you changed, so no change occurred. Select another object of the same type for the same change, or change options for a different type of object by pressing <ESC> two times, and selecting a different type of object.

Output device not ready

Check to make sure that your output device is connected to your computer, and that it is turned on. Refer to the Release and Installation Notes that came with the SCO ImageBuilder User's Guide, or contact your system administrator for instructions on setting up your device.

SERIALIZATION ERROR: Invalid serial number

The program you installed does not have a valid serial number. Contact your system administrator.

Symbol too complex to undo action

The rotate, move, scale, or warp action you just tried to undo cannot be accomplished because the symbol is too complex. Simply press
<ESC> and reselect the object to rotate, move, scale, or warp again.

Visibility is turned off for this data set

Changes you make to this data set will not appear in the Chart, because visibility is turned off. To make the data set visible in the chart, select Draw/Options/Visibility.
Replace this Page with Tab Marked:

Appendix C
Command Structure
APPENDIX C: SCO ImageBuilder Menu

**Draw**
see page C-2

**Chart**
see page C-3

**Background**
Solid
Shaded

**Palette**
Get
Change
  DesignAColor
RGB
HSI
Save
Delete
Quit

**MakeSlide**
SlideList
Add
ViewList
Erase
ChangeDir
Quit
OrderForm
Customer
Media
Presentation
Send
Quit
Quit

Quit or
ReturnTo-
Pro
QuitProgram
Resume-
Program
DRAW Commands

Create
Text
Line
Box
Circle
Polygon
Options
Text
Color
Font
Height
Justify
Quit
Lines
Color
Pattern
Arrows
Smoothing
Width
Quit
Shapes
BorderColor
InteriorColor
Pattern
Quit
Modify
Alter
ObjectOptions
Wording
Quit
Copy
Rotate
Move
Scale
Warp
Delete
Group
InBox
Object
UndoSymbol
Quit
Order
Front
Back
Quit
Quit
Print
Paste
Remove
Quit
File
Get
Add
Save
Delete
ChangeDir
Library
Quit
Zoom
FullSize
Magnify
Pan
Quit
AddChart
Add
Replace
Quit
Transfer
Copy
Quit
Appendix C

CHART
Commands

Data
DataEntry
Calendar
EraseData
Quit

ChartType
VerticalBar
Line
ScatterPlot
Area
Mixed
HorizontalBar
Pie
Quit

Options
(Pie)
Color
Explode
Pattern
Quit

(Bar/Area/Line)
Font
Color
Pattern
Delete
Visibility
Quit
XAxis
(ScatterPlot)
Enter
Font
Color
MarkerStyle
Delete
Visibility
Quit

(Mixed)
YAxis
Color
DataSetType
Delete
Pattern
Quit

Layout
Titles
Main
Enter
Font
Color
Quit
Subtitle
Delete
Enter

AutoScale
Scale
Grid
Quit
YAxis
AutoScale
Scale
Precision
  NoDecimals
  OneDecimal
  TwoDecimals
  Dollars
Grid
Quit

Legend
  LegendOff
  LegendInside
  LegendOutside
Stack
Quit

Output

File
  Get
  Save
  Delete
  ChangeDir
  ImportWKS
Quit

Erase

Transfer
  Copy
  Paste
  Remove
Quit

Print
  Preview

C-4
Replace this Page with Tab Marked:

Appendix D
Symbol Library
APPENDIX D: Symbol Library

A symbol library is a collection of pre-drawn clip art, including maps, men, women, buildings and objects. SCO ImageBuilder comes with a library of symbols you can incorporate into your pictures and charts to add variety and interest.

To access the symbol library, you must be in the Draw menu. Once you add a symbol to the Draw graphics area, you may change it with the Modify commands. You can copy, rotate, move, scale or warp the symbol as a whole unit. You can also undo the symbol and edit the options of its individual objects.

To add a symbol to the Draw graphics area:

1. Select File.

2. Select Library. The names of symbols in the library appear on the screen. (To preview a symbol, press <F6>.)

3. Select the name of a symbol.

NOTE: You cannot save symbols to or delete symbols from the symbol library.
<table>
<thead>
<tr>
<th>Apple</th>
<th>Arrow-L1</th>
<th>Arrow-L2</th>
<th>Arrow-R1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow-R2</td>
<td>Atom</td>
<td>Audience</td>
<td>Basketball</td>
</tr>
<tr>
<td>Beer</td>
<td>Bread</td>
<td>Buildings1</td>
<td>Buildings2</td>
</tr>
<tr>
<td>Building3</td>
<td>Butler</td>
<td>Candybox</td>
<td>Champagne</td>
</tr>
<tr>
<td>Cheese</td>
<td>Cityscape</td>
<td>Copyright</td>
<td>Cosmetic</td>
</tr>
<tr>
<td>----------</td>
<td>-----------</td>
<td>-----------</td>
<td>----------</td>
</tr>
<tr>
<td>Derrick</td>
<td>Dynamite1</td>
<td>Dynamite2</td>
<td>Eagle</td>
</tr>
<tr>
<td>ElectTrans</td>
<td>Envelope</td>
<td>EnvelPen</td>
<td>Floppy</td>
</tr>
<tr>
<td>Flower</td>
<td>Football</td>
<td>Fries</td>
<td>GasPump</td>
</tr>
<tr>
<td>GlassIce</td>
<td>Hamburger</td>
<td>Handshake</td>
<td>Hat</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------</td>
<td>-----------</td>
<td>--------------</td>
</tr>
<tr>
<td>Helicopter</td>
<td>HeSells</td>
<td>Host</td>
<td>House</td>
</tr>
<tr>
<td>LadyShoe</td>
<td>LeafTree</td>
<td>LightBulb</td>
<td>Mainframe</td>
</tr>
<tr>
<td>Man1</td>
<td>Man2</td>
<td>Man3</td>
<td>Map-Africa</td>
</tr>
<tr>
<td>Map-Africa2</td>
<td>Map-Austr1</td>
<td>Map-Austr2</td>
<td>Map-Europe1</td>
</tr>
<tr>
<td>------------</td>
<td>------------</td>
<td>------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Map-Europe2</td>
<td>Map-Japan1</td>
<td>Map-Japan2</td>
<td>Map-USA1</td>
</tr>
<tr>
<td>Map-USA2</td>
<td>Map-USA3</td>
<td>Map-USA4</td>
<td>Map-World1</td>
</tr>
<tr>
<td>Map-World2</td>
<td>Medical</td>
<td>MeetPress</td>
<td>Microphone</td>
</tr>
<tr>
<td>Money</td>
<td>NoSmoke</td>
<td>NoSymbol</td>
<td>Office</td>
</tr>
<tr>
<td>---------</td>
<td>-----------</td>
<td>----------</td>
<td>-----------------</td>
</tr>
<tr>
<td>OilDrum</td>
<td>Pencil</td>
<td>PineTree</td>
<td>Plane</td>
</tr>
<tr>
<td>Pointer</td>
<td>Policeman</td>
<td>Rabbit</td>
<td>RegTrade</td>
</tr>
<tr>
<td>Safe</td>
<td>Ship1</td>
<td>Ship2</td>
<td>Ship3</td>
</tr>
<tr>
<td>Shoe</td>
<td>Signal</td>
<td>Small Town</td>
<td>Sock</td>
</tr>
<tr>
<td>--------</td>
<td>--------</td>
<td>------------</td>
<td>--------</td>
</tr>
<tr>
<td><img src="image1" alt="Shoe" /></td>
<td><img src="image2" alt="Signal" /></td>
<td><img src="image3" alt="Small Town" /></td>
<td><img src="image4" alt="Sock" /></td>
</tr>
<tr>
<td>Softball</td>
<td>Star 1</td>
<td>Star 2</td>
<td>Star 3</td>
</tr>
<tr>
<td><img src="image5" alt="Softball" /></td>
<td><img src="image6" alt="Star 1" /></td>
<td><img src="image7" alt="Star 2" /></td>
<td><img src="image8" alt="Star 3" /></td>
</tr>
<tr>
<td>Star 4</td>
<td>Star 5</td>
<td>Star 6</td>
<td>Star 7</td>
</tr>
<tr>
<td><img src="image9" alt="Star 4" /></td>
<td><img src="image10" alt="Star 5" /></td>
<td><img src="image11" alt="Star 6" /></td>
<td><img src="image12" alt="Star 7" /></td>
</tr>
<tr>
<td>Star 8</td>
<td>Star 9</td>
<td>Star 10</td>
<td>Star 11</td>
</tr>
<tr>
<td><img src="image13" alt="Star 8" /></td>
<td><img src="image14" alt="Star 9" /></td>
<td><img src="image15" alt="Star 10" /></td>
<td><img src="image16" alt="Star 11" /></td>
</tr>
<tr>
<td>Star12</td>
<td>Sweater</td>
<td>System</td>
<td>Tickets</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td>Trademark</td>
<td>Truck</td>
<td>Typewriter</td>
<td>UncleSam</td>
</tr>
<tr>
<td>Woman1</td>
<td>Woman2</td>
<td>Woman3</td>
<td>Woman4</td>
</tr>
<tr>
<td>Woman5</td>
<td>Woman6</td>
<td>Writing</td>
<td>Yen</td>
</tr>
</tbody>
</table>
Replace this Page with Tab Marked:

Index
INDEX

A

Add
  AddChart  3-50, 3-58, 3-122
AddChart  3-56
Adding
  a chart  3-50
  a color to a palette  3-117
  a picture  3-58
Alter  3-30
Area chart  3-71
Area patterns  3-81
Arrows  3-21
Automatic redraw  2-16
AutoScale  3-93
Axis precision  3-95

B

Background  3-1, 3-107
  solid  3-107
  gradated  3-108
Bar chart
  horizontal  3-73
  vertical  3-68
B&W foreground  3-132
B&W header  3-133
BorderColor  3-25
Box  3-10
  options  3-10

C

Calendar  3-65
Change  3-111
ChangeDir  3-52, 3-105, 3-125
Changing
  a background  3-107
  a color's hue  3-114
  a color's intensity  3-116
  a color's saturation  3-115
  chart type  3-66
  directories  3-52, 3-105, 3-125
  options
    (for new objects)  3-76
    options
    (for existing objects)  3-31
  palette colors  3-111
  palettes  3-109
  text  3-32
Chart  3-1, 3-61
  definition  3-61
  graphics area  3-61
  menu  3-62
  options  3-76
  titles  3-85
Chart commands  3-61
Charts
  See Data charts
ChartType  3-66
Circle  3-11
Clipboard  3-99
### SCO ImageBuilder User's Guide

<table>
<thead>
<tr>
<th>Color</th>
<th>3-77, 3-107, 3-114</th>
</tr>
</thead>
<tbody>
<tr>
<td>for data charts</td>
<td>1-9</td>
</tr>
<tr>
<td>for text charts</td>
<td>1-7</td>
</tr>
<tr>
<td>HSI</td>
<td>3-119</td>
</tr>
<tr>
<td>line</td>
<td>3-20</td>
</tr>
<tr>
<td>methods for creating mixing</td>
<td>3-111</td>
</tr>
<tr>
<td>on devices</td>
<td>3-109</td>
</tr>
<tr>
<td>palettes</td>
<td>3-109</td>
</tr>
<tr>
<td>RGB</td>
<td>3-118</td>
</tr>
<tr>
<td>text</td>
<td>3-15</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Color prints</th>
</tr>
</thead>
<tbody>
<tr>
<td>See Prints</td>
</tr>
</tbody>
</table>

| Combining data charts | 3-59 |
| pictures | 3-50 |

| Command definition | 1-10 |
| selecting | 1-13 |

| Comments | 3-135 |
| Copy | 3-33, 3-44, 3-99 |
| Create | 3-5 |
| Current chart | 3-61 |
| Current picture | 3-3 |
| Cursor keys | 1-15 |
| moving in Draw | 1-12 |
| on menu line | 1-13 |
| Customer | 3-127 |

### D

| Data entering | 3-64 |
| Data charts | 1-7 |
| Data | 3-63 |

| Deleting a chart | 3-104 |
| a picture | 3-43 |
| a Clipboard item | 3-100 |
| color palettes | 3-120 |
| data values | 3-65 |
| key | 1-17 |

| Data entry | 3-64 |
| Data set | 3-63 |
| Data display | 3-63 |
| erasing | 3-66 |
| Data Entry | 3-64 |
| DataSetType | 3-82 |
| Delete | 3-52, 3-90, 3-104 |

| tutorial | 2-8 |

| Data entry | 3-64 |
| Data set | 3-63 |
| Data display | 3-63 |
| erasing | 3-66 |
| Data entry | 3-64 |
| Data set | 3-63 |
| Data display | 3-63 |
| erasing | 3-66 |
palettes 3-120
titles 3-90
DesignAColor 3-113
Draw 3-3
Drawing commands 3-4

G
Get 3-48, 3-103, 3-110
Getting
a chart 3-103
a palette 3-110
a picture 3-48
Graphics 1-1
good data charts 1-7
good text charts 1-5
tips 1-4
Graphics area 1-11
erasing Draw 3-43
erasing Chart 3-98
moving the cursor 1-12
Grid 3-94
Group 3-37

H
Height 3-17
Help
getting 1-18
key 1-17
HorizontalBar chart 3-73
HSI 3-118
Hue 3-114

I
ImportWKS 3-106
InBox 3-38
### Inserting
- **data values**: 3-65
- **key**: 1-17
- **Intensity**: 3-116
- **InteriorColor**: 3-25

### J
- **Justify**: 3-18

### K
- **Keyboard**
  - **function keys**: A-3
  - **key table**: 1-1, A-1
  - **using keyboard**: 1-14

### L
- **Layout**: 3-83
  - of data charts: 1-8
  - of text charts: 1-6
- **Legend**
  - **labels**: 3-65
- **Library of symbols**: D-1
- **Line**: 3-8
- **Line chart**
  - **options**: 3-9, 3-20
- **Line patterns**: 3-80
- **Lines**: 3-19

### M
- **MAGICorp**
  - customer info: 3-127
  - media info: 3-128
  - order forms: 3-126
  - site code: 3-127
  - transmitting files: 3-135
  - turn-around time: 3-134
  - tutorial lesson: 2-18
- **Magnify**: 3-55
- **Main**: 3-86
- **Main menu**: 3-1
- **MakeSlide**: 3-2, 3-121
- **Making presentations**: 1-4
- **Making slides**: 3-121
  - tutorial lesson: 2-18
- **Making transparencies**: 3-121
- **Managing files**: 3-47
- **MarkerStyle**: 3-82
- **Media**: 3-128
  - Choosing a medium: 1-1
- **Menu**
  - main: 3-1
  - selecting from: 1-13
  - selecting options: 1-13
  - structure: C-1
- **Menu line**: 1-11
- **Messages**: B-1
- **Mixed chart**: 3-72
- **Modify**: 3-28
- **Modifying palettes**: 3-111
- **Mouse**
  - buttons: 1-18

---

I-4
key 1-17
Move 3-35
Moving the cursor 1-12
Name & address 3-128
Number of black & whites 3-131
Number of prints 3-130
Number of slides 3-129
Number of transparencies 3-129

P

Palette 3-1, 3-109
adding a color 3-117
changing a color 3-111
definition 3-109
Pan 3-56
Paper output 1-2
Paste 3-45, 3-100
Pattern 3-21, 3-26, 3-80
Picture 3-3
combining 3-50
deleting a file 3-52
getting 3-48
saving 3-51
zooming 3-54
Pie chart 3-75
Pie slice 3-13
changing options for 3-76
exploding 3-78
Pie slice labels 3-64
Plotter output 1-2, 3-46, 3-102
background color 3-107
Polygon 3-12
options 3-13
Precision 3-94
Presentation 3-133
SCO ImageBuilder User’s Guide

Presentation name 3-134
Presentations
  transparencies 1-3
  paper handouts 1-2
tips 1-4
35mm slides 1-2
using MAGICorp 3-121
Preview 3-46, 3-102
Printer output 1-1, 3-46, 3-101
  background color 3-107
Prints
  finish 3-132
  number to order 3-130
Priority 3-134
Prompt line 1-11

Q
Quit 3-2, 3-107, 3-136
Quitting the program 3-136

R
Remove 3-100
Reordering objects 3-41
RGB 3-117
Rotate 3-34

S
Saturation 3-115
Save 3-51, 3-105, 3-119

Saving
  a chart 3-104
  a palette 3-119
  a picture 3-51
Scale 3-35, 3-92
Scaling an axis 3-92
ScatterPlot chart 3-70
SCO FoxBASE 1-8, 3-64
SCO ImageBuilder
  chart types 3-66
  data charts 1-7
  error messages B-1
  keys A-1, 1-1
  main menu 3-1
  menu structure C-1
  purpose of 1-1
  screen 1-10
  starting the program 1-10
  tutorial 2-1
  using the program 1-9
SCO Professional 1-8, 3-64
Scrolling
  keys 1-16
  options menus 1-13
Selecting
  a command 1-13
  an option 1-13
Send 3-135
Shaded background 3-108
Shapes 3-24
Shell escape 1-15
Site code 3-127
Slide list
  assembling 3-122
  erasing 3-124
SlideList 3-122
Slide mounting 3-131

I-6
Index

Smoothing 3-22  in presentations 1-3
Solid 3-107  mounting 3-131
Solid background 3-107  number to order 3-129
Stack 3-98  using slide service 3-121
Starting the program 1-10  Transparency mounting 3-132
Subtitle 3-86  Tutorial 2-1
Symbol
  chart symbol 3-59  U
  creating 3-38 - 3-39
  definition 3-37
  library D-1
  undoing 3-39
Using the program 1-9

T

Tablet
  buttons 1-18
  key 1-17
Template library D-1
Text
  command 3-7
  justification 3-19
  options 3-8
Text charts 1-5
  creating good ones 1-5
  margins 1-5
  tutorial lesson 2-2
35mm Slides
  mounting 3-131
  number to order 3-129
  presentations 1-2
  using slide service 3-121
Titles 3-85
Transfer 3-43, 3-99
Transparencies

W

Values 3-64
VerticalBar chart 3-68
ViewList 3-124
Visibility 3-79

Warp 3-36
Width 3-23
Wording 3-32

X

XAxis 3-87, 3-90
  scaling 3-92
  title 3-87
  X-axis labels
inserting  3-65
monthly   3-65

Y

Y Axis  3-87, 3-91
label precision  3-94
scaling      3-92
title        3-87

Z

Zoom  3-54